Jump to content

Problem writing to user shares (SOLVED)


kno

Recommended Posts

I need some help with my Unraid setup.


I am having problems writing files to my Unraid server. When I try to write files to it I get an error message that I do not have access rights to do so. My problems started a while back when I created a user and made some of the shares private. I gave the user read/write access. I am running newest version of Unraid, but started to mess about with the users a couple of weeks ago. I was on some version og 5 back then. I do not know on what version I created the server. Probably late version 4. I have never had any access problems before I created users. Previously I did not have any root password or users. I was looking to upgrade my security, but now I regret having ever touched them.

 

I have tried searching the forums, the wiki and the net for solutions but nothing seems to work. I have tried the following:
-Removing the user and setting the shares to public
-Updating Unraid to the newest version
-Running New Permissions under tools
-Running Docker Safe New Perms under tools
-Changing user name and password to the same as Windows 10 user name/password as per:

https://forums.lime-technology.com/topic/54454-unraid-os-version-630-stable-release-available/?do=findComment&comment=532202
https://wiki.lime-technology.com/Plugin/webGui/SMB

-It seems that when I restart everything I am able to write one or two files to the Unraid server before my access is blocked, although I cannot say if this is consistent or folder dependent. Once file transer is blocked I cannot transfer any files to any folder any user share.

 

Also, is there a way to restore the system to no users & security as per a new server?

 

I am not an advanced user, so I have only used the webgui.

 

 

So, do you have any suggestions to what might help? What information do you need?

 

Hope somebody can help...



 

Link to comment

I did some more studying. Accessed Unraid with telnet and ran MC.

 

The files I was able to write to the server just after rebooting have the following properties:
Owner: root/root/ 
Size: 0
Mode: -rw-rw-rw- (0666)

 

Most folders:
Owner: nobody/users
Mode: drwxrwxrwx (0777)

 

Most files:
Owner: nobody/users
Mode: -rw-rw-rw- (0666)

 

Some folders have:
Owner: “my username”/users
Mode: drwxrwxrwx (0777)

 

Some files have:
Owner: “my username”/users
Mode: -rw-rw-rw- (0666)

 

So, I am trying to figure out what is going on. My knowledge about the subject is limited.

 

From my point it view it looks like Unraid for some reason is connecting me as the root user. However the root user does not have any rights to write to the user shares.

 

How can this happen and how can I undo it? I have tried access from two different windows 10 computers. I have the same problem on both, so I think that it is an Unraid problem.

 

What do you think?
 

Link to comment

So I ran the new permissions and it seems I can write to most of my folders now, however there is one specific folder that might be the cause for my problems.

 

When I try to write a file to this specific folder (it is inside one of my user shares) my permission are now denied. My permission to write to any other folder is now also denied, even those folders that worked before I tried to write to this specific folder.

 

I cannot see any difference from Telnet/MC for this specific folder compared to the others.

 

Whan can be the cause of this problem? Any suggestions on how to fix it?

Link to comment

I suspect that a disk in the share has some file system corruption and when you attempt to write to an area which is corrupted the OS is changing the disk to read only to prevent further corruption.

 

i would suggest you post your system diagnotics ( Tools -> Diagnostics ) and I'm sure someone will be able to confirm whether this is the case and advise on how to fix it.

Link to comment
  • 2 weeks later...

Sorry for the delayed response to this post.

 

I created two sets of anonymized diagnostics.

 

One is before I provoked the error and one after. I have posted both syslog’s.

 

Here you can clearly see that some error is provoked and that the system becomes read only afterwards. Look at the last bit of the syslog_after_error.txt


How can I fix this error? Do you have any suggestions?


 

 

 

Link to comment
  • 1 month later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...