Jump to content
sonofdbn

MinimServer docker problem

27 posts in this topic Last Reply

Recommended Posts

MinimServer is a UPnP music server; I'm trying to install a MinimServer docker (https://hub.docker.com/r/tromatik/docker-minimserver/). I haven't done a "manual" docker install before, but after a bit of reading I managed to download it via the CA tab and fiddled around mapping paths and ports, and in particular setting Network Type to "Bridge". Somewhat to my surprise (and a testimony to the amount of information available here), I managed to get MinimServer running. It required going to MinimServer's http page and accepting a licence agreement, but after that it seemed to be OK, as its web ui said it was running (and the log showed this as well). The problem was that I couldn't access it from any PC on my network.

 

MinimServer is controlled via MinimWatch, which can be installed on a Windows PC. I installed it, and it had no problem finding a MinimServer test server that I was running on a Synology NAS. But I couldn't get it to find the docker MinimServer. (I tried shutting down the Syno server and reinstalled MinimWatch, but that didn't help.)

 

I'm wondering if the problem is with UPnP (which I know very little about) and whether it somehow needs to be enabled on unRAID. I read a thread here on the Logitech Media Server docker which mentioned a similar-sounding UPnP problem. It was suggested there that Bridge mode should be used for Network Type, so I tried that, but it seems to remove (or not require) any port mapping then. So I think I misunderstood what is required. Is something else required in order to enable UPnP? (And is that the likely problem?)

Share this post


Link to post

Good morning sonofdbn, here is a discussion that you might find useful: http://forum.minimserver.com/showthread.php?tid=4156

 

I followed these steps as provided by Simon:

  1. Create a folder to be used for building the Docker image (I used /mnt/user/system/docker/appdata/minimserver)
  2. Download the file MinimServer-0.8.4.7-linux-intel.tar.gz from this page and save it in this folder
  3. Download the file Dockerfile.bin from this link, save it in this folder and rename it to Dockerfile
  4. In a terminal window, change directory to this folder and run the following commands:
docker build -t minimserver:0.8.4.7 .
docker run -p:1900:1900/udp -p:9790:9790 -p:9791:9791 --net=host minimserver:0.8.4.7

This should start MinimServer in a Docker container. Issue is the following:

docker run -p:1900:1900/udp -p:9790:9790 -p:9791:9791 --net=host minimserver:0.8.4.7
MinimServer 0.8.4.7, Copyright © 2012-2017 Simon Nash. All rights reserved.
autoUpdate: installed package 'minimserver-0.8-update-104'
autoUpdate: relaunching
MinimServer 0.8.4.7 update 104, Copyright © 2012-2017 Simon Nash. All rights reserved.
MinimServer: ohNet port 9791 is already in use
MinimServer: startup error (see crash file for stack trace)

The discussion is kind of stuck since Sep. 7th.

 

There might be some Docker experts here who can help or having any great idea?

Edited by EdgarWallace

Share this post


Link to post

Good morning, here is how I implemented by using one of the Dockerhub (this is copy & paste of post #38 of the MinimServer Forum link I posted above. : https://hub.docker.com/r/tromatik/docker-minimserver/

1.) You need to accept Dockerhub in CA
2.) Install the Docker from above
3.) Modify settings and add one Host Path
4.) Starting your new Docker and open the log in order to accept Terms & Conditions
Done

 

However, this version is not officially supported by Simon but his official guide doesn‘t provide a solution that is surviving a reboot.

Share this post


Link to post

Thanks for sharing. For whatever reasons, Simon didn't appreciate this solution and hinted it may stop working?

 

Anyhow, I like it and may be a good solution for me as well. Can you share a bit more how you have done it. The four steps above read easy, but not clear to me where to do what. Thanks!

Share this post


Link to post

Have you installed the Community Apps? That is a prerequesite.

 

Please check the screen shot of the Docker settings. That should answer your remaining questions if you are a bit familiar with the unRAID Docker environment. Good luck!!

minim.jpg

Share this post


Link to post

Wow, I haven't been keeping track of this, and now things have moved on so much. Thanks so much, EdgarWallace. I've successfully installed the docker following your instructions. A wonderful Christmas present!

 

Er, of course now I want more... I've installed Minimstreamer as well, as I normally use this to convert flac to wav24. But to do this I also need to install ffmpeg, presumably somewhere where Minimstreamer can find it. Any idea how this can be done?

Share this post


Link to post

Well, I did some digging around and I came up with an inelegant way of putting ffmpeg into the container. My Linux skills are very limited, so I googled around and also read the Minimserver documentation about the stream converter (in my case ffmpeg) here.

 

The first thing was to get a command prompt in the container. I opened a TTY window on my Windows PC and logged on to the unRAID server. Then I got into the docker container by using

docker exec -it docker-minimserver /bin/bash

I hunted a bit and found the minimserver directory under /opt. Under that minimserver directory is another opt directory, and I think I had to create the bin sub-directory under that. So that gave me the opt/bin directory I had to put ffmpeg in (/opt/minimserver/opt/bin).

 

Next, I had to get ffmpeg, and found a static build here. I used the x86_64 build; initially I wasn't sure how to get it into the container, but since I had already mapped the /media folder to my music folder, I just needed to get ffmpeg into the music folder. So I downloaded the package ffmpeg-git-64bit-static.tar.xz and unzipped it (used 7-Zip) then copied ffmpeg into the music folder. Then in the terminal window I copied ffmpeg from the /media folder into /opt/minimserver/opt/bin. (I  actually took a longer route, but this is the gist of what worked.)

 

After that I opened the properties window from Minimwatch, went to System and entered ffmpeg for stream.converter and clicked Apply, and Minimserver found it (it appears as opt/bin/ffmpeg in my case) and now I'm happily transcoding flac to wav24.

 

I'm not sure if Minimserver needs to be restarted for it to see the ffmpeg, and when I first tried, it didn't appear to find ffmpeg but after a few seconds I think the error message saying Minimserver couldn't find ffmpeg disappeared.

 

No doubt there is a better way of doing this (and I'm not sure if this will survive a restart), but I'm happy it's working. Now I can shutdown my Linux Mint VM which I used only to run Minimserver. 

Share this post


Link to post

Great that you sorted it out.

 

The remaining issue is that this Docker contains an old version of Minimserver so let‘s hope that this Docker is going to be updated. 

Share this post


Link to post

Thanks @EdgarWallace. This is indeed very clear and I should be able to build the docker from the screenshot above. Big thanks!

 

Shouldn't it be possible to update Minimserver from within the docker? Will this break things?

Share this post


Link to post

Any thoughts on whether it is possible to update Minimserver from within the docker? Or other updates for a more up to date version?

Share this post


Link to post

I just changed the Repository towards: nielsdb97/docker-minimserver

 

This is a fork of the previous docker an is updated to the most recent version of MinimServer. All other Docker definitions can be kept.

Share this post


Link to post

Wow, cool, you rock! This is great!

 

Just made an attempt to install the new fork "fresh". Unfortunately, not successful.

 

Do I need to manually set the host ports 1 and 2 and the host path. I don't mean the content of it, but the actual "rows"/"fields" don't show in the template? Also, your screenshot shows the network type as host and I assume I can set it to bridge instead?

Share this post


Link to post

Thanks for your quick reply. I have followed instructions and download has started. Unfortunately, it doesn't complete and shows: Error: unauthorized: authentication required

Share this post


Link to post

Awesome.  I'm going to have to try this out.  It's pretty much the only reason I keep my DS1513+ is minimserver.

But if I can run it on unraid that would be groovy. lol

Share this post


Link to post

Thanks. I haven't reached the stage yet to start it, but was only installing the actual docker. Unless it auto-started?

 

Will check the logs on the weekend. How to access minimwatch and where can I accept the T&C?

Share this post


Link to post

MinimWatch is available here, available for all kind of operating systems: LINK

I am running it on my macOS machine so that I am having full control over my music library.

Share this post


Link to post

so i need minim watch to use the docker as i otherwise can not agree with the gt&c


Sent from my iPhone using Tapatalk

Share this post


Link to post

Thanks all for this info. I managed to build this docker and set the media path to /mnt/user/Music, which is where my music is located. However the minimwatch icon turns red and I get a message that no content directory is found.

Share this post


Link to post

Have people managed to get this working? Is there a simpler way to do it for a newbie?

Share this post


Link to post

Bumping this. Has anyone tried this and is it working? Have there been updates to the latest minim version?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.