Jump to content
Djoss

[Support] Djoss - JDownloader 2

194 posts in this topic Last Reply

Recommended Posts

Should we ever update Jdownloader through the program itself or should we ONLY ever update it through the docker? I'm just curious since I'm waiting for Jdownlaoder to fix this Katfile issue.

Share this post


Link to post
55 minutes ago, severanced said:

Should we ever update Jdownloader through the program itself or should we ONLY ever update it through the docker? I'm just curious since I'm waiting for Jdownlaoder to fix this Katfile issue.

I am not sure what the Djoss's official stance is on this, but I update the program in the container all the time. Jdownloader updates far more frequently than the Container it seems. I have never had an issue updating the program within the container.

Share this post


Link to post

JDownloader is continually updating itself (and daily) within the container.

Note that you may have to manually check for updates in JD to apply the one the requires a restart of the app.

Share this post


Link to post

with this docker i have problems decrypting Filecrypt containers, if i add one, the links of the filecrypt html show as OFFLINE 

 

already updated JD2 and even reinstall the docker

 

with JD2 directly on the pc, filecrypt containers works without problems , so i guess there is a problem with JD2 on the docker

 

image.thumb.png.c6baa83a0bda627f789e6fe9e6e64338.png

Edited by Carmico

Share this post


Link to post
9 hours ago, Carmico said:

with this docker i have problems decrypting Filecrypt containers, if i add one, the links of the filecrypt html show as OFFLINE 

 

already updated JD2 and even reinstall the docker

 

with JD2 directly on the pc, filecrypt containers works without problems , so i guess there is a problem with JD2 on the docker

 

image.thumb.png.c6baa83a0bda627f789e6fe9e6e64338.png

Do you see any related error under /mnt/user/appdata/JDownloader2/logs/ ?

Also, if you can share the link, you can send it to me via private message and I will try to reproduce.

Share this post


Link to post
7 hours ago, Djoss said:

Do you see any related error under /mnt/user/appdata/JDownloader2/logs/ ?

Also, if you can share the link, you can send it to me via private message and I will try to reproduce.

believe me that problem is not the filecrypt container link, the link works with other JD2 , just with JD2 on docker doesnt work , i read on JD forum that seems to be related to the FF linux version

Share this post


Link to post
1 hour ago, Carmico said:

believe me that problem is not the filecrypt container link, the link works with other JD2 , just with JD2 on docker doesnt work , i read on JD forum that seems to be related to the FF linux version

I believe you :)  But if there is an issue with JD running in the Docker container, there may have some errors in the log.

Also, what do you mean by "FF linux version"?  And please share any forum discussion about this issue.

Share this post


Link to post

I just tried to add the filecrypt container ID and JDownloader does show that all the 62 files are online.

Can you try again?

Share this post


Link to post

Hello,

I have been using Jdownloader under Windows for a long time. I thought I'd change my habits and use it under Unraid.
I got it configured and running, I guess.

But no matter what I can't add anything to the linkgrabber.

It just won't get links from my clipboard, even when using copy and paste.
Any idea?

Share this post


Link to post
4 hours ago, xtrips said:

Hello,

I have been using Jdownloader under Windows for a long time. I thought I'd change my habits and use it under Unraid.
I got it configured and running, I guess.

But no matter what I can't add anything to the linkgrabber.

It just won't get links from my clipboard, even when using copy and paste.
Any idea?

Are you using the Clipboard button, at the top-right of the web page?

But the easiest way to add links would be to use MyJdownloader with its browser plugin.

Share this post


Link to post

I mostly use this with Mega, which it is awesome with, but I've been running into other sites (RapidGator, UploadGIG, etc.) that requires a browser to do the captchas and since it is running in a container of course this doesn't work. I don't think there is a way to get the link to open elsewhere/outside the container either, and that probably wouldn't work anyway since it would see it coming from a different location I imagine.

 

Is there anyway to put in a simple/basic install of Chrome or Firefox maybe into the container to allow those to open up and be done?

Share this post


Link to post
10 minutes ago, deusxanime said:

I mostly use this with Mega, which it is awesome with, but I've been running into other sites (RapidGator, UploadGIG, etc.) that requires a browser to do the captchas and since it is running in a container of course this doesn't work. I don't think there is a way to get the link to open elsewhere/outside the container either, and that probably wouldn't work anyway since it would see it coming from a different location I imagine.

 

Is there anyway to put in a simple/basic install of Chrome or Firefox maybe into the container to allow those to open up and be done?

You can use myJDownloader with a mobile app/browser extension.  To my knowledge, this can be used to resolve any captcha.

  • Like 1
  • Upvote 1

Share this post


Link to post
20 minutes ago, Djoss said:

You can use myJDownloader with a mobile app/browser extension.  To my knowledge, this can be used to resolve any captcha.

Interesting, didn't know there was such a thing! I'll give it a try. Thanks!

 

 

Share this post


Link to post
On 1/9/2019 at 5:09 PM, Djoss said:

You can use myJDownloader with a mobile app/browser extension.  To my knowledge, this can be used to resolve any captcha.

I've just discovered this wonderful browser extension thanks to your input. It has definetly improved my workflow: right click on link and send to Jdownloader. Kudos, my friend.

Share this post


Link to post

Hi forum!

I've just deployed a new ssd which I'll be using for VMs and Jdownloader. The disk is not part of the array (using Unassigned Devices).

I've successfully mapped /output dir on the disk and everything is working, however Fix Common Problems says that "Docker application JDownloader2 has volumes being passed that are mounted by Unassigned Devices, but they are not mounted with the slave option".

I can specify the slave option (RW/Slave) if I add another path to the container, but can't do that on the default one, I just don't find the relevant option.

 

Any help?

Share this post


Link to post
3 hours ago, melagodo said:

Hi forum!

I've just deployed a new ssd which I'll be using for VMs and Jdownloader. The disk is not part of the array (using Unassigned Devices).

I've successfully mapped /output dir on the disk and everything is working, however Fix Common Problems says that "Docker application JDownloader2 has volumes being passed that are mounted by Unassigned Devices, but they are not mounted with the slave option".

I can specify the slave option (RW/Slave) if I add another path to the container, but can't do that on the default one, I just don't find the relevant option.

 

Any help?

In container settings, you need to toggle the Advanced view (upper right).

  • Like 1

Share this post


Link to post
3 hours ago, melagodo said:

but can't do that on the default one, I just don't find the relevant option.

Show More Settingsimage.png.669e53c0d98e234e59a0a4438092d76c.png

  • Like 1

Share this post


Link to post

I have given this docker in my unRaid (6.6.7) a different IP (Networktype: custom br0).
But for now, it is ignoring the option 'WEB Port for GUI'.

How can i set a custom IP and WebUI port (80)?
 

Share this post


Link to post
6 hours ago, schwabelbauch said:

I have given this docker in my unRaid (6.6.7) a different IP (Networktype: custom br0).
But for now, it is ignoring the option 'WEB Port for GUI'.

How can i set a custom IP and WebUI port (80)?
 

If you use something else than "Bridge" for the network type, you can't map the ports.  You need to use the ports used by the container.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now