CentOS VM won't boot when CPU Mode = QEMU64, but CPU Mode = host passthrough boots with kernel problems (kernel:Dazed and confused, but trying to continue)


3 posts in this topic Last Reply

Recommended Posts

I created a new VM, it looks like this:

 

5de930d0e40cc3c3ecdeaa6ab5eca618.png

 

It installed fine, I have CentOS 7 + cPanel running on it. It is running on my cache SSD so it boots up super quick.

 

The problem starts when I logged on it from SSH. I get error messages like this every second:

[root@mrlb1b myscripts]#
Message from syslogd@mrlb1b at Jul  5 15:11:32 ...
 kernel:Uhhuh. NMI received for unknown reason 21 on CPU 0.

Message from syslogd@mrlb1b at Jul  5 15:11:32 ...
 kernel:Do you have a strange power saving mode enabled?

Message from syslogd@mrlb1b at Jul  5 15:11:32 ...
 kernel:Dazed and confused, but trying to continue

Message from syslogd@mrlb1b at Jul  5 15:12:02 ...
 kernel:Uhhuh. NMI received for unknown reason 31 on CPU 0.

Message from syslogd@mrlb1b at Jul  5 15:12:02 ...
 kernel:Do you have a strange power saving mode enabled?

Message from syslogd@mrlb1b at Jul  5 15:12:02 ...
 kernel:Dazed and confused, but trying to continue

Message from syslogd@mrlb1b at Jul  5 15:12:32 ...
 kernel:Uhhuh. NMI received for unknown reason 21 on CPU 0.

Message from syslogd@mrlb1b at Jul  5 15:12:32 ...
 kernel:Do you have a strange power saving mode enabled?

Message from syslogd@mrlb1b at Jul  5 15:12:32 ...
 kernel:Dazed and confused, but trying to continue

Message from syslogd@mrlb1b at Jul  5 15:13:02 ...
 kernel:Uhhuh. NMI received for unknown reason 31 on CPU 0.

Message from syslogd@mrlb1b at Jul  5 15:13:02 ...
 kernel:Do you have a strange power saving mode enabled?

So I searched around and this post points out that changing CPU Mode from Host Passthrough to QEMU Emulated solved the problem: https://forums.lime-technology.com/topic/46550-debian-84-vm-uhhuh-nmi-received-for-unknown-reason-20-on-cpu/?do=findComment&comment=551532

 

The problem now is, after changed the CPU mode to QEMU Emulated, the VM won't fully boot anymore. It's been 1 hour and the VM is stuck on this screen: 

d7703dc6559638da5466ab31b23dad62.png

 

I can't SSH into it. If I change CPU Mode to Host-Passthrough it boots up fine again, but I get those kernel errors every second again.

 

Has anyone seen this before? Any help is appreciated.

 

 

 

Link to post
  • 4 weeks later...

I had this problem also  this fixed it for me i edited the file  /etc/default/grub

i just added pcie_aspm=off

 

i still couldnt use cpu host pass-through because i still got the same errors but i switched it too QEMU64 and it has been a couple of hours now and i haven't had the error popup yet.

GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="crashkernel=auto rhgb quiet pcie_aspm=off"
GRUB_DISABLE_RECOVERY="true"

 

after editing the grub file run this command

 

grub2-mkconfig -o /boot/grub2/grub.cfg

and reboot. see if it works for you it did for me.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.