Long lines wrap poorly in SSH


15 posts in this topic Last Reply

Recommended Posts

This doesn't happen in any other *nix machines I use except for UnRAID.

 

When in an SSH session and I reach the end of the line, instead of line-wrapping to the next line, it jumps forward, much like when you're using nano and cursor to the edge of a long line.

I can't figure out how to change this behavior.  I often will SSH into the machine to move large files around or do other tasks more easily done with the command line.  Because of the file structure I use, I often have paths that are rather long (example: /mnt/user/Video/TV/Star\ Trek\ The\ Next\ Generation\Season\ 01/Star\ Trek\ TNG\ S01E01-Encounter\ at\ Farpoint\ Part\ 1.avi) 

Once I get past the "edge" of the terminal, the line jumps forward and I can't see what I've already typed (to check for errors) and I can't back up (with cursors or backspace) past the point of the "jump."

Can anyone direct me to the setting that will make the terminal session behave like all my other *nix (OSX, Mint, Ubuntu, Raspbian) terminal sessions?

Edited by 2twisty
Link to post

I am using Linux Mint.  I open an xTerm and use the command line SSH app.  The problem can't be in the terminal app I'm using since I don't get this behavior with any other *nix system I've connected to.  Only unRAID.

 

Link to post

Apparently, there is a version of PuTTY for Linux.  You can find it by googling "PuTTY for linux".  Looking at a couple of items listed, I noticed that one said that PuTTY had several features which xTerm does not support.  You might want to try PuTTY.  (It has been a long time (try 30 years) since I was involved with terminal emulation problems but I seem to remember, you had to setup whatever Shell program (in unRAID's case-- BASH) to tell it what terminal emulation you were going to be using. Or do the converse and setup the emulator to the emulation that the shell was expecting.)

Link to post
  • 3 weeks later...

THe line wraps about halfway across the window, regardless of how wide it is. It also wraps *onto the same line* not the line under it, which causes the command to overwrite itself. For example, running a simple mv command with full pathing is impossible, same goes for some long one-off docker commands.

Link to post

It's set to defaults, which work perfectly fine on many other linux servers and VMs, just Unraid that has the issue. The settings look exactly the same as your pic, except the columns and rows change to match the window size. its almost as if something server-side is not registering or acknowledging the new size.

Link to post

You do realize that you can change the settings and save that new configuration as a 'Saved setting'.  If you have the IP address included in that Saved session, it will automatically bring up the terminal window as soon as you click the 'Open' button.  You can have one for every device/server/VM that you need to log into.   It has been a long time since I have had to play around with the settings so I am no expert on them.

Link to post
  • 1 year later...

I'm surprised no one has an answer to this issue. I guess not that many use ssh on unraid. This is a problem with only unraid and I am also searching for a solution. Ignore the guy above who is fixated on putty. That will not resolve this issue witch is an unraid terminal issue only. It is server side.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.