[Support] Djoss - CrashPlan PRO (aka CrashPlan for Small Business)


1020 posts in this topic Last Reply

Recommended Posts

  • Replies 1k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Yes, I will provide a new image with the new CrashPlan version integrated.   Thanks for reporting this.  This is currently the most efficient wait for me to know there is a new CrashPlan ver

Support for CrashPlan PRO (aka CrashPlan for Small Business) docker container   Application Name: CrashPlan PRO (aka CrashPlan for Small Business) Application Site: https://www.crashplan.com

I think this is related to the "official" way to use CP on a headless computer:   https://support.code42.com/CrashPlan/4/Configuring/Use_CrashPlan_on_a_headless_computer   Not sure

Posted Images

5 hours ago, lordbob75 said:

 

One other thing:

Could you open Chrome's developer tools (shift+ctrl+i), make sure to select the "console" tab, and then load the container's UI by adding the argument '?logging=debug' to its URL.  For example:

 

http://192.168.1.5:7810/?logging=debug

 

Then, provide the Chrome's console output.

 

Thanks!

Link to post

I followed the instructions at the start of the thread to copy my app data folder to the Pro. I also upgraded my CrashPlan account to Pro and confirmed I can log in via the webpage. I installed the Pro container but am unable to log in. I am inserting the correct password however I keep receiving the message "Unable to sign in".

 

I have confirmed via the Code42 webpage my account is correct. Even if I change pwd I still receive the same message.

Link to post
11 hours ago, RAINMAN said:

I followed the steps to update and its working but now I have 2 backups, one without files but I cannot delete it as it says I need to have a default.  I cant find where to change the default to the new one.  Did I miss a step somewhere?

Not sure to understand your issue.  Can you post a screenshot showing what you are talking about?

Link to post
5 hours ago, darrenyorston said:

I followed the instructions at the start of the thread to copy my app data folder to the Pro. I also upgraded my CrashPlan account to Pro and confirmed I can log in via the webpage. I installed the Pro container but am unable to log in. I am inserting the correct password however I keep receiving the message "Unable to sign in".

 

I have confirmed via the Code42 webpage my account is correct. Even if I change pwd I still receive the same message.

You were using the home version using jlesage/crashplan container or another one?

Link to post
12 hours ago, lordbob75 said:

Windows 10, Version 63.0.3239.84 (Official Build) (64-bit)

 

Does not work in chrome on my android either, although it connects, just doesn't load anything aside from the top menu bar.

That's strange, I'm using the exact same Chrome version I can't reproduce the issue.

You said that after clearing the cache it works.  What you need to do then to reproduce the problem?

Link to post
22 minutes ago, Djoss said:

You were using the home version using jlesage/crashplan container or another one?

 

I upgraded from gfjardim/crashplan

 

The issue is that I have 2 backup sets.  I cant delete the old one.  

 

image.thumb.png.7c034f30359d9e6feddfa81b8b66c08a.png

 

When I try and delete it, I get this error.

 

image.thumb.png.7b0731b560eb346a0cf7f4d42d94e695.png

 

I'm not sure why I ended up with 2 sets.  Maybe I screwed something up along the way...

Link to post
13 minutes ago, RAINMAN said:

 

I upgraded from gfjardim/crashplan

 

The issue is that I have 2 backup sets.  I cant delete the old one.  

 

image.thumb.png.7c034f30359d9e6feddfa81b8b66c08a.png

 

When I try and delete it, I get this error.

 

image.thumb.png.7b0731b560eb346a0cf7f4d42d94e695.png

 

I'm not sure why I ended up with 2 sets.  Maybe I screwed something up along the way...

 

Are you using the default container settings?  What are your volume mappings?

Link to post
1 minute ago, RAINMAN said:

Default mappings and settings except max memory is 5G.

 

image.png.87834681ca1875fc5c603706b2c72213.png

 

 

Since the paths under the old container were different, did you re-selected your files under /storage ?

Check which files are selected in both backup sets...

Link to post
2 hours ago, RAINMAN said:

Yes, I deselected the files in the old set and re-selected them in the new set.

What you normally need to do is keep files from your old container selected (the ones under /mnt/user/) and select the same files under the new path (/storage).

You then preform a backup.  Once done, then you can remove the old selection.

Link to post
8 hours ago, Djoss said:

That's strange, I'm using the exact same Chrome version I can't reproduce the issue.

You said that after clearing the cache it works.  What you need to do then to reproduce the problem?

Will test again when I get home, but I had cleared the cache, it worked, then next time I opened it, it wasn't working. Clearing the cache again fixed it until the next time I opened it.  Not sure if it was the next day or whatever though.

Link to post

Hi I'm really confused here. I previously migrated from Crashplan home to previous Crashplan Pro app (gfjardim/crashplan:latest) went through migration to pro and all seemed to work ok using Pro version.

 

Now appears I now need to use jlesage/crashplan-pro:latest docker instead. Obviously wanting to re-use my existing config, so I added a few folder / path (/mnt/user/appdata/CrashPlanPRO) and copied gfjardim appdata config content to that (see below).

 

image.thumb.png.bad163e790164546301c975377640530.png

 

Docker starts ok, I'm able to log in with usual credentials, I choose my existing tower, but then I'm asked to choose files to transfer or skip. if I choose file transfer, appears I need to choose files on my crashplan online backup, but if I choose skip files I receive a scary message (see below)

 

image.png.fdcbc91fb4258f7e24f2c0eb12ec34e1.png
All i want to achieve is to sync my data on tower to my online crashplan, so my backups can restart. (obviously I don't want to resend the TB's of data already synced as that might take about a month) - Some guidance appreciated please as dont want to mess things up.

 

Migrating to jlesage crashplanPro.pdf

Link to post
On 24/12/2017 at 3:05 AM, huntjules said:

Hi I'm really confused here. I previously migrated from Crashplan home to previous Crashplan Pro app (gfjardim/crashplan:latest) went through migration to pro and all seemed to work ok using Pro version.

 

Now appears I now need to use jlesage/crashplan-pro:latest docker instead. Obviously wanting to re-use my existing config, so I added a few folder / path (/mnt/user/appdata/CrashPlanPRO) and copied gfjardim appdata config content to that (see below).

 

image.thumb.png.bad163e790164546301c975377640530.png

 

Docker starts ok, I'm able to log in with usual credentials, I choose my existing tower, but then I'm asked to choose files to transfer or skip. if I choose file transfer, appears I need to choose files on my crashplan online backup, but if I choose skip files I receive a scary message (see below)

 

image.png.fdcbc91fb4258f7e24f2c0eb12ec34e1.png
All i want to achieve is to sync my data on tower to my online crashplan, so my backups can restart. (obviously I don't want to resend the TB's of data already synced as that might take about a month) - Some guidance appreciated please as dont want to mess things up.

 

Migrating to jlesage crashplanPro.pdf

 

First, appdata from your old container is not fully compatible with this one.  So the copy you did is useless.  Normally, you would have start with an empty appdata.

 

Then, you can skip the file transfer without issue.  The wizard assumes that the current device doesn't have a local copy of the data in the cloud, which is obviously no the case.

 

Since the file paths between the old and the new container is different (your files are under /storage in the new one), you will need to re-select your files under the correct path, then perform a backup (without removing files marked as missing, which are under the old  /mnt/user path).  Because of deduplication, nothing will be re-uploaded.

 

All these instructions can be found at https://github.com/jlesage/docker-crashplan-pro#taking-over-existing-backup

 

 

Link to post
On 24/12/2017 at 8:50 AM, tola5 said:

Hi my Crashplan pro just keep showing waiting for connection . I have login and all  I read som say it if it need more ram but I have follow this one and adde 4GB did not help  https://support.code42.com/CrashPlan/5/Troubleshooting/Adjust_Code42_app_settings_for_memory_usage_with_large_backups other there have try the same ? 

 

It is waiting for which connection? To CrashPlan Central?

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.