[Support] Djoss - CrashPlan PRO (aka CrashPlan for Small Business)


1056 posts in this topic Last Reply

Recommended Posts

  • Replies 1.1k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Support for CrashPlan PRO (aka CrashPlan for Small Business) docker container   Application Name: CrashPlan PRO (aka CrashPlan for Small Business) Application Site: https://www.crashplan.com

I think this is related to the "official" way to use CP on a headless computer:   https://support.code42.com/CrashPlan/4/Configuring/Use_CrashPlan_on_a_headless_computer   Not sure

Yes, I will provide a new image with the new CrashPlan version integrated.   Thanks for reporting this.  This is currently the most efficient wait for me to know there is a new CrashPlan ver

Posted Images

I am using the default mapping. Nothing has changed with my setup. My backups are still happening according to my crashplan account online, but I just can't get the app to connect. I also installed a VNC viewer app and tried to connect to IP:7910, but it just says connection refused. Something broke, but not sure what or how to fix it. One odd thing in the settings is that I have "Web port for GUI" and "VNC port for gui" listed 3 times? All three are set the same, Web = 7810 and VNC = 7910. I don't even see a setting for port 5800 which is the port it uses when I right click on the docker and choose "Web GUI". I'm always nervous to mess with the settings since I don't really understand them and I don't want to accidentally cause all my files to be backed up again. 

Link to post

Try to remove duplicated settings.  Then look at the Docker tab, you have a column with all the port mappings.  Make sure there is no duplicates.

 

Also, port 5800 is the container's internal port.  By default, it is mapped to port 7810 and it's the port you use to access the web interface: http://IP:7810.

Link to post

I was able to remove the duplicate entries, but it's still not working. Under "deployed hosts ports" I see this:

crashplanpro    7810 7910
plex    32400
plexpy    8181

 

Crashplanpro and ports are in red. I'm noot sure if that's because I'm on that docker or if it's because there is a problem.?

 

 

Link to post

No reason. I just set it to bridge mode and it created the duplicate ports again. I removed them and restarted the container. Now the page doesn't load at all over port 7810 or 5800? Everything was working fine on 10/9 when you pushed out the update to fix our problems so I can't figure out what changed since then. How can I see what is running on port 5900? I've not added anything in the last few weeks so not sure what would be using that port

Link to post
Just now, meoge said:

tcp        0      0 0.0.0.0:5900            0.0.0.0:*               LISTEN      15843/qemu-system-x

 

Any idea what that would be?

 

It's to access your VM.

 

Bridge mode should work fine.  It's the default and recommended mode.  Try to edit the config again and after you hit the Apply button, post the docker command that is showed.  Also, look again at the container logs.

Link to post

Command after switching to bridge mode:

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name="CrashPlanPRO" --net="bridge" -e TZ="America/New_York" -e HOST_OS="unRAID" -e "USER_ID"="99" -e "GROUP_ID"="100" -e "UMASK"="000" -e "APP_NICENESS"="" -e "DISPLAY_WIDTH"="1280" -e "DISPLAY_HEIGHT"="768" -e "X11VNC_EXTRA_OPTS"="" -e "CRASHPLAN_SRV_MAX_MEM"="4096M" -e "SECURE_CONNECTION"="0" -p 7810:7810/tcp -p 7910:7910/tcp -v "/mnt/user":"/storage":ro -v "/boot":"/flash":ro -v "/mnt/user/appdata/CrashPlanPRO":"/config":rw jlesage/crashplan-pro
400b1f3d13144d3662c40b79179ad93e7f49fc4fade1c92b81e9e33dde768f15

The command finished successfully!

 

Nothing is loading when I go to IP:5800 or IP:7810

 

 

CrashPlanProDockerLog.txt

Link to post

Ok now the issue is that port mappings have incorrect container ports.  I think this is an issue that occurs when switching the network mode.

To bring back default mappings:

  • Remove ports from settings.
  • Apply settings.
  • Click the "Check for Updates" button (Docker tab).
  • Edit again the config.  Ports will be back.
  • Just re-apply the config (change any field and put it back to the same value).
Link to post

I am seeing this repeatedly. If I click Yes, it will attempt to start scanning files again, then after maybe 30 seconds it returns to this screen then has to restart scanning files again. Any ideas on what may be causing this loop?

crashpro.PNG

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.