[Support] Djoss - CrashPlan PRO (aka CrashPlan for Small Business)

Recommended Posts

Posted (edited)

Seems to have been an issue with my PC or browser. Had no issues with it today.


Unable to type, nor paste Japanese characters into the search bar while looking for a file to restore. 

The file names all show correctly in Japanese, but I would like to be able to search them in Japanese as well.

Am I missing something? Am running on Version: 6.11.5



Edited by ryoko227
Adding the update
Link to comment
On 5/9/2023 at 2:22 PM, bubbadk said:

this is odd. I can back everything up except plex, which is what i was planning to be my main plan about using crashplan.


i have set permissions and stuff. But it won't let me back up plex. 


does any1 have an idea

Skærmbillede 2023-05-09 201816.png

Skærmbillede 2023-05-09 201846.png


This is because the "Plex Media Server" folder is part of the internal CrashPlan exclusion list...

Link to comment
3 hours ago, ryoko227 said:

Unable to type, nor paste Japanese characters into the search bar while looking for a file to restore. 

The file names all show correctly in Japanese, but I would like to be able to search them in Japanese as well.

Am I missing something? Am running on Version: 6.11.5




Did you try to paste with "Ctrl-v" ?  If that doesn't work, can you provide an example of what you are trying to copy/paste ?

Link to comment
14 hours ago, Djoss said:


Did you try to paste with "Ctrl-v" ?  If that doesn't work, can you provide an example of what you are trying to copy/paste ?

My apologies, not sure why it didn't work yesterday, but I tried again this morning and had no issues!

Probably something was just funky with my PC or Chrome
Thank you though for responding! @Djoss

Link to comment
  • 4 weeks later...

This one has stopped working for me.   The problem is that I am not able to access the Web UI. Also I don't think the backup are running.




Removing container: CrashPlanPRO
Successfully removed container 'CrashPlanPRO'

Command execution
docker run
  -e TZ="Europe/Berlin"
  -e HOST_OS="Unraid"
  -e 'USER_ID'='99'
  -e 'GROUP_ID'='100'
  -e 'UMASK'='000'
  -e 'APP_NICENESS'=''
  -e 'DISPLAY_WIDTH'='1280'
  -e 'DISPLAY_HEIGHT'='768'
  -e 'X11VNC_EXTRA_OPTS'=''
  -e 'TCP_PORT_7810'='7810'
  -e 'TCP_PORT_7910'='7910'
  -e 'TCP_PORT_7810'='7810'
  -e 'TCP_PORT_7910'='7910'
  -l net.unraid.docker.managed=dockerman
  -l net.unraid.docker.webui='http://[IP]:[PORT:5800]'
  -l net.unraid.docker.icon='https://raw.githubusercontent.com/jlesage/docker-templates/master/jlesage/images/crashplan-pro-icon.png'
  -v '/mnt/user':'/storage':'ro'
  -v '/mnt/user/appdata/CrashPlanPRO':'/config':'rw' 'jlesage/crashplan-pro'

The command finished successfully!


[supervisor  ] service 'certsmonitor' is disabled.
[supervisor  ] loading service 'nginx'...
[supervisor  ] loading service 'xvnc'...
[supervisor  ] loading service 'openbox'...
[supervisor  ] loading service 'CrashPlanEngine'...
[supervisor  ] loading service 'logmonitor'...
[supervisor  ] loading service 'logrotate'...
[supervisor  ] all services loaded.
[supervisor     ] starting services...
[supervisor     ] starting service 'xvnc'...
[xvnc           ] Xvnc TigerVNC 1.13.1 - built May 16 2023 17:43:49
[xvnc           ] Copyright (C) 1999-2022 TigerVNC Team and many others (see README.rst)
[xvnc           ] See https://www.tigervnc.org for information on TigerVNC.
[xvnc           ] Underlying X server release 12014000
[xvnc           ] Fri Jun 16 10:32:11 2023
[xvnc           ]  vncext:      VNC extension running!
[xvnc           ]  vncext:      Listening for VNC connections on /tmp/vnc.sock (mode 0660)
[xvnc           ] (EE) 
[xvnc           ] Fatal server error:
[xvnc           ] (EE) vncExtInit: failed to bind socket: Address in use (98)
[xvnc           ] (EE) 
[supervisor     ] service 'xvnc' failed to be started: not ready after 5000 msec, giving up.
[supervisor     ] stopping service 'xvnc'...
[supervisor     ] service 'xvnc' exited (with status 1).
[finish      ] executing container finish scripts...
[finish      ] all container finish scripts executed.
[init        ] container is starting...
[cont-env    ] loading container environment variables...
[cont-env    ] APP_NAME: loading...
[cont-env    ] APP_VERSION: loading...
[cont-env    ] DISPLAY: executing...
[cont-env    ] DISPLAY: terminated successfully.
[cont-env    ] DISPLAY: loading...
[cont-env    ] DOCKER_IMAGE_PLATFORM: loading...
[cont-env    ] DOCKER_IMAGE_VERSION: loading...
[cont-env    ] GTK2_RC_FILES: executing...
[cont-env    ] GTK2_RC_FILES: terminated successfully.
[cont-env    ] GTK2_RC_FILES: loading...
[cont-env    ] GTK_THEME: executing...
[cont-env    ] GTK_THEME: terminated successfully.
[cont-env    ] GTK_THEME: loading...
[cont-env    ] HOME: loading...
[cont-env    ] QT_STYLE_OVERRIDE: executing...
[cont-env    ] QT_STYLE_OVERRIDE: terminated successfully.
[cont-env    ] QT_STYLE_OVERRIDE: loading...
[cont-env    ] TAKE_CONFIG_OWNERSHIP: loading...
[cont-env    ] XDG_CACHE_HOME: loading...
[cont-env    ] XDG_CONFIG_HOME: loading...
[cont-env    ] XDG_DATA_HOME: loading...
[cont-env    ] XDG_RUNTIME_DIR: loading...
[cont-env    ] XDG_STATE_HOME: loading...
[cont-env    ] container environment variables initialized.
[cont-secrets] loading container secrets...
[cont-secrets] container secrets loaded.
[cont-init   ] executing container initialization scripts...
[cont-init   ] 10-certs.sh: executing...
[cont-init   ] 10-certs.sh: terminated successfully.
[cont-init   ] 10-check-app-niceness.sh: executing...
[cont-init   ] 10-check-app-niceness.sh: terminated successfully.
[cont-init   ] 10-cjk-font.sh: executing...
[cont-init   ] 10-cjk-font.sh: terminated successfully.
[cont-init   ] 10-clean-logmonitor-states.sh: executing...
[cont-init   ] 10-clean-logmonitor-states.sh: terminated successfully.
[cont-init   ] 10-clean-tmp-dir.sh: executing...
[cont-init   ] 10-clean-tmp-dir.sh: terminated successfully.
[cont-init   ] 10-fontconfig-cache-dir.sh: executing...
[cont-init   ] 10-fontconfig-cache-dir.sh: terminated successfully.
[cont-init   ] 10-init-users.sh: executing...
[cont-init   ] 10-init-users.sh: terminated successfully.
[cont-init   ] 10-nginx.sh: executing...
[cont-init   ] 10-nginx.sh: terminated successfully.
[cont-init   ] 10-openbox.sh: executing...
[cont-init   ] 10-openbox.sh: terminated successfully.
[cont-init   ] 10-set-tmp-dir-perms.sh: executing...
[cont-init   ] 10-set-tmp-dir-perms.sh: terminated successfully.
[cont-init   ] 10-vnc-password.sh: executing...
[cont-init   ] 10-vnc-password.sh: terminated successfully.
[cont-init   ] 10-web-data.sh: executing...
[cont-init   ] 10-web-data.sh: terminated successfully.
[cont-init   ] 10-x11-unix.sh: executing...
[cont-init   ] 10-x11-unix.sh: terminated successfully.
[cont-init   ] 10-xdg-runtime-dir.sh: executing...
[cont-init   ] 10-xdg-runtime-dir.sh: terminated successfully.
[cont-init   ] 15-install-pkgs.sh: executing...
[cont-init   ] 15-install-pkgs.sh: terminated successfully.
[cont-init   ] 55-crashplan-pro.sh: executing...
[cont-init   ] 55-crashplan-pro.sh: terminated successfully.
[cont-init   ] 55-validate_max_mem.sh: executing...
[cont-init   ] 55-validate_max_mem.sh: terminated successfully.
[cont-init   ] 85-take-config-ownership.sh: executing...

** Press ANY KEY to close this window ** 


Link to comment

Occasionally (like half the times I try) I can't login the web-ui saying Crashplan is "upgrading to a new version".

Looking at the history log I see these messages beginning on March 10th:


06/20/23 04:55 PM    CrashPlan started, version 11.0.1, GUID 632038001948010500
06/20/23 04:56 PM    Downloading a new version of CrashPlan.
06/20/23 04:57 PM    Download of upgrade failed - version 15252000061111, connection lost.
06/20/23 04:57 PM    Unable to apply upgrade(s), retrying in one hour


Docker image version is 23.06.1 which is the latest. Should the image updated to get rid of this issue?


Link to comment

There is a new version of CrashPlan available.   I'm working on this and a new image will be released soon.


However, I'm not sure why this prevent you from accessing the interface.  Do you usually have to enter your username/password every time you access the interface ?

Link to comment

Thanks for the quick turn-around Djoss.


Alas no, Docker's WebGui Still shows the "upgrading to new version" message after entering login credentials into Web Gui's Interface.


Edit after 3 hours:

Docker's WebGui still throws the "upgrading to new version" issue

Docker's WebGui shows version

CP's Website Portal indicates Computer is Online & Backup is 100%

CP's Website Portal shows version

Edited by landS
Link to comment

Alas, this appears to be a troublesome beast.


I updated from v6.12.1 to 6.12.2.

In the Crashplan Docker’s WebUi it shows in the left hand popout:

     Crashplan v11.1.1 & Docker Image v23.06.2


Image 1 is what the Crashplan WebUi looks like when I start the docker.

Image 2 is what the Crashplan WebUi looks like after I insert the password and click Continue.  This is where the message pops up.  If I close the WebUi and open it up the problem persists.

Image 3 is what Crashplan’s Website looks like.  The only item of note here is that the computer shows as online.   




Link to comment

Is anyone else seeing really high, essentially constant disk reads with Crashplan?  I'm not sure how long this has been going on but I've noticed in the last few days, there's a near constant "incredible" amount of disk reads going on on my server.


I installed itop and narrowed it down to crashplan (by tracing the PID with ps).  The crashplan process is almost always at the top of the iotop disk read list.


And iotop -a show a ton of accumulated reads several GB after only a couple minutes:

I've logged into the web GUI and it says all backups have been completed for several hours, and I haven't written to any of the backup sets in the mean time.  I've confirmed that stopping the Crashplan container stops the excessive reads.


Has anyone else seen anything like this?  Or have any ideas.  I have 3 backup sets but they only account for about 2TB and most of it rarely changes.


Edited by stanger89
Link to comment

@Flemming I had a similar issue with CrashPlan UI not showing -- just an error page in the browser. I had to change the Docker Network type in my template from `Bridge` which used to work fine to `Host` (no other type worked), and now my UI is showing and launching correctly from the Unraid right click menu....

Edited by CajunCoding
Link to comment
  • 1 month later...

Hello, I am planning to install and use UNRAID for the first time and one of my requirements is to use Crashplan for backups.  I noticed from this thread that people are having issues but no posts since June 30th.  Is this fixed and stable now?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.