[Support] Djoss - CrashPlan PRO (aka CrashPlan for Small Business)


1061 posts in this topic Last Reply

Recommended Posts

  • Replies 1.1k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Support for CrashPlan PRO (aka CrashPlan for Small Business) docker container   Application Name: CrashPlan PRO (aka CrashPlan for Small Business) Application Site: https://www.crashplan.com

I think this is related to the "official" way to use CP on a headless computer:   https://support.code42.com/CrashPlan/4/Configuring/Use_CrashPlan_on_a_headless_computer   Not sure

Yes, I will provide a new image with the new CrashPlan version integrated.   Thanks for reporting this.  This is currently the most efficient wait for me to know there is a new CrashPlan ver

Posted Images

Yeah it can take a few seconds before being ready, but it should not be that long.  Unless you just enable the secure connection, in which case it can that a 1-2 minutes (but only for the first start).

Link to post
On 10/19/2017 at 8:57 AM, meoge said:

What did you increase it to?

I increased it to 32G (overkill I know) just to make sure it doesn't crash for now. I will decrease it eventually but I just wanted to make sure my backup finishes for about 3.5M files.

Link to post

Yes, from CP Home.  I did the adoption process, it said 'adoption successful' at the time, but still says all of my folders are missing.

 

I assumed when the message about successful adoption came up all was OK, so I logged out and didn't check again as I was away from home for a few days so struggling to remember if I missed a bit!

Link to post

So if your were not using my container for CP home, then the path to your files inside the container are not the same. You need to re-select them, there are under /storage. You will then have 2 sets of selections, one missing and the other not.

Link to post

Anyone else seeing CPU usage spike with this docker running?  When my server sitting idle it is normally 0-5% CPU usage.  When I start this docker it sits around 30%+ all the time.  It is running as expected and doing everything it should but what is it doing all the time?  Backups are scheduled to run 2am-6am only.  Changing cpu setting in the docker  % when away, % when present seem to not change anything.  I also tried the niceness setting in advance setup but didn’t see a change their either.   Am I missing something?  This normal for this docker? 

 

This was a fresh install/backup set so no conversion or other stuff like that.  

Link to post
  • 2 weeks later...
On 11/18/2017 at 4:18 AM, mustaqiim said:

Hey guys, i was wondering if this upload speed is normal? Can't seem to get higher than 4Mbps :\ It's not saturating my currently upload speed tho :(

Screen Shot 2017-11-18 at 6.16.18 PM.png

 

I've gotten much lower speeds since migrating to small business from home. I doubt it's the container because I've been getting terrible speeds since the migration on both gfjardim's container and this one. It rarely goes about 2Mbps. Before the small business migration I'd get 4.5-5.5Mbps. I don't know if they're throttling me since the migration or if small business is inherently slower, but it's a real problem.

Link to post

Hi guys,

 

It took me a while to figure out why Crashplan wasn't maxing (or at least near-maxing) my upload capacity.

The thing is that Crashplan seem to have been developed with much lower connections in mind than the ones we have today.

 

• Stop the Crashplan docker

• Go to your appdata folder, navigate to your Crahsplan folder

• Edit the "my.service.xml" file in the "conf" folder

 

And change the following value to 1:

          <dataDeDupAutoMaxFileSizeForWan>1</dataDeDupAutoMaxFileSizeForWan>
 

• This will effectively disable the data de-duplication for any file larger than 1 byte for any backup done over the internet

• Start your Crashplan docker again

 

This always had me max my connection again. Otherwise, I rarely went beyond 2 MB/s. (currently happily going over 25 MB/s with that)

 

Kind regards,

Denis

Link to post
45 minutes ago, Fatal_Flaw said:

 

I've gotten much lower speeds since migrating to small business from home. I doubt it's the container because I've been getting terrible speeds since the migration on both gfjardim's container and this one. It rarely goes about 2Mbps. Before the small business migration I'd get 4.5-5.5Mbps. I don't know if they're throttling me since the migration or if small business is inherently slower, but it's a real problem.

 

It could have been the Pro version overwriting your my.services.xml file during an update (see my post above).

Link to post
19 minutes ago, denishay said:

 

It could have been the Pro version overwriting your my.services.xml file during an update (see my post above).

 

I have double checked my config file and it does still have dedupe disabled. It is uploading at the speed I would expect it to if dedupe were enabled. But with the config file being correct, I don't know where to go from here.

 

          <compression>OFF</compression>
          <dataDeDupAutoMaxFileSize>1</dataDeDupAutoMaxFileSize>
          <dataDeDupAutoMaxFileSizeForWan>1</dataDeDupAutoMaxFileSizeForWan>
          <dataDeDuplication>MINIMAL</dataDeDuplication>

 

I went and looked at some old logs

I 10/01/17 12:16AM [XXXXXX Backup] Stopped backup to CrashPlan Central in 21.2 hours: 116 files (44.40GB) backed up, 44GB encrypted and sent @ 6.8Mbps

and compared to the new logs

I 11/21/17 07:43AM [XXXXXX Backup] Stopped backup to CrashPlan Central in 4.7 hours: 25 files (4.70GB) backed up, 4.60GB encrypted and sent @ 1.6Mbps (Effective rate: 1.9Mbps)

So i don't know if they're throttling now, or if something is screwed up with my client despite what the config file is saying. I'm tempted just delete the container, reinstall, and instead of attempting to transfer all the settings from the gfjardim's container. just adopt the backup. I'm concerned that with dedup being disabled, I'll end up having to reupload everything.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.