Jump to content
clowrym

[Support] Clowrym's Docker Repository

136 posts in this topic Last Reply

Recommended Posts

33 minutes ago, Raczo said:

 

I'm not sure if it takes time for community apps to pick up the change?

 

  <Config Name="PLEX_LOCAL_PORT" Target="PLEX_LOCAL_PORT" Default="32400" Mode="tcp" Description="Container Port: PLEX_LOCAL_PORT" Type="Port" Display="always" Required="true" Mask="false">Local Port</Config>

 

Share this post


Link to post
Just now, Raczo said:

Got the port to work now but when i try to play a song it connects and dissconnects directly. What can be wrong? it can see all of my music but doesn't play it

 

 

To be honest I've never used this, I created the template for  buddy of mine, I'll check and see if he had any issues with it.

Share this post


Link to post
On 8/4/2018 at 12:33 PM, Shamalamadindong said:

First time user of MineOS, same deal as the other guy, nothing starts.

 

 

can you provide a screenshot of your docker path/port settings.

Share this post


Link to post

im trying to run mineos-node and an apache webserver docker at the same time but your docker doesent listen to the port to I had to remove apache to be able to get in

 

as you can see I set mineos to use port 6443

1382840591_mineos-nodedockerconfig.thumb.PNG.37541b8501c4a303e816e8c770feacc1.PNG

but its not instead its using port 8443

1098904907_mineos-nodedockerport.PNG.f606dc8304c7f059f499695549e0fc9f.PNG

 

why is it still using the default port even though I have changed it?

 

this is very frustrating

my apache and mineos were stomping on eachother because both are configured to use 8443 by default and neither are listening to the changes I make

 

EDIT: if I change the network to bridge mode instead of host mode and have 8443 internal to 6443 external it works

Edited by cTurtle98
found solution

Share this post


Link to post
1 hour ago, cTurtle98 said:

im trying to run mineos-node and an apache webserver docker at the same time but your docker doesent listen to the port to I had to remove apache to be able to get in

 

as you can see I set mineos to use port 6443

1382840591_mineos-nodedockerconfig.thumb.PNG.37541b8501c4a303e816e8c770feacc1.PNG

but its not instead its using port 8443

1098904907_mineos-nodedockerport.PNG.f606dc8304c7f059f499695549e0fc9f.PNG

 

why is it still using the default port even though I have changed it?

 

this is very frustrating

my apache and mineos were stomping on eachother because both are configured to use 8443 by default and neither are listening to the changes I make

 

EDIT: if I change the network to bridge mode instead of host mode and have 8443 internal to 6443 external it works

can you show me this:

 

image.png.cd22e3f4abff50981e462e24c008066a.png

Share this post


Link to post
3 hours ago, cTurtle98 said:

if I change the network to bridge mode instead of host mode and have 8443 internal to 6443 external it works

Exactly. In host mode, the whole range of ports are exposed, no NAT'ing involved, so whatever the application itself opens and listens on is used. In bridge, the host port is opened and redirected to the specified container port.

 

The GUI currently doesn't handle that not so subtle difference well, ideally I think when host mode is selected all port assignments should be hidden, because they aren't going to be used in any way.

Share this post


Link to post
2 hours ago, jonathanm said:

Exactly. In host mode, the whole range of ports are exposed, no NAT'ing involved, so whatever the application itself opens and listens on is used. In bridge, the host port is opened and redirected to the specified container port.

 

The GUI currently doesn't handle that not so subtle difference well, ideally I think when host mode is selected all port assignments should be hidden, because they aren't going to be used in any way.

thanks for the clarification

Share this post


Link to post

I am getting permission denied errors on all my downloads error.PNG.e7f5df1c8de54a3c7823bd155fddf109.PNG

 

The User/Group-IDs are still the default ones from your template and should work with unraid. /downloads/Transmission belongs to nobody:users and has 777 permissions.

 

Any clue?

Share this post


Link to post
On 9/8/2018 at 11:40 AM, rix said:

I am getting permission denied errors on all my downloads error.PNG.e7f5df1c8de54a3c7823bd155fddf109.PNG

 

The User/Group-IDs are still the default ones from your template and should work with unraid. /downloads/Transmission belongs to nobody:users and has 777 permissions.

 

Any clue?

ca you show me your folder mappings? Anytime ive had this in th epast its beena  folder mapping issue during template creation!

 

Share this post


Link to post

I figured it out.. Had to set umask to 0

Share this post


Link to post

I'm trying to get transmission-openvpn up and running using NordVPN. Right now I just get this in the log:

 

Using OpenVPN provider: NORDVPN
Supplied config default.ovpn could not be found.
Using default OpenVPN gateway for provider nordvpn
Setting OPENVPN credentials...
adding route to local network 192.168.0.0/24 via 172.17.0.1 dev eth0
Options error: In [CMD-LINE]:1: Error opening configuration file: /etc/openvpn/nordvpn/default.ovpn

 

There were no ovpn files included. I cloned them from the repo and have those in place at /mnt/user/appdata/Transmission_VPN/openvpn/nordvpn/. I'm not sure how to point the container to this new location. I also fixed a bad symllink for default.ovpn. I'm guessing I need to add a mount for the /etc/openvpn/nordvpn path?

 

UPDATE

 

I got further along. Added a mapping for /etc/openvpn/nordvpn to map to /mnt/user/appdata/Transmission_VPN/openvpn/nordvpn. Now it can find my default.ovpn file and I got connected to NordVPN. I can only map to one file and would like the option to include multiple files. At least that much is working.

 

Still can't get the Transmission UI to load, though. Just times out over port 9091. So, still digging here.

 

UPDATE 2

 

Got the GUI to load. I missed an item on the local network and had the wrong subnet. RTFM.

 

I have some tests to do, but I am wondering about how to better manage the OPVN files. I just have it using default.ovpn and then I just change the symbolic link as needed. Would be nice if I could put a list in there. Not sure how to do that in the OPENVPN_CONFIG that appears customized for PIA. Would I just remove this variable listing and create my own where I could then list multiple items? Let me know if I'm violating any best practices here.

Edited by snowboardjoe

Share this post


Link to post
4 hours ago, snowboardjoe said:

I'm trying to get transmission-openvpn up and running using NordVPN. Right now I just get this in the log:

 

Using OpenVPN provider: NORDVPN
Supplied config default.ovpn could not be found.
Using default OpenVPN gateway for provider nordvpn
Setting OPENVPN credentials...
adding route to local network 192.168.0.0/24 via 172.17.0.1 dev eth0
Options error: In [CMD-LINE]:1: Error opening configuration file: /etc/openvpn/nordvpn/default.ovpn

 

There were no ovpn files included. I cloned them from the repo and have those in place at /mnt/user/appdata/Transmission_VPN/openvpn/nordvpn/. I'm not sure how to point the container to this new location. I also fixed a bad symllink for default.ovpn. I'm guessing I need to add a mount for the /etc/openvpn/nordvpn path?

 

UPDATE

 

I got further along. Added a mapping for /etc/openvpn/nordvpn to map to /mnt/user/appdata/Transmission_VPN/openvpn/nordvpn. Now it can find my default.ovpn file and I got connected to NordVPN. I can only map to one file and would like the option to include multiple files. At least that much is working.

 

Still can't get the Transmission UI to load, though. Just times out over port 9091. So, still digging here.

 

UPDATE 2

 

Got the GUI to load. I missed an item on the local network and had the wrong subnet. RTFM.

 

I have some tests to do, but I am wondering about how to better manage the OPVN files. I just have it using default.ovpn and then I just change the symbolic link as needed. Would be nice if I could put a list in there. Not sure how to do that in the OPENVPN_CONFIG that appears customized for PIA. Would I just remove this variable listing and create my own where I could then list multiple items? Let me know if I'm violating any best practices here.

You can change the OPENVPN provider by setting to advanced view & adjusting the Default values to whatever your location names are seeperated by "|" ie.... name1|name2|name3| etc.

Share this post


Link to post

When i use the transmission_vpn i keep getting the following error

 

Using OpenVPN provider: NORDVPN
Starting OpenVPN using config default.ovpn
Setting OPENVPN credentials...
adding route to local network 192.168.1.0/24 via 172.17.0.1 dev eth0
Wed Sep 26 04:42:04 2018 OpenVPN 2.4.6 x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Apr 24 2018
Wed Sep 26 04:42:04 2018 library versions: OpenSSL 1.0.2g 1 Mar 2016, LZO 2.08
Wed Sep 26 04:42:04 2018 neither stdin nor stderr are a tty device and you have neither a controlling tty nor systemd - can't ask for 'Enter Auth Username:'. If you used --daemon, you need to use --askpass to make passphrase-protected keys work, and you can not use --auth-nocache.
Wed Sep 26 04:42:04 2018 Exiting due to fatal error

 

Share this post


Link to post

I figured it out. In my default ovpn file i had to list out the password.txt file next to authentication line.  Seemed to fix it.

Share this post


Link to post

The WebUI refuses to connect in the current version or it gives a Connection failed error:

 

image.png.4bf00c54998d2f26515a221c4135ee59.png

 

There seem to be two problems:

1. PIA needs to be connected to a port forwarding host as mentioned here: https://www.privateinternetaccess.com/helpdesk/kb/articles/how-do-i-enable-port-forwarding-on-my-vpn. This fixes this error:

Quote

 

Wait for tunnel to be fully initialized and PIA is ready to give us a port
Wed Oct 17 12:01:42 2018 Initialization Sequence Completed
Generating new client id for PIA
Port forwarding is already activated on this connection, has expired, or you are not connected to a PIA region that supports port forwarding
curl encountered an error looking up new port: 7


 

 

1

 

Note, that the settings do not allow for the selection of all those endpoints. For example, there is an invalid Germany choice. Instead there should be a "DE Frankfurt" and a "DE Berlin"

 

2. From what I could find out  there seems to be also a problem with 2.94. Reverting to 2.93 by using "linuxserver/transmission:121" into the repository and applying the change fixed this. But then, this version doesn't use PIA.

 

Does anybody have an idea how to fix this problem e.g. by reverting to an older version of haugene/transmission-openvpn?

 

Thanks!

 

tazman

 

Share this post


Link to post
3 hours ago, tazman said:

 

 

Note, that the settings do not allow for the selection of all those endpoints. For example, there is an invalid Germany choice. Instead there should be a "DE Frankfurt" and a "DE Berlin"

 

 

TO be honest, I havent kept up with any new opvn locations that have been added, I added DE Berlin/Frakfurt this morning for you. You can add your own locations if any are missing. I'm not sure on your other issue, I've had no problems keeping with the most current version. Might want to post a support ticket here as I only created the Template for unraid, not the application itself!

I currently run the Dev branch of his repository

 

 

I'm currently running:

 

Transmission: 2.94 (d8e60ee44f), RPC: 15

Web Control: 1.6.0 alpha (20180418)

 

Edited by clowrym

Share this post


Link to post
20 hours ago, ndaringer said:

the MinecraftPE docker is 4 months out of date.

I've only created the templates, Nukkit Might be able to update it for you.

Share this post


Link to post

Transmission:

 

Is there anyway to disable downloading to incomplete folder? I tried editing the settings.json, but when i start the docker et defaults back to true. :/

 

Or maybe a way to separate download folder and configuration folder. (maybe I'm getting it all worng)

Share this post


Link to post
On 11/3/2018 at 2:39 PM, Madhouse said:

Transmission:

 

Is there anyway to disable downloading to incomplete folder? I tried editing the settings.json, but when i start the docker et defaults back to true. :/

 

Or maybe a way to separate download folder and configuration folder. (maybe I'm getting it all worng)

you should be able to add Transmission parameters to your docker template and they will survive reboot as detailed here . Detailed part way down the page under "Transmission configuration options"

 

for instance, you would add "TRANSMISSION_INCOMPLETE_DIR_ENABLED" with a value of "false" to disable the incomplete download directory. This holds true for any variable you want to survive a reboot.

Edited by clowrym

Share this post


Link to post
On 11/4/2018 at 9:40 PM, clowrym said:

you should be able to add Transmission parameters to your docker template and they will survive reboot as detailed here . Detailed part way down the page under "Transmission configuration options"

 

for instance, you would add "TRANSMISSION_INCOMPLETE_DIR_ENABLED" with a value of "false" to disable the incomplete download directory. This holds true for any variable you want to survive a reboot.

Thank you so much, I wasn't aware of that.. :)

Share this post


Link to post

Hey Guys,

 

Whenever I try to change my download destination It either causes a hard error and makes the docker restart constantly or doesn't apply the changes. I can download fine currently but I have a download destination directly into a folder that I use to rename files. I attached the 2 lines i have tried to edit, I have even tried editing the .json file and changing the destinations in the web ui and a remote client. No joy with any such method, but when i change the destination in the docket template it just causes the error. What am I missing? 

Untitled.png

Share this post


Link to post

what are you changing the destinations to? can you provide the template screenshot after you've made the change and get the error. Also a screenshot of the error might be helpful

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now