Jump to content
clowrym

[Support] Clowrym's Docker Repository

116 posts in this topic Last Reply

Recommended Posts

The issue seems to has resolved itself. 99% sure I was the problem I must have incorrectly typed something at some point and been to silly to realize it.  

Share this post


Link to post
10 hours ago, Harag said:

The issue seems to has resolved itself. 99% sure I was the problem I must have incorrectly typed something at some point and been to silly to realize it.  

Most issues are usually a error in mapping / ports!! Glad you got it working!@!

Share this post


Link to post

I'm getting some problems with the Transmission VPN. currently I have it with PIA and it works fine. But I cannot get the docker openvpn-as to access the transmission remotely. 

 

I noticed that If I turn off the transmission the vpn connects right away. And if I connect remotely and then start the transmission it works. 

 

I even added this. 

 

image.thumb.png.eddfdec1b62c3328bd85eb26f1a759e0.png

 

Also I remember this wasn't like this before. Because I used PIA before. 

 

Share this post


Link to post

Sorry for the late reply.. its been a busy couple weeks at work!! 

 

There seems to be an issue with adding multiple local networks in the cell you have above, I tried the same originally when I first made this template. I ended up adding a script to user scripts plugin that runs on server boot & that I run if I force a restart/update on Transmission. I have listed it below.... I know its a work around, but I havent figured out how to allow multiple networks in the docker template.....

 

I use the script below for access loutside of my local network thru the VPN I have set up for my work computer / phone when I am not on ly local network.

 

adjust the ip addresses to suit your network setup!!

#!/bin/bash
echo adding 10.1.0.0/25 LAN_NETWORK
docker exec Transmission_VPN /bin/sh -c "/sbin/ip r a 10.1.0.0/24 via 172.17.0.1 dev eth0"
echo Netowrk added
exit

 

Edited by clowrym

Share this post


Link to post
On 12/4/2018 at 1:04 AM, clowrym said:

Sorry for the late reply.. its been a busy couple weeks at work!! 

 

There seems to be an issue with adding multiple local networks in the cell you have above, I tried the same originally when I first made this template. I ended up adding a script to user scripts plugin that runs on server boot & that I run if I force a restart/update on Transmission. I have listed it below.... I know its a work around, but I havent figured out how to allow multiple networks in the docker template.....

 

I use the script below for access loutside of my local network thru the VPN I have set up for my work computer / phone when I am not on ly local network.

 

adjust the ip addresses to suit your network setup!!


#!/bin/bash
echo adding 10.1.0.0/25 LAN_NETWORK
docker exec Transmission_VPN /bin/sh -c "/sbin/ip r a 10.1.0.0/24 via 172.17.0.1 dev eth0"
echo Netowrk added
exit

 

@clowrym Thanks for that. Actually, I was able to make it see my other networks. To me still doesn't make sense because I keep using the server IP plus the port but. 

 

image.thumb.png.e15fbbf929802ad6ff1c7aa9da01e03e.png

 

I had to add manually there the virtual network and the vpn network to access the torrent.

 

Now Something that really bugs my mind and I don't know why is. 

 

Currently I have the OpenVPN-as docker container setup with UDP using port 9443, forwarded through my router. Works perfect. But when I have the Transmission docker running, My OpenVPN doesn't connect using UDP. I currently have it running on TCP. 

 

If Transmission for PIA is using OpenVPN Port 1198, why is it blocking my connection for my own VPN. 

 

Share this post


Link to post
Posted (edited)

I've just installed transmission-openvpn docker and got it running with NordVPN. I do not recommend anyone to use NordVPN as they do not support port forwarding so my speeds are abysmal. They are refusing to issue me with a refund for the unused subscription time as I no longer need Nord.

 

Anyway, onto why I'm here.. I've noticed two plain text files in this config folder containing the credentials for Transmission and the credentials for my NordVPN account. They are named:

openvpn-credentials.txt

transmission-credentials.txt

 

This seems like a pretty serious security vulnerability? Password should never be stored in plain text... 🤨

Edited by danger781

Share this post


Link to post
2 hours ago, danger781 said:

I've just installed transmission-openvpn docker and got it running with NordVPN. I do not recommend anyone to use NordVPN as they do not support port forwarding so my speeds are abysmal. They are refusing to issue me with a refund for the unused subscription time as I no longer need Nord.

 

Anyway, onto why I'm here.. I've noticed two plain text files in this config folder containing the credentials for Transmission and the credentials for my NordVPN account. They are named:

openvpn-credentials.txt

transmission-credentials.txt

 

This seems like a pretty serious security vulnerability? Password should never be stored in plain text... 🤨

 

 

Interesting, not sure why those are there, my password is stored in the config file for transmission

 

I didnt create the docker, only the template for unraid, you could post here: https://github.com/haugene/docker-transmission-openvpn

Share this post


Link to post

Yeah that repo writes the credentials out to a plain text file in start.sh for openvpn:

# add OpenVPN user/pass
if [[ "${OPENVPN_USERNAME}" == "**None**" ]] || [[ "${OPENVPN_PASSWORD}" == "**None**" ]] ; then
  if [[ ! -f /config/openvpn-credentials.txt ]] ; then
    echo "OpenVPN credentials not set. Exiting."
    exit 1
  fi
  echo "Found existing OPENVPN credentials..."
else
  echo "Setting OPENVPN credentials..."
  mkdir -p /config
  echo "${OPENVPN_USERNAME}" > /config/openvpn-credentials.txt
  echo "${OPENVPN_PASSWORD}" >> /config/openvpn-credentials.txt
  chmod 600 /config/openvpn-credentials.txt
fi

I have no idea why though. It doesn't seem to get referenced again after that *.txt is initially created. Baffling!

Share this post


Link to post
13 hours ago, danger781 said:

I've just installed transmission-openvpn docker and got it running with NordVPN. I do not recommend anyone to use NordVPN as they do not support port forwarding so my speeds are abysmal. They are refusing to issue me with a refund for the unused subscription time as I no longer need Nord.

 

I've not run into this problem. I get incoming connections from peers just fine. At the same time, I've also verified all traffic is being tunneled through NordVPN (they only see my VPN IP).

 

13 hours ago, danger781 said:

Anyway, onto why I'm here.. I've noticed two plain text files in this config folder containing the credentials for Transmission and the credentials for my NordVPN account. They are named:

openvpn-credentials.txt

transmission-credentials.txt

 

This seems like a pretty serious security vulnerability? Password should never be stored in plain text... 🤨

 

Due to the nature of how these programs work, how else would you store them? The applications must know what the passwords are to submit the services you're subscribed to. If you encrypt it, the application has no method to extract it to submit the credential to the service on every startup of the container. Best thing to do is to make sure such files are only readable for the application that needs it.

 

 

Share this post


Link to post

Hi all,

 

I'm having trouble getting the Transmission docker up and running. The log shows the following error:


Got new port 59595 from PIA
transmission auth required
localhost:9091/transmission/rpc/ responded: "success"
Checking port...
Error: portTested: http error 0: No Response

 

Reading through the thread it looks to be the same DNS issue reported on P.2. It's probably very simple but I don't know how to add the DNS flag, any pointers would be appreciated.

 

On 1/2/2018 at 6:55 PM, clowrym said:

 

Looks like a DNS problem, Can you add dns flag to your template --dns 8.8.8.8

Thanks!

Edited by Hendricks

Share this post


Link to post
6 hours ago, Hendricks said:

Hi all,

 

I'm having trouble getting the Transmission docker up and running. The log shows the following error:


Got new port 59595 from PIA
transmission auth required
localhost:9091/transmission/rpc/ responded: "success"
Checking port...
Error: portTested: http error 0: No Response

 

Reading through the thread it looks to be the same DNS issue reported on P.2. It's probably very simple but I don't know how to add the DNS flag, any pointers would be appreciated.

 

Thanks!

make sure "advanced view" is on for your docker template and  add --dns 8.8.8.8 to the extra parameters 

Share this post


Link to post

Thanks Clowrym, i thought it had to be something fairly simple. The log now shows that the port is open, however the GUI doesn't come up...any thoughts?

 

STARTING TRANSMISSION
CONFIGURING PORT FORWARDING
Transmission startup script complete.
Wait for tunnel to be fully initialized and PIA is ready to give us a port
Fri Feb 8 17:29:13 2019 Initialization Sequence Completed
Generating new client id for PIA
Got new port 21613 from PIA
transmission auth required
localhost:9091/transmission/rpc/ responded: "success"
Checking port...
Port is open: Yes

Share this post


Link to post

DId you add your local network properly? ie. 192.168.1.0/24 or whatever local network your using? Also, are you trying to access it from within your network? If not then you have to add whatever network's you want to access it from.

Share this post


Link to post
DId you add your local network properly? ie. 192.168.1.0/24 or whatever local network your using? Also, are you trying to access it from within your network? If not then you have to add whatever network's you want to access it from.
This is exactly the problem you are getting. Remember the containers run in a virtual network, if you cinnect via VPN or whatever network. You have to add it to the options for the container as well.

Sent from my Pixel 2 XL using Tapatalk

Share this post


Link to post

That solved it, all appears to be working properly.

 

Thanks for the help in getting it set up, much appreciated. 

 

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now