Jump to content
FallingSloth

Devices attached to USB controller won't work through hub

6 posts in this topic Last Reply

Recommended Posts

I have a PCI usb card that I've successfully passed through to my Windows VM.  Any device I connect directly to the card works fine, but if I connect a hub to the card and try to connect a device to the VM through the hub, Windows doesn't detect the device.  I have checked the hub on a different device so I know that it's working.

 

I guess an alternative would be to buy a bunch of usb extension cables but I'd prefer to have the hub if possible.

 

Any reason a hub connected to a passed-through controller shouldn't work?

Share this post


Link to post

Did you try connecting the hub directly to the USB port passed through to the VM?  I have a long USB extension cable that explicitly says that it cannot drive a USB hub. Might want to double check what you are trying to do is supported.

 

Otherwise I would think a hub would work if connected directly to the USB port, but have never tried it.

Share this post


Link to post

Forgive my confusion, but what good would it do connecting it to a port that isn't passed through to the VM?

 

The hub is connected to the PCI usb controller that is passed through to the VM, and it is powered by a mains adapter.  My understanding is that any device connected to a controller that is passed through to a VM is in turn passed through to that VM.  Is it because it's a hub, or is there something I'm doing wrong?

Share this post


Link to post

So as i understanding it, you have passed through a USB controller, and connected a long USB cable to one of the ports, and connected a USB hub on the other end.

 

My point was that long USB extension cables do not (at least not all) support driving a USB hub on the other end. Mine explicitly says it will not, so I am running 2 separate USB extension cables for 2 USB devices. According to the cable docs, to power the long run, the cable itself is looking like a USB hub, and it doesn't support passing to another USB hub. Only elemental USB devices are allowed on the other end.

 

So my question was - have you tried tested your configuration natively (e.g., on another computer or to a non-passthrough USB on your unRAID server) and confirmed that the hub is recognized and works on the other end? If not, you are using an unsupported configuration that won't work.

 

But if natively you are finding the hub is recognized and functions at the end of the long USB cable, while via a VM, it does not, I don't have an explanation. Like you, I'd expect that the passthrough would allow the VM to detect the hardware.

 

BTW, I am assuming this is all on a USB 2.0 controller, and not USB 3.0. I have no experience with USB 3.0 passthrough, and know there can be compatibility issues. 

Share this post


Link to post

There is no extention cable, I was simply saying that if the hub won't work then I will need to use extentions as an alternative.  The cable goes straight from the usb card to the hub and is about a meter long.  When I connect the hub to my laptop everything works fine, but when I connect it to the usb card it doesn't.

 

@Squid Thanks for the tip, I'll give that a go.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.