Jump to content

USB3 HELL - Sonnet Allegro Pro 4 Port USB

11 posts in this topic Last Reply

Recommended Posts

I recently purchased the Sonnet Allegro Pro 4 Port USB PCI Express card featured in the the video below and was unable to get it working in unRaid 6.4.0 rc9f.  The card appears to work in the system BIOS but as soon and the unRaid kernel takes control of the card it goes to hell.  Should this card work in the Linux 4.12.14 kernel?  It is acting the same way that the StarTeck PEXUSB3S44V card did.  Sonnet sent me an email stating that they got the card working in the Linux 4.12.13 kernel but I am not sure what flavor of Linux they were testing on.


unRaid Hosts 4 Player VR video



It is just frustrating that this is the second card that uses a different USB controller that will not work.






Share this post

Link to post

Hey Chris,


I can appreciate your frustration.  Getting the hardware right is challenging.  Will look into this further for you... I promise.

Share this post

Link to post

Thank you Jon. 


I am worried it my be something related to my old ASUS Z9PE-D16/2L Socket 2011 motherboard.  I do have the latest BIOS installed.  When I get home, hopefully next week, I will install the card and post a diagnostic log.

Edited by csmccarron

Share this post

Link to post

Hi there,


Been using this card for almost a year now with UNRAID i.e. before the mentioned article. I have an ASUS X99-WS/IPMI Motherboard. I pass each of the usb ports/controllers to a VM and they work great. The key was with the bios settings for me. Switch ACS to ON I believe, if I remember correctly (might have been a couple of other settings). Futhermore, last time I tried to install the official drivers for the card inside a VM having passed through the one controller, whilst it helped performance even more - it caused the VM to crash the entire of UNRAID host so best to not install those.


Lastly to pass through I followed the following guide via the IOMMU method. Hope this helps!


Share this post

Link to post

Code for passing through the first port for me is (obviously your port numbers may vary):


    <hostdev mode='subsystem' type='pci' managed='yes'>
      <driver name='vfio'/>
        <address domain='0x0000' bus='0x09' slot='0x00' function='0x0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x08' function='0x0'/>

Share this post

Link to post

I am not sure my motherboard has an ACS setting.  When I reboot to install 6.5.1 I will check.  I am thinking that maybe my MB is too old for this type of card.  I also had a hard time with USB 3.1 cards.  I finally settle on two USB 3 card which currently is working.  If I get it working I will update this post.

Share this post

Link to post

So, I had a number of problems with other cards:


I tried one other 4 port usb with dedicated channels so could forward to each VM which I just couldn't get unraid to recognise/work with


1. Startech PEXUSB3S44V 4 Port PCI Express (PCIe) SuperSpeed USB 3.0 Card Adapter with 4 Dedicated 5Gbps Channels, UASP, SATA / LP4 Power


Also had problems with a number of other standard usb hubs which didn't have dedicated channels with only some ports working for specific actions e.g. booting unraid but this seem to be due to a limitations of the total Number of usb port addresses that unraid or the bios was accepting to be allocated which the dedicated channels solved.



So I suppose your mileage could vary but though it didn't work for me, try the startech one

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.