Mono is running at 100%


Recommended Posts

Running 6.3.4


I noticed that when I run top in CLI, mono is running at 100%.  I've narrowed it down to Sonarr causing it, because when I stop sonarr, mono goes away.. or at least stops running at 100%.


I checked the logs in Sonarr and it doesn't seem to be doing anything... actually it's pretty idle(no downloads, no scanning..) when I checked, but no matter what Sonarr seems to be doing, it causes Mono to run at 100% from the second I start it up, and runs at 100% for days on end.


I checked the logs on the docker image itself and it doesn't seem to be doing anything.  I've seen where some people found the docker continuing to try to auto update when it's already updated.. or it keeps trying to start the docker when it's already running, but that doesn't seem to be what's going on with my setup.

Link to comment
  • 4 years later...
29 minutes ago, TheMannequin said:

Every found a solution? This is the only thread I found with my exact issue...

You have to narrow it down to which exact container its coming from and then ask within it's support thread (click on the icon, select Support)

Link to comment
  • 1 year later...

Few months now I have been experience this problem with Mono running on 100% cup and soon as I stop Sonarr the cup returns to normal idle levels. Now I am having to reboot Sonarr daily to stop the fan on the server waking the neighbours in the adjoining apartment. 


Currently Running Unraid 6.11.5 

Sonarr Version -

Package Version - by sonarr

Mono Version - 6.12.0


Any resolve to this please I am not able to find any guidance. Any assistance will be gratefully welcomed. 

Edited by theplayhub
Link to comment
  • 2 weeks later...

Hi I am having the same issue,


I have tried setting the path to the cache /mnt/cache_nvme/appdata rather than /mnt/user/appdata but still see the 100% usage on a single core, I am unable to find any info in the support thread either unfortunately.




Edited by ravepants
Link to comment
  • 1 month later...
Posted (edited)

Thank you for all you help. I don't have any cache setup at the moment, I do intend to do this at some point. But I have just done as @ravepants mentioned and unticked Analyse Video Files.

will monitor and report back. 


Its already looking promising but this creams up over the hours and the fans kick in. So will let it rest for the day and see how it holds. 



Thanks again.



Sadly no fix for me. After leaving it for 12 hrs the CPU has risen again. I placed Sonarr on the CPU 15 and 31 to monitor and its already hitting 85%. If I don't restart Sonarr now the fans will start blowing.



Back to the hunt to find solution.


Edited by theplayhub
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.