[Plugin] CA Appdata Backup / Restore v2


Squid

Recommended Posts

17 minutes ago, Squid said:

On my system they are readable by group and world.  (6.10)

 

Either way, backup sets on the update now have explicit permissions of 0777 set

Wow thanks for the update!

Link to comment
On 7/21/2022 at 10:39 PM, BRiT said:

If you already have it installed you can look at the php files itself.

I must be looking in the wrong place, as cat'ing the files associated with the plugin in /boot shows zero commands.

Where do you see the raw commands being ran?

Link to comment
36 minutes ago, boomam said:

I must be looking in the wrong place, as cat'ing the files associated with the plugin in /boot shows zero commands.

Where do you see the raw commands being ran?

That's not the installed to directory.

 

Look under /usr/local/emhttp/plugins/ hierarchy, that will have plugins installed.

Edited by BRiT
Exact directory of plugins installed into
  • Upvote 1
Link to comment

The backup started at 3 am 7/25 (and per the settings shut down the containers)

You noticed that nothing was running at 6:37 and started them up

 

The backup finished at 7:45am and then started the verification of the backup (per your settings)

 

At 8:44 the verify was finished and it would have restarted them at that time.

 

What's the size of the appdata folder?

Link to comment
23 hours ago, Squid said:

Your backup is slower than a herd of turtles (and nowhere near the speed of a scalded haint)

 

I'd start a backup manually and watch the output tab and see what's going on.

Yeah, looks to be the Plex server - there is a lot of metadata and images that are taking a lot of time.

Thanks for helping me to work it out - I will set it to start earlier in the morning.

Link to comment
18 hours ago, thesmackdown said:

Thanks for helping me to work it out - I will set it to start earlier in the morning.

 

Assuming the speed bottleneck is array write you could use the CA Auto Turbo Write Mode plugin to enable Turbo mode on a schedule coincident with your backup.

  • Like 1
Link to comment
  • 2 weeks later...

Hi,

 

I am on Unraid Version: 6.10.0-rc4 and try to use the CA Backup / Restore Appdata. Worked fine the first time when I used it in v 6.9. in february, now on version from 2022.07.23. I hit the backup button and it does something for 3 secs, but it does not create any new backup file in the appdata backup. See below message image.thumb.png.525a4514b1301c585879ef2f98a85a80.png

 

What could be the cause ? Absolutely no change since last backup ? - I doubt it. Any pointers would be much appreciated.

 

Thx !

Link to comment

Hello Squid,

 

While your plugin has been quietly doing its thing for a while and only I only required 1 or 2 restores over the last three years (which have been flawless, thanks!) - I've now come back from a vacation to a system that may have gone through a few power surges while I was gone.  All appeared fine except a dead Plex installation and when I tried restoring from a backup, nothing happens in the UI, and the log shows:

Aug 18 14:11:53 Tower atd[2834]: PAM unable to dlopen(/lib64/security/pam_unix.so): /lib64/libc.so.6: version `GLIBC_2.34' not found (required by /lib64/libresolv.so.2)
Aug 18 14:11:53 Tower atd[2834]: PAM adding faulty module: /lib64/security/pam_unix.so
Aug 18 14:11:53 Tower atd[2834]: Module is unknown

 

I'm on 6.9.2

 

Any thoughts?

Link to comment

Question on the Restore -

 

Is there a way to restore the "Appdata" folder for just one docker. I ran into an issue with one of my dockers and feel this may be the best way to handle; however, I don't want to restore every docker/file --- just the ones specific to the docker that had an issue. 


Thanks!

Link to comment
On 8/18/2022 at 2:22 PM, another_hoarder said:

Hello Squid,

 

While your plugin has been quietly doing its thing for a while and only I only required 1 or 2 restores over the last three years (which have been flawless, thanks!) - I've now come back from a vacation to a system that may have gone through a few power surges while I was gone.  All appeared fine except a dead Plex installation and when I tried restoring from a backup, nothing happens in the UI, and the log shows:

Aug 18 14:11:53 Tower atd[2834]: PAM unable to dlopen(/lib64/security/pam_unix.so): /lib64/libc.so.6: version `GLIBC_2.34' not found (required by /lib64/libresolv.so.2)
Aug 18 14:11:53 Tower atd[2834]: PAM adding faulty module: /lib64/security/pam_unix.so
Aug 18 14:11:53 Tower atd[2834]: Module is unknown

 

I'm on 6.9.2

 

Any thoughts?

I have the same issue and i am on 6.10.3
just found out (with horror) my backup is at 0

 

# ls -al Appdata/2022-08-22\@07.00/
total 0
drwxrwxrwx 1 root   root  38 Aug 22 07:02 ./
drwxrwxrwx 1 nobody users 94 Aug 22 07:02 ../
-rwxrwxrwx 1 root   root   0 Aug 22 07:02 CA_backup.tar.gz*

anybody else have this issue ?

Link to comment

[UPDATE]

  1. Un-install UD preclear , reboot, error gone 
  2. for the CA_backup.tar.gz at 0B 

After troubleshoot i found out CA Backup/ Restore Apdata was silently failing with no indication of issue

CA Backup/ Restore Apdata was reporting backup complete without any error

Aug 29 07:41:41 unraid CA Backup/Restore: #######################
Aug 29 07:41:41 unraid CA Backup/Restore: appData Backup complete
Aug 29 07:41:41 unraid CA Backup/Restore: #######################

in the log

Backup/Restore Complete. tar Return Value: 0


but running the exact same command manually
give me
(yes i change the target file to not erase the automated one)

cd '/mnt/apps/appdata/' && /usr/bin/tar -cvaf '<redacted for privacy>/CA2_backup.tar.gz' *
...
snipped for summary
...
/bin/sh: line 1: gzip: command not found
/usr/bin/tar: <redacted for privacy>/CA2_backup.tar.gz: Wrote only 4096 of 10240 bytes
/usr/bin/tar: Child returned status 127
/usr/bin/tar: Error is not recoverable: exiting now


clearly not zero

even the Diff for "verication" did not return error even with a gz file at 0B 

really surprise 
just reporting for information , after reinstalling gzip via nerdztools (i am investigating why it disapear ) all is good
[Edited] i have to note i am using pigz from nerdz-pack and it is where gizip was missing but still.... CA Backup/ Restore Apdata should have report the failure.... is it a bug ?

 

thanks

Edited by ZappyZap
Link to comment
2 hours ago, ZappyZap said:

after reinstalling gzip via nerdztools (i am investigating why it disapear ) all is good
[Edited] i have to note i am using pigz from nerdz-pack and it is where gizip was missing

NerdPack is deprecated on 6.11. See its thread for suggested workaround.

Link to comment
5 minutes ago, trurl said:

NerdPack is deprecated on 6.11. See its thread for suggested workaround.

that's i know.... and it is not the issue here...
still do not explain why CA backup/Restore failed silently ..... and did not catch the tar error 
 

Link to comment

[SOLVED] - changed 'user' to 'cache'. Went from 480GB to 58GB. 

 

I have these three paths in my excluded field, yet I don't think they are being excluded. Can anyone see a typo or a problem. 

 

They are end to end, comma separated, and no space after the comma. I only word wrapped them for this post. 

 

/mnt/user/appdata/Plex/Library/Application Support/Plex Media Server/Cache,
/mnt/user/appdata/Plex/Library/Application Support/Plex Media Server/Media,
/mnt/user/appdata/Plex/Library/Application Support/Plex Media Server/Metadata

 

EDIT: I need a / at the end of each path, don't I?

EDIT 2: Nope, no change.

 

[SOLVED] - changed 'user' to 'cache'. Went from 480GB to 58GB. 

Edited by rmeaux
Link to comment

I was prepping for a possible new unRAID server to add to my existing two. I'm thinking of migrating my TV shows to their own server, and movies only on the one that currently serves both. I started looking at the plugins I would want and noticed that I can no longer find the CA Appdata Backup/Restore v2 plugin from the Apps tab.

 

Has it been deprecated or pulled for some reason? Is there a recommended alternative if it's no longer available? I can make my own scripts but found the plugin just does the job quite well.

  • Like 3
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.