** VIDEO GUIDE ** How to setup an OpenVPN server on unRAID for secure remote connections UPDATED GUIDE DEC 2017 **

Recommended Posts

Hi I decided to make an updated guide to replace my old OpenVPN video. You will see how to install and configure linuxserver.io's OpenVPN-as as a docker container in unRAID. This is so you can securely connect to your server from a remote location. You will see how to create users, remove the default admin account and stop it being recreated,forward the correct ports and connect with a client.
Hope its useful :)


  • Like 1
Link to comment
  • 9 months later...



I have followed your video and i can connect to the openvpn that I installed in docker and on my pc, what do i need to do now so i can configer my sever when i'm not home and also put files on my raid system. Because when I go in finder I dont see my unraid server .  do I need to do somthing on my pc to add the server and when I click go to nameSERVER.ducknds.org:943 it takes me to the openVPN webUI. and not to my webUI of unraid 


Link to comment
  • 4 months later...

I seem to have set this up properly, but when trying to access the server remotely I'm directed to a "Luma" web login interface instead of my unRaid server login (I have a separate Luma NVR box on my network, but it has a different port forwarded at the router)...


Any tips on what I'm doing wrong? My port forwarding seems to be setup properly in my router, but no luck getting to the unRaid server remotely.

Link to comment
  • 3 weeks later...
  • 1 month later...

I have OpenVPN-as installed and operating as a container, but I had to manually add the INTERFACE line for bond0 and when i go to the webui it says "Unable to Connect". rather than the certificate / insecure error.  any ideas why I'm hitting this?


I was able to move past that!  But not sure how.


Although now, since OpenVPN is on 2.7.3, the UI is vastly different, and I do not see a place to generate a VPN config file.  Any ideas there?


Resolved as well by going to the container and removing /admin/ from the URL, brought a different logon page and was able to create profile.


Edited by rmd85871516
Link to comment

Great Video I've got this up and running flawlessly. I use it mainly to access blocked sites while at work. Is there a way to setup OpenVPN Community Edition on UnRaid? The OpenVPN-as only allows 2 concurrent connections. Myself, my wife, and a friends cant all be connected at once with this version. Thank you.

Link to comment



I have two questions:


1) In the video it states "host" for the Docker config (in a screenshot). The default ist "Bridge". If changing to "host" the server is not starting correctly. Should I keept it to "bridge"?


2) I have a special requirement in addition to connecting from outside to my environment. I am using PiHole + OpenDNS to secure the internet for my kids. Onmy firewall I am only allowing the PiHole DNS IPs and the OpenDNS IPs. But sometimes I need to disable this. Therefore I want to connect from internally to OpenVPN, getting a different IP and DNS config and allow then the new IP (or a whole new network) to be unrestricted. 

Is this possible?


Best Regards,


Link to comment



I have made the normal Setup as shown in the video (with "BRIDGE"). I can successfully connect from external.


But now the funny thing about my second requirement. It is at least working for iOS.


*) iOS: When I am in my WLAN without OpenVPN connected, I have a secured internet connection. No Drugs, Porns,... sites.

As soon as I am starting OpenVPN I have full access.

It seems it is working, because my UnRaid Server is also unrestricted. It seems the iPhone is using then the IP of the UnRaid server to communicate with externals - so this is OK


*) Windows: I can establish a OpenVPN Connection from my Intranet, but as soon as it is active I have still access to my internal IPs, but no access to public IPs anymore. It seems Windows is behaving differently compared to iOS... Any ideas?



Link to comment

After updating the docker and being unable to connect to my unraid server I started fresh.

I have completed all the steps, I can connect to my server from work using openvpn but I have no access to anything as before.


Any thing I can try ? as I have no idea of what can be wrong.







Edited by zzgus
Link to comment
  • 9 months later...

Another fantastic video from Spaceinvader One. This set up perfectly and I have full access to my home network and all docker webUIs remotely. My issue is I want to use my home internet connection for remote web browsing but when I am connected the the OpenVPN server my connection reports no internet access. I can browse the web fine, but I am using the local connection not my home connection. In other words no tunnel, just two separate connections, one for internet and one for my home unRAID. I have been experimenting with the DNS Settings and when I manually set them to CloudFlare I am at least using their DNS (per However I am also running piHole docker and when I point the DNS in OpenVPN to either my router (which points to piHole) or directly to piHole I lose my internet connection over the VPN and reports the local ISP's DNS. Any suggestions on configuring openVPN and piHole to allow remote tunneling for browsing the web over my home connection when remote?


Thanks in advance.

Link to comment
  • 2 months later...

Dont know if it the right place to post my issue, but i will try.


Using spaceinvaders video i could get OpenVPN Server running on my unraid and it worked flawlessly with my domain till something broke. cant figure out the issues on my own.


I think it has to do somethign with CNAME entries at my Namecheap domain provider


i have following entries


CNAME entry 1    Host: www Value: mydomain.com


A+ dynamic DNS Entry  @ and my static ip


i am not using duckdns and it have been working till now without any problems


i try to use openvpn on my phone to login into my home network and it is "Looking up for DNS" all the time


any ideas from the community for this? dont want to start messing around with duckdns




P.S. used duckdns and it works, just would like to know how i messed up the namecheap settings ;(


Edited by un4given
Link to comment
  • 5 months later...
On 10/7/2018 at 2:12 PM, Squid said:

Easiest is to just navigate to the IP address of the server instead of it's name.

That works to access the Unraid UI, however I'm unable to connect to my files via Windows Explorer using either server name or IP. Any tips on this as I've searched the forum and not really found a resolution. Thanks!

Link to comment
1 hour ago, bsimonian said:

That works to access the Unraid UI, however I'm unable to connect to my files via Windows Explorer using either server name or IP. Any tips on this as I've searched the forum and not really found a resolution. Thanks!

Have you tried using the WireGuard solution yet?

Link to comment
  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.