Jump to content
linuxserver.io

[Support] Linuxserver.io - airsonic

166 posts in this topic Last Reply

Recommended Posts

On 4/9/2019 at 9:45 PM, saarg said:

I didn't have any issues with dlna here when I had it enabled. 

Any chance you want to enable it again, verify it's working properly, then wait and see what happens after a few days to weeks?

Share this post


Link to post
6 hours ago, dboonthego said:

Any chance you want to enable it again, verify it's working properly, then wait and see what happens after a few days to weeks?

Then I won't have any access to it as I reverse proxy it using its own bridge. Have to move it to a separate bridge giving it an IP if I'm enabling dlna. 

 

Probably better to ask the airsonic devs about it as they make it ght have a clue what is going on. 

Share this post


Link to post

I changed over to this version from binhex but unable to acess airsonic through nginx which I was able to on the the binhex version. This is my config, any change that I dont know about?

server {
    listen 443 ssl;
    listen [::]:443 ssl;

    server_name music.*;

    include /config/nginx/ssl.conf;

    client_max_body_size 0;

    # enable for ldap auth, fill in ldap details in ldap.conf
    #include /config/nginx/ldap.conf;

    location / {
        # enable the next two lines for http auth
        #auth_basic "Restricted";
        #auth_basic_user_file /config/nginx/.htpasswd;

        # enable the next two lines for ldap auth
        #auth_request /auth;
        #error_page 401 =200 /login;
        
        include /config/nginx/proxy.conf;
        resolver 127.0.0.11 valid=30s;
        set $upstream_airsonic airsonic;
        proxy_pass http://192.168.0.50:4040;
    }

 

Share this post


Link to post
11 minutes ago, mkono87 said:

I changed over to this version from binhex but unable to acess airsonic through nginx which I was able to on the the binhex version. This is my config, any change that I dont know about?


server {
    listen 443 ssl;
    listen [::]:443 ssl;

    server_name music.*;

    include /config/nginx/ssl.conf;

    client_max_body_size 0;

    # enable for ldap auth, fill in ldap details in ldap.conf
    #include /config/nginx/ldap.conf;

    location / {
        # enable the next two lines for http auth
        #auth_basic "Restricted";
        #auth_basic_user_file /config/nginx/.htpasswd;

        # enable the next two lines for ldap auth
        #auth_request /auth;
        #error_page 401 =200 /login;
        
        include /config/nginx/proxy.conf;
        resolver 127.0.0.11 valid=30s;
        set $upstream_airsonic airsonic;
        proxy_pass http://192.168.0.50:4040;
    }

 

You probably didn't remove the CONTEXT_PATH variable.

Share this post


Link to post
4 hours ago, saarg said:

You probably didn't remove the CONTEXT_PATH variable.

Ah! I knew there was something I forgot. Thanks.

Share this post


Link to post

Hey all. In the past week all of the sudden Airsonic has stopped working for me. Won't load at all just get a "This site can't be reached" message. I have't changed any settings or done anything with Unraid. Looking through the logs I see several errors that seem to relate to java, but the big one says "application failed to start". I am attaching logs and configuration. Thanks

Capture.PNG

log.txt

Share this post


Link to post
47 minutes ago, Dizzy810 said:

I am attaching logs

Go to Tools - Diagnostics and attach the complete diagnostics zip file to your next post.

Share this post


Link to post
7 minutes ago, Dizzy810 said:

Here you go.

Your docker image isn't currently full, but the fact that you have given it 100G makes me wonder if you have had problems filling it in the past. If you have your docker applications correctly configured it is extremely unlikely you would ever need even 20G.

 

Also, your system share has files still on disk10.

 

Delete and recreate it at 20G then reinstall your dockers with the Previous Apps feature on the Apps page.

Share this post


Link to post
13 hours ago, trurl said:

Your docker image isn't currently full, but the fact that you have given it 100G makes me wonder if you have had problems filling it in the past. If you have your docker applications correctly configured it is extremely unlikely you would ever need even 20G.

 

Also, your system share has files still on disk10.

 

Delete and recreate it at 20G then reinstall your dockers with the Previous Apps feature on the Apps page.

Done. Still won't load. The reason I had it so high was when I first started using Unraid I didn't know any better and I thought the appdata was also going to be stored in the docker image. I quickly learned that it was a mistake, but with 1tb cache drive I wasn't to concerned.

 

I have attached update logs.

tower-diagnostics-20190421-0724.zip

Share this post


Link to post

You still have some of system share on disk10. That shouldn't cause any particular problem, it will just mean that parity has to get involved for writes to that share (and they may be frequent), slowing things down, and disk10 and parity may not be able to spin down since files in that share may be in constant use.

 

You would have to disable docker and VM services so none of that share's files are open, then run mover to get the files moved to cache where they belong. You can always find out which disks are used by each share by using the Compute feature on the User Shares page.

 

I don't use this specific docker so you may need to wait for someone else to help on that.

Share this post


Link to post

Iv noticed when I enable dlna and restart it does not get saved. Any ideas?

Share this post


Link to post
On 6/18/2019 at 7:24 AM, mkono87 said:

Iv noticed when I enable dlna and restart it does not get saved. Any ideas?

It appears like the checkbox does not correctly indicate if DLNA is enabled or disabled, but the setting does save for me.  10.2.1 did not work this way.  This behavior must be new to 10.3.1.  

 

If you get it working, I'd be curious to know how long your server stays functional with it enabled.  I've been dealing with a 24-48 max uptime before Airsonic becomes unresponsive.

Share this post


Link to post

Every time I update the container I have to remove the context path /airsonic as I dont use that. Is there a way to edit the template or do I need to use the binhex version container?

Share this post


Link to post
7 hours ago, mkono87 said:

Every time I update the container I have to remove the context path /airsonic as I dont use that. Is there a way to edit the template or do I need to use the binhex version container?

You have to turn on the authoring mode in docker settings, then remove the template url in the airsonic template and disable authoring mode again.

Share this post


Link to post
On 8/2/2019 at 5:10 PM, saarg said:

You have to turn on the authoring mode in docker settings, then remove the template url in the airsonic template and disable authoring mode again.

Thanks appreciate it

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.