(Solved) 6.3.5 Unraid server becomes unresponsive – cpu 100 – cold reboot only option


Recommended Posts

8 minutes ago, Switchblade said:

In the shrink array instructions, why do I need steps 7 and 8?  If I have already deleted all files, the drive should be empty and parity good.


Yes - parity is good. With the drive still part of the array.

But if you skip step 7 and 8, then you will have invalid parity the same moment you remove the drive.


It's by zeroing the drive you will be able to remove the drive without rebuilding parity.

So only that route will maintain parity protection through the task.

Link to comment

First disk is complete.  Holly crap you were not kidding, took about 30 hours to copy 4.9tb.


Here is the summary part from the end of the output file:


sent 4,881,463,720,150 bytes  received 1,625,786 bytes  48,715,517.38 bytes/sec
total size is 4,880,266,563,432  speedup is 1.00 


Verify info:


sending incremental file list

sent 3,680,474 bytes  received 7,142 bytes  63.49 bytes/sec
total size is 4,880,266,563,432  speedup is 1,323,420.49 (DRY RUN) 


No errors and it looks like all files are there.  I am confused by the above end report, showing bytes "received"??  However the bytes sent is correct.


I went ahead and stopped the array, changed disk1 to xfs, started, formatted and now I'm running rsync again for the next drive.  This will take over a week at this rate, but at least I'm on my way.


I have a couple of other questions for you guys, and I'm just curious what you guys are running.


For SMB user shares, what split level do you guys like?  I have a mix of Top level only, none, and then split all you want.  Of course this means my data is spread accross all drives.  I don't mind splitting it, but it seems might be good to limit to maybe just 3 upper directories, or even Top level.  Thanks in advance for sharing.  :)


Oh, last question.  Do you guys leave Disk shares enabled?  The default permissions is Public, so no security.  I just realized mine was set this way.  All this time I thought I had my server locked down, meanwhile disk shares are wide open.  I want to just disable disk shares, after I'm done with this conversion.  I only connect to user shares.


Thanks again!


Edit:  I forgot to ask about leaving SMB shares active during the copy process.  I have left SMB shares enabled, yet the only access to any files would be Movie players with read only access.  Is this a issue to allow read only SMB access during the copy process, or should I just disable SMB shares until done?



Edited by Switchblade
Link to comment
  • 2 weeks later...

fs conversion completed, took 13 days.  Everything went as planned, even the last part to remove the extra drive.  The only issue was that when I ran a parity check at the very end, my 2nd parity disk was out of sync, meaning I had a bunch of parity errors for parity disk 2 only.  All good after the parity check and I have verified I lost no files.


Extra info for those interested:


Leaving read only access via smb shares was fine and did not cause any issues.

I put split level to auto, split as the system wants to

I turned off disk shares, don't use disk shares.


I will run the server for a month, maybe two and if no errors return, I will assume this was indeed related to the older file system and doing the xfs conversion fixed it.  If no issues, I will mark this thread resolved.


Thanks again for the support!


Edited by Switchblade
Link to comment
  • 1 month later...



Server has been up for 48 days without one single issue.  I will assume the fs conversion did the trick and I also noticed increase in performance.  File transfers and even deleting files is faster now.  Today i upgraded to 6.5 and had to reboot, still everything looks good.


Thanks again for the help guys!


Edited by Switchblade
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.