Jump to content
binhex

[Support] binhex - NZBHydra2

52 posts in this topic Last Reply

Recommended Posts

On 9/13/2019 at 1:55 AM, djgizmo said:

hmmm... 

 

I'm unable to access the webgui and my other dockers are unable to communicate with my Hydra2 instance.   It shows running in Unraid, however the log shows...
 


�[2m2019-09-12 20:52:39.950�[0;39m �[31mERROR�[0;39m �[2m---�[0;39m �[2m[ main]�[0;39m �[36morg.nzbhydra.NzbHydra �[0;39m �[2m:�[0;39m�[35m �[0;39m�[34m�[0;39mAn unexpected error occurred during startup

org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'entityManagerFactory' defined in class path resource [org/springframework/boot/autoconfigure/orm/jpa/HibernateJpaConfiguration.class]: Invocation of init method failed; nested exception is org.hibernate.boot.archive.spi.ArchiveException: Unable to extract bytes from InputStream
Caused by: java.io.IOException: Input/output error

 

Suggestions?

ive just run up the latest image and container starts without issue, so i can only assume one of the following:-

 

1. bad config - check your configuration files located in /config/, did you change any config recently?, if you have a backup of your config then try a restore.

2. bad upgrade - as new versions are released there is sometime the requirement to upgrade the database or change config entries, its possible this has broken nzbhydra2 for you, the only way out of this will again be a restore of your config, or delete everything on /config for this container and reconfigure nzbhydra2 from scratch.

Share this post


Link to post
1 minute ago, pro9c3 said:

is the /data path supposed to be my downloads directory for nzbs?

/data path should be the path where your download client (such as nzbget or sabnzbd) is monitoring for nzb's (sometimes called blackhole), if you aren't using blackhole for your download client then you do not require /data.

Share this post


Link to post
1 minute ago, binhex said:

/data path should be the path where your download client (such as nzbget or sabnzbd) is monitoring for nzb's (sometimes called blackhole), if you aren't using blackhole for your download client then you do not require /data.

wow, insanely fast response, thanks!   I'm not using blackhole for nzb just nzbget so I will ignore the /data path then.*

Share this post


Link to post

I just updated binhex-NZBHydra2 to the latest.  Now no access to the webui and other dockers cannot communicate with binhex-NZBHydra2.  The binhex-NZBHydra2 docker log shows failed database migration and "Migration V1.21__LINK_SEARCHENTITY_TO_INDEXERSEARCHENTITY.sql failed".

 

Anyone else having any issues after upgrade?

nzbhydra2_log_clip.jpeg

Edited by DoItMyselfToo

Share this post


Link to post

Another NZBHydra2 update came through.  Deleted existing docker.  Deleted appdata.  Cleared browser cache.  Reinstalled.  Reconfigured.  Working fine.

Edited by DoItMyselfToo

Share this post


Link to post
Another NZBHydra2 update came through.  Deleted existing docker.  Deleted appdata.  Cleared browser cache.  Reinstalled.  Reconfigured.  Working fine.
Yes I can only assume a buggy release from the developer and thus they released a fixed version

Sent from my CLT-L09 using Tapatalk

Share this post


Link to post

The docker is version 2.13.7 and the latest is 2.13.13. I stopped the docker, clicked on force update but nothing was updated.

 

UPDATE: I also saw this in the log.

2020-02-17 20:47:41,626 DEBG 'start-script' stdout output:
WARNING: An illegal reflective access operation has occurred

WARNING: Illegal reflective access by com.sun.xml.bind.v2.runtime.reflect.opt.Injector (jar:file:/usr/lib/nzbhydra2/lib/core-2.13.7-exec.jar!/BOOT-INF/lib/jaxb-impl-2.3.0.jar!/) to method java.lang.ClassLoader.defineClass(java.lang.String,byte[],int,int)

WARNING: Please consider reporting this to the maintainers of com.sun.xml.bind.v2.runtime.reflect.opt.Injector

WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations

WARNING: All illegal access operations will be denied in a future release

 

Edited by opentoe

Share this post


Link to post
11 hours ago, opentoe said:

The docker is version 2.13.7 and the latest is 2.13.13. I stopped the docker, clicked on force update but nothing was updated.

 

UPDATE: I also saw this in the log.


2020-02-17 20:47:41,626 DEBG 'start-script' stdout output:
WARNING: An illegal reflective access operation has occurred

WARNING: Illegal reflective access by com.sun.xml.bind.v2.runtime.reflect.opt.Injector (jar:file:/usr/lib/nzbhydra2/lib/core-2.13.7-exec.jar!/BOOT-INF/lib/jaxb-impl-2.3.0.jar!/) to method java.lang.ClassLoader.defineClass(java.lang.String,byte[],int,int)

WARNING: Please consider reporting this to the maintainers of com.sun.xml.bind.v2.runtime.reflect.opt.Injector

WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations

WARNING: All illegal access operations will be denied in a future release

 

there was a bug introduced in my python script which i use to auto build the images, im working on a fix for it, but in the meantime the images have been triggered, so you should see a new build shortly.

Share this post


Link to post

I have been loving this docker. I have been looking for something just like this for a while. It works very well and I hope development keeps going and getting better. After I saw the stats page for the indexers I was blown away. I can now see how all my indexers are performing. I would love to donate something to this project if it still is being developed. What would be the best place to donate? I can send money/crypto, just tell me where.

 

 

Share this post


Link to post

Any idea what this means? I saw it come up after I did a search and sent everything to my downloader.

 

Sabnzbd says NZB was added successfully but didn't return an NZO ID

 

Share this post


Link to post

Hey,

Both sonarr and radarr is unable to use nzbhydra to search for shows/movies anymore. It seems to be an issue with nzbhydra. If i go to nzbhydra -> Config -> Indexers and try to check capabilites of my three indexers, all of them fail with an error message like this:

"[2m2020-03-30 21:41:50.530[0;39m [31mERROR[0;39m [2m---[0;39m [2m[0.0-5076-exec-3][0;39m [36mo.n.indexers.capscheck.NewznabChecker [0;39m [2m:[0;39m[35m [Host: 192.168.1.228] [0;39m[34m[0;39mError while accessing indexer: Error while communicating with indexer omgwtfnzbs. Server returned: java.net.SocketException: Connection reset"

 

 

Share this post


Link to post

Is anyone else having problems with his docker as of yesterday?

 

All of my indexers were "Disabled by system" and I can't get any of them to complete the manual caps check.

Share this post


Link to post
1 hour ago, akme1245 said:

2.21.0-2-01 works.  latest doesn't load for me.

Same issue, reverted to older image.

Share this post


Link to post
Posted (edited)

console into app

vi /home/nobody/start.sh

change the last line to read; cd /usr/lib/nzbhydra2 && /usr/lib/nzbhydra2/nzbhydra2wrapperPy3.py --datafolder /config/nzbhydra2

restart

 

The image has changed to python3, but the startup script is referring to a wrapper that is nolonger in the image - I assume this will be fixed in the container by the maintainer

 

Dave

Edited by Flubster
spelling

Share this post


Link to post
I thought it was just me! great but how to I revert back to an older image?
I will take a look at the issue tonight guys.

If you want to roll back then see link to documentation in first post, then unraid faq.

Sent from my CLT-L09 using Tapatalk

Share this post


Link to post
6 hours ago, Flubster said:

console into app

vi /home/nobody/start.sh

change the last line to read; cd /usr/lib/nzbhydra2 && /usr/lib/nzbhydra2/nzbhydra2wrapperPy3.py --datafolder /config/nzbhydra2

restart

 

The image has changed to python3, but the startup script is referring to a wrapper that is nolonger in the image - I assume this will be fixed in the container by the maintainer

 

Dave

Thank you for this. If anyone else is like me and needs instructions on how to edit in vi mode this article helped me: https://staff.washington.edu/rells/R110/

Share this post


Link to post
7 hours ago, Flubster said:

console into app

vi /home/nobody/start.sh

change the last line to read; cd /usr/lib/nzbhydra2 && /usr/lib/nzbhydra2/nzbhydra2wrapperPy3.py --datafolder /config/nzbhydra2

restart

 

The image has changed to python3, but the startup script is referring to a wrapper that is nolonger in the image - I assume this will be fixed in the container by the maintainer

 

Dave

 

30 minutes ago, Sloppy said:

Thank you for this. If anyone else is like me and needs instructions on how to edit in vi mode this article helped me: https://staff.washington.edu/rells/R110/

Flubster fixed worked like a charm and thanks to sloppy I was able to get through it no prob!

 

Woke up to the issue and within 20 mins had it fixed thanks to all of your support! Couldn't do it without yall and hope everyone is doing well in these weird and crazy times. Your support is appreciated more than ever! ❤️

Share this post


Link to post
11 hours ago, binhex said:

I will take a look at the issue tonight guys.

If you want to roll back then see link to documentation in first post, then unraid faq.

Sent from my CLT-L09 using Tapatalk
 

Latest update seems to have fixed it! Thanks for all you do!

<Heading to to 'buy you a long overdue beer'>

Share this post


Link to post

Hey @binhex, thanks again!  Just wanted to note though, when using the "latest" tag, the container doesn't seem to work.  Oddly though, "2.21.1-4-02" works perfectly.  I've restarted the container with both tags twice just to be sure. 

 

Thanks again for all your efforts!

Share this post


Link to post
1 hour ago, noja said:

Hey @binhex, thanks again!  Just wanted to note though, when using the "latest" tag, the container doesn't seem to work.  Oddly though, "2.21.1-4-02" works perfectly.  I've restarted the container with both tags twice just to be sure. 

 

Thanks again for all your efforts!

works fine for me, make sure you 'force update' to ensure you are running latest.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.