unRAID OS version 6.4.0 Stable Release Available


limetech

537 posts in this topic Last Reply

Recommended Posts

38 minutes ago, marcosv said:

Tried upgrading from 6.3.5 stable using updates in the plugins page.  Upon reboot, get messages about not being able to mount UNRAID.  System comes up as "tower", having lost all of my settings.  Checked the USB thumb drive; its volume label is still "UNRAID".

 

Any suggestions on how to roll back to 6.3.5?  I should have made a backup of the USB thumb drive before doing this update; but, I thought the update would go well.

 

Motherboard is an ASRock EP2C602-4L/D16.  USB 2 port is a front port hooked up to a motherboard USB header.

 

Try redoing your flashdrive, backup first, redo with v6.4 then restore the config folder from the backup.

Link to post
  • Replies 536
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Download   If you are running a previous stable release, clicking 'Check for Updates' on the Plugins page is the preferred way to upgrade. If you are running a 6.4.0-rc, click 'Check fo

Not criticizing. It's just that simple answers to simple questions often lead to more questions, some of which may have already been answered.   By the way, we are all mostly just volunteers

For PFSense if you're using unbound dns resolver just put into custom options and this will work correctly server: private-domain: "unraid.net"  

Posted Images

The upgrade process from 6.3.5 to 6.4 went smoothly but I'm having a weird logging issue when starting one of my VM's with an Intel HD Graphics passthrough. It loads on the monitor ok but I'm getting a flood of these errors in the unraid log:

 

Jan 14 01:18:50 Tower kernel: vfio-pci 0000:00:02.0: BAR 2: can't reserve [mem 0xd0000000-0xdfffffff 64bit pref]

 

It seems to be filling up my /var/logs folder 100% completely. I've attached my diagnostics zip. What could be causing this issue now?

 

 

tower-diagnostics-20180114-0125.zip

Link to post
11 hours ago, gar13 said:

I get request timeout for  any host on my network trying to ping google dns

 

That is the issue. Before obtaining the plugin information a quick ping test is done to the google DNS server to ensure network connectivity. If this test fails no further reading is done.

 

Reconfigure your pfsense router to allow pings to 8.8.8.8 from local devices.

Link to post
8 hours ago, cybrnook said:

Small graphical anomalies with the new "Azure" theme (Dashboard):

 

5a5ac1fe3594b_unraidazuretheme.jpg.741f33407c3b2b615351f33ae3890e3f.jpg

 

This is a browser artifact and happens when browser scaling is set larger than 100%. Different browsers give different results when scaling.

Edited by bonienl
  • Like 2
Link to post
7 hours ago, Zonediver said:

Found also an issue with the new interface - its a gray transparent area with a green bar.

 

grey area.jpg

 

Choosing the right combination of banner and theme makes a difference.

image.thumb.png.ca2b487d2f5abc81b1fe4f05ec89f6c9.png

image.thumb.png.c6f5853a4834fa5c0ce41d1b7b8f2a81.png

Edited by bonienl
Link to post
18 minutes ago, Zonediver said:

@bonienl: Has the banner a different size now? What means the "right" combination?

 

Depending on your screen resolution the banner can be made wider than the original width of 1270px.

Themes white and black go up to 1920px, while themes azure and gray use the full screen width for the banner.

 

"Right" in this context simply means when choosing a GUI theme some banners display better than others, but it is all personal preference.

Link to post
12 minutes ago, MrLondon said:

Hi I successfully upgraded to 6.4 and then used the option with Letsencrypt SSL certificate, but now I seem to be unable to connect to the docker databases? Is there anything I need to change in these dockers?

 

There is nothing specific to change for accessing docker containers. What exactly happens?

Link to post
2 minutes ago, bonienl said:

 

Depending on your screen resolution the banner can be made wider than the original width of 1270px.

Themes white and black go up to 1920px, while themes azure and gray use the full screen width for the banner.

 

"Right" in this context simply means when choosing a GUI theme some banners display better than others, but it is all personal preference.

 

Thanks for this hint - i use Azure and Grey (verry cool by the way xD) and my Screen has a resolution of 1680x1050 - so what shall i choose for the banner width? 1680?

Link to post

When I am trying to update my headless Kodi box which is using MariaDB I am getting from sickbeard this message back:

 

2018-01-14 10:53:55 CP Server Thread-3 :: XBMC: Failed to detect XBMC version for '192.168.0.24:8088', check configuration and try again.
2018-01-14 10:41:44 CP Server Thread-3 :: XBMC: Failed to detect XBMC version for '192.168.0.24:8088', check configuration and try again.

 

also when I try to connect to the MariaDB via HeidiSQL I get the message that it is not able to connect

Link to post
1 hour ago, remati said:

The upgrade process from 6.3.5 to 6.4 went smoothly but I'm having a weird logging issue when starting one of my VM's with an Intel HD Graphics passthrough. It loads on the monitor ok but I'm getting a flood of these errors in the unraid log:

 

Jan 14 01:18:50 Tower kernel: vfio-pci 0000:00:02.0: BAR 2: can't reserve [mem 0xd0000000-0xdfffffff 64bit pref]

 

It seems to be filling up my /var/logs folder 100% completely. I've attached my diagnostics zip. What could be causing this issue now?

 

 

tower-diagnostics-20180114-0125.zip

 

Just solved the issue. It seems like enabling the UEFI unraid boot option causes the problem. Reverting back to the legacy boot option no longer floods my log files with the BAR 2 - PTE error. No idea why.

Link to post
3 minutes ago, Zonediver said:

 

so what shall i choose for the banner width? 1680?

 

Yes, in your case 1680 will exactly fit your screen when using the new themes. When the banner is smaller it will be stretched.

Link to post
6 minutes ago, MrLondon said:

When I am trying to update my headless Kodi box which is using MariaDB I am getting from sickbeard this message back:

 


2018-01-14 10:53:55 CP Server Thread-3 :: XBMC: Failed to detect XBMC version for '192.168.0.24:8088', check configuration and try again.
2018-01-14 10:41:44 CP Server Thread-3 :: XBMC: Failed to detect XBMC version for '192.168.0.24:8088', check configuration and try again.

 

also when I try to connect to the MariaDB via HeidiSQL I get the message that it is not able to connect

 

Check the port configuration of your containers.

The GUI runs by default on port 443 and is not related to Docker.

Link to post
14 hours ago, garycase said:

Noted the following on 6.4:

 

=> On the Plugins page, clicking "Check for Updates" does a check, but after it's done still shows Status: Unknown for my only plugin (Dynamix Cache Directories)

 => On the new "OS Update" page in Tools, clicking "Check for Updates" does a check, but it also shows Status: Unknown after the check.

 

 

 

Update on this:   I made NO changes;  didn't ReBoot;  didn't Stop/Restart the array; etc. => just did my usual Parity check to see if the update had any appreciable impact on parity check times (it didn't) ... BUT the Check for Updates is now working fine on both the Plugins tab and the OS Updates section.   Just thought I'd try it once more before rebooting after the parity check -- and Voila!  It works now.

 

Link to post
8 minutes ago, MrLondon said:

I figured out the IP address of my server changed but did not realise it.

 

If your router has the possibilty, make the IP address of your server fixed. That is let the router always hand out the same IP address for your server.

Link to post
On 2018-01-13 at 9:59 AM, Richard Aarnink said:

I just updated my system to 6.4.0 without any issues, it took approx 10-15 minutes

 

Brief description of my system:

- Gigabyte H270N-WIFI motherboard, 16GB DDR4 and an Intel Pentium G4560 (3,5 GHz)

- array consists of 5x 3TB WD Red HDD's and a 120GB SSD for caching

- use Docker containers for MySQL, Apache webservers, Plex and Duplicati (all work fine)

- VM are not in use (currently)

 

Update:--> Docker LetsEncrypt raises some issues, which I need to investigate. The log of this docker now reports 
 


[cont-init.d] 10-adduser: exited 0.
[cont-init.d] 20-config: executing...
sed: /etc/php7/php.ini: No such file or directory
sed: /etc/php7/php-fpm.conf: No such file or directory
sed: /etc/php7/php-fpm.d/www.conf: No such file or directory
sed: /etc/php7/php-fpm.d/www.conf: No such file or directory
[cont-init.d] 20-config: exited 0.
[cont-init.d] 30-keygen: executing...
using keys found in /config/keys
[cont-init.d] 30-keygen: exited 0.
[cont-init.d] 50-config: executing...
2048 bit DH parameters present
SUBDOMAINS entered, processing
Sub-domains processed are: -d www.<<removed by me before posting log>>
E-mail address entered: <<my email>>
Different sub/domains entered than what was used before. Revoking and deleting existing certificate, and an updated one will be created
usage:
certbot [SUBCOMMAND] [options] [-d DOMAIN] [-d DOMAIN] ...

Certbot can obtain and install HTTPS/TLS/SSL certificates. By default,
it will attempt to use a webserver both for obtaining and installing the
certificate.
certbot: error: argument --cert-path: No such file or directory
Generating new certificate
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator standalone, Installer None
Obtaining a new certificate
Performing the following challenges:
Client with the currently selected authenticator does not support any combination of challenges that will satisfy the CA.
Client with the currently selected authenticator does not support any combination of challenges that will satisfy the CA.
IMPORTANT NOTES:
- Your account credentials have been saved in your Certbot
configuration directory at /etc/letsencrypt. You should make a
secure backup of this folder now. This configuration directory will
also contain certificates and private keys obtained by Certbot so
making regular backups of this folder is ideal.
ERROR: Cert does not exist! Please see the validation error above. The issue may be due to incorrect dns or port forwarding settings. Please fix your settings and recreate the container

 

Found some information here, but I will need to investigate some more.

https://community.letsencrypt.org/t/solution-client-with-the-currently-selected-authenticator-does-not-support-any-combination-of-challenges-that-will-satisfy-the-ca/49983

 

Thank you very much  

I have the same issue.

I changed the port of Unraid GUI to 4443 and still the same issue. I tried even to turn off ssl but same problem.

Link to post
  • limetech unpinned and locked this topic
Guest
This topic is now closed to further replies.