Jump to content
Sign in to follow this  
johnnie.black

Sometimes posts marked as read without being actually read

14 posts in this topic Last Reply

Recommended Posts

At first I though I might have imagined it but It happened several times now, I usually click the Unread Content link and start reading threads, then click the browser back button to go back to the unread list, the last thread clicked won't be on the list no more, this is good, now I usually leave threads I believe will take more time to read/reply for the end and the problem is that sometimes, one of these threads will disappear from the unread list without me reading it, this has happened at least 5 or 6 times and makes me wonder if other threads are masked ar read without me noticing, I know this is probably hard to diagnose but I'm sure there's a problem, I'm not crazy :)

Share this post


Link to post

I have seen the same.

 

I might have 3 unread.

I click the third and read.

Return to the list and have no unread.

Open the other two (no longer marked) threads and they contain unread content at the end.

 

I'm using Chrome.

 

I think I see it more now than a month ago - might it have anything to do with the much more common spam deletions?

Share this post


Link to post
55 minutes ago, pwm said:

I'm using Chrome.

Firefox here.

 

55 minutes ago, pwm said:

might it have anything to do with the much more common spam deletions?

Pretty sure I've seen this before the spam invasion.

Share this post


Link to post
1 minute ago, johnnie.black said:

Pretty sure I've seen this before the spam invasion.

I have seen it before the spam invasion too.

 

Just have a feeling I might see it more lately than one month ago.

 

But that might also be because I have visited much more threads and subfora.

Share this post


Link to post

Happens to me as well. If you go to the "normal" forum view, you will see which subforums contain unread content by the icon change, yet unread lists clear. It's been happening to me since the forum change.

 

My suspicion is that it has to do with the filters, because the forum really does know what threads you've visited, it updates the icons in the main list properly.

Share this post


Link to post

Just saw the issue again.

 

Had three unread threads.

Visited the third.

When I returned out, I had zero unread threads.

 

The topmost thread had just about at the same time received a new post.

 

So it seems like there may be some race condition between two users that results in the error.

Share this post


Link to post

I just saw another strange thing with the unread threads logic.

 

In the announce subforum, I came back out from having read all new posts in the release thread for 6.4.0.

Suddenly had two unread threads - the release thread I had just visited and the new thread with update notes.

 

Clicked once more the bullet for the release thread and got sent to the first post.

Manually clicked last page - no new post to find.

Then exited and still had the same two threads unread.

 

Repeated the same action once more with the same result.

Trying to read the announce thread just could not clear any unread bullets - and never had any unread posts to read.

 

Clicked instead on the bullet for the update notes thread.

Noticed it had received a third post - and that the first post was edited.

Exited that thread and that cleared the update notes for both the update notes thread and the 6.4.0 release thread.

 

Not sure if this is related, but the first post in the update notes thread was to my knowledge originally a post of the 6.4.0 release thread but moved into a separate thread. Does the forum get a "phantom binding" between threads when a post has been moved between threads? And will an edit of the moved post turn on "unread" for both the new and original thread?

Share this post


Link to post

Right now I have the reverse.

I have an icon showing that I have unread threads in General Support.

But if I open General Support there is no unread thread.

 

If I wait until someone makes a new post in General Support, and I read that thread, the thread doesn't show any "next unread".

 

Only way to clear this mismatch is to mark "All read" for General Support.

Share this post


Link to post

Just an FYI this is still happening, it happens so many times that I now try to just browse the forums instead of clicking the unread list or I keep missing posts that are wrongly marked as read.

Share this post


Link to post
16 hours ago, johnnie.black said:

now try to just browse the forums instead of clicking the unread list or I keep missing posts that are wrongly marked as read.

Well, this doesn't work, posts are also marked read when browsing without actually reading them, at least they do on the Bug Reports suf-forum, haven't noticed this yet on the main forums, so hopefully it's limited to that one.

Share this post


Link to post

This it still happening, every day, over a year after initial reporting, kind of disappointing it's not fixed yet.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this