[SOLVED] Missing br0 interface in GUI


Recommended Posts

unRAID 6.4.0

Supermicro - X9DRD-7LN4F with 4 NICs


I have a couple of dockers that I had setup and working that I had bridged to their own IP addresses. My NICs were all bonded together in active-backup mode. I messed around with the network setting to setup some of the NICs as separate interfaces. Somewhere in this process the br0 interface was deleted/disappeared. I put everything back to the way it was before (I think), but the br0 is gone from the GUI. Here's a sample from the log file;


Jan 23 10:47:25 asok root: pihole: Error response from daemon: network br0 not found Error: failed to start containers: pihole

And some screenshots below.


Reboot server a few times, started and stopped docker and VM service many times...


How do I get br0 back?









Edited by subagon
added content
Link to comment

Some more info after reading this post https://lime-technology.com/forums/topic/61006-how-to-setup-ips-for-dockers/


root@asok:~# docker network ls
NETWORK ID          NAME                DRIVER              SCOPE
32176c05a279        bridge              bridge              local
7ce2002afcd5        host                host                local
5b8a210f2546        none                null                local
root@asok:~# docker network create -d macvlan --subnet= --gateway= -o parent=br0 br0
Error response from daemon: network dm-2f4a429bc5a3 is already using parent interface br0
root@asok:~# docker network rm dm-2f4a429bc5a3
Error response from daemon: network dm-2f4a429bc5a3 not found


Link to comment



One more question...


As I said, my motherboard has 4 NICs. I now have eth0 setup to bridge and therefore have the br0 interface. I've turned off bonding (this server is in my home and I don't need redundancy). So I now have the following interfaces showing up on the Network Setting page;


  • br0
  • br1
  • eth2
  • br3


I want to use br0, br1, and br3 for various dockers plus file sharing off of eth0/br0. I'd like to put Plex on eth2 all by itself.


The problem is I can only see Bridge, Host, None, and br0 when editing the Plex (or any) docker. I tried the commands you provided above, but without any luck. How can I add br1,eth2, and br3 to the drop down list or manually edit the Plex docker file to use eth2?



Edited by subagon
Link to comment

You'll need to have an IP assigned to the interface you want to show up Docker network drop down. This will be fixed in a future release according to @bonienl

Or you'll need to have the docker network manually recreated every startup of the docker service.

caveat: If you have multiple interfaces with ip addresses in the same subnet (and are physically on the same LAN), some protocols are known to misbehave - I think Samba (Windows File Shares) is one of those. This is because broadcast and discovery sometimes get confused.

caveat: The host cannot talk to dockers on the same interface as itself, so if br0 has an IP of, br1 has an IP of, container A is on br1 with ip of Container A will fail to talk to and vice versa. This is by design. Container A needs to talk to unRAID using and only. However, any protocol that uses discovery and broadcasting will potentially be confused and try to use the wrong IP at times, resulting in flaky behavior.


To manual create a docker network and use it with the Plex docker container see this topic:


Edited by ken-ji
Corrected the reference post with details for 6.4
Link to comment
  • 3 months later...
  • 2 months later...

This fixed my issue.

On 1/23/2018 at 5:59 PM, bonienl said:


Do the following to let docker rebuild the networks

rm /var/lib/docker/network/files/local-kv.db
/etc/rc.d/rc.docker restart



Yes I also get the same issue but it is actually the Docker Execution error I am getting. 



Edited by witalit
Link to comment
  • 1 month later...
11 minutes ago, ken-ji said:

Post you diagnostics file. I'm guessing there's something wrong in your config that's causing the docker to treat the br0 network as a custom definition and possibly purging it. You might also want to provide the screenshot of your docker network settings 'Settings | Docker'




Edited by H2O_King89
Link to comment
1 minute ago, ken-ji said:

This is weird. Other than the proxynet bridge, did you create any other bridges by cli?

because the bridges in your network interfaces (from the diags) named br-* do not line up with those the docker is reporting... only docker networks of type bridge can be seen with the ifconfig -a

Maybe @bonienl has some idea...


just that proxy net and have reboot with no issues for months then reboot a few days ago and started having this issue and found this topic.

Link to comment
  • 6 months later...

Hi guys


I am getting the same issue, after changing motherboard to a supermicro C9-X299 PG-300F. The solution to restart the docker network works, but only untill reboot, then I have to manually do it again. Did you guys get it solved for you?


One thing that might be a clue is that on boot I get this message "RTNETLINK answers: Network is down". It waits for a bit but then proceeds to boot.

I have tried to disable all but one network interface (using LAN2, the one with shared IPMI) and I have disabled all VLANS.


Anyone has any ideas?

Link to comment
  • 4 months later...
  • 1 month later...
On 8/14/2019 at 3:27 AM, jpowell8672 said:

Started having this same exact problem today for the first time, one problem after another lately.

did you ever find a solution? this problem just started for me. its like docker service starts before the system gets ip address assigned and can't start br0,br1, or any bridge what so ever.

Edited by letrain
Link to comment
27 minutes ago, letrain said:

did you ever find a solution? this problem just started for me. its like docker service starts before the system gets ip address assigned and can't start br0,br1, or any bridge what so ever.

I had to rebuild the docker network stack:


rm /var/lib/docker/network/files/local-kv.db

/etc/rc.d/rc.docker restart


but then on reboot br0 would be gone again so I then deleted my docker image:


Settings>Docker - Advanced View - Enable Docker: No - Delete The Image File Check Box - Apply - Enable The Service - Apply


Followed By


Apps Tab, Previous Apps Section - Check off all your previously installed apps and install them via the button.


So far this has fixed it for me on reboots.

Link to comment
Don't know what that would have to do with it but I am also running a pfsense vm.

I was thinking that since docker starts before pfsense vm can get going it wasn't handing out ip's so the bridges weren't able to be seen by docker. It's worked in the past, I just figured it was that. I just tried rebooting again and custom br0 and br1 aren't persisting even though the docker settings have it set for persisting after reboot... My Dockers with proxynet presist but proxynet is not listed as an option when creating a container unless I restart docker...   

Is it because I'm using br1 instead of br0?



Edit: I solved it by giving eth0 and eth1 static ip addresses.


Sent from my Pixel 2 XL using Tapatalk








Link to comment
  • 3 months later...

Hi all, I'm an Unraid noob (6.8.1) but am loving the change and soaking up as much as I can so thank you for all the info! Anyhoo, I'm having this exact issue with my Unifi Controller docker; losing the defined IP address after server restart. Its the only one configured to use BR0, the rest being bridge/host. In my situation the setting is lost only upon server restart, however it resolves itself if I simply stop/start the docker.


EDIT: Only after I hardcoated my IP on the Unraid server did this resolve; it was previously using a DHCP reservation.

Edited by walchst
Link to comment
  • JorgeB changed the title to [SOLVED] Missing br0 interface in GUI

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.