Jump to content
Djoss

[Support] Djoss - FileBot

398 posts in this topic Last Reply

Recommended Posts

Yep, just remove your credentials from the opensubtitles portion of the docker template, save and restart.

Share this post


Link to post

I am running into an issue with permissions and it doesn't seem to pop up in this thread via search. 

 

I have 3 shares:

1 - Temporary storage place on my cache drive (/mnt/user/temp_files)

2 - Movies folder (/mnt/user/Movies)

3 - TV Shows folder (/mnt/user/TV Shows)

 

I have my Docker container setup to pass (/mnt/user) to the container as (/storage). When I bring up the WebUI I can configure FileBot to pull my media files from the folder on my Cache drive and tag them, but when I try to copy them to the parity protected share on the array I get an error. I tried using move in FileBot first and it created all the folders, but never moved the content. When I switch to copy I get the following error:

4.png.d531d50ca87a6fe50b6e50d46f831605.png

 

I am a little lost as to what to do.

Share this post


Link to post

Hoping iI can get some help. When I start the docker everything loads and it goes through the /watch directory and lists each item as [amc] input: /watch/filename

 

However it doesn't process anything.  I am licensed. 

Share this post


Link to post
10 hours ago, ati said:

I am running into an issue with permissions and it doesn't seem to pop up in this thread via search. 

 

I have 3 shares:

1 - Temporary storage place on my cache drive (/mnt/user/temp_files)

2 - Movies folder (/mnt/user/Movies)

3 - TV Shows folder (/mnt/user/TV Shows)

 

I have my Docker container setup to pass (/mnt/user) to the container as (/storage). When I bring up the WebUI I can configure FileBot to pull my media files from the folder on my Cache drive and tag them, but when I try to copy them to the parity protected share on the array I get an error. I tried using move in FileBot first and it created all the folders, but never moved the content. When I switch to copy I get the following error:

4.png.d531d50ca87a6fe50b6e50d46f831605.png

 

I am a little lost as to what to do.

how does this part looks like

 

image.thumb.png.e1a5a43d2c4abdf8542cba37b0eb4bf6.png

Share this post


Link to post
4 hours ago, Stizuner said:

Hoping iI can get some help. When I start the docker everything loads and it goes through the /watch directory and lists each item as [amc] input: /watch/filename

 

However it doesn't process anything.  I am licensed. 

may take a look at your logs what filebot does (or better doesnt do), there should be some infos ...

 

when u where playing and setting up, may take a look at your amc-exclude list due they ve been processed earlier ... and now skipped.

Share this post


Link to post
7 hours ago, alturismo said:

how does this part looks like

 

image.thumb.png.e1a5a43d2c4abdf8542cba37b0eb4bf6.png

I am not using any automation, I am trying to do it all manually inside FileBot, so they're all blank. Do I need them even if I am not using the AMC script? 

Share this post


Link to post
4 hours ago, ati said:

I am not using any automation, I am trying to do it all manually inside FileBot, so they're all blank. Do I need them even if I am not using the AMC script? 

well, i only use automation so ...

 

but u could try from inside container, just try to move something the way filebot would do, may that brings u closer

 

open docker shell, cd /storage, check what u see and try to move things there

Share this post


Link to post
19 hours ago, alturismo said:

well, i only use automation so ...

 

but u could try from inside container, just try to move something the way filebot would do, may that brings u closer

 

open docker shell, cd /storage, check what u see and try to move things there

Works fine in shell. Issue appears to be with FileBot...

 

/tmp # cd /storage/temp_files/

/tmp # touch testfile

/tmp # cp testfile /storage/Movies/

/tmp # ls /storage/Movies/ | grep test
testfile

 

Share this post


Link to post
14 hours ago, ati said:

Works fine in shell. Issue appears to be with FileBot...

 


/tmp # cd /storage/temp_files/

/tmp # touch testfile

/tmp # cp testfile /storage/Movies/

/tmp # ls /storage/Movies/ | grep test
testfile

 

and you also have /storage in your webui settings in output format ?

 

you always have to think from docker point of view ... may take a look there.

Share this post


Link to post
On 9/5/2020 at 3:26 PM, ati said:

I am running into an issue with permissions and it doesn't seem to pop up in this thread via search. 

 

I have 3 shares:

1 - Temporary storage place on my cache drive (/mnt/user/temp_files)

2 - Movies folder (/mnt/user/Movies)

3 - TV Shows folder (/mnt/user/TV Shows)

 

I have my Docker container setup to pass (/mnt/user) to the container as (/storage). When I bring up the WebUI I can configure FileBot to pull my media files from the folder on my Cache drive and tag them, but when I try to copy them to the parity protected share on the array I get an error. I tried using move in FileBot first and it created all the folders, but never moved the content. When I switch to copy I get the following error:

4.png.d531d50ca87a6fe50b6e50d46f831605.png

 

I am a little lost as to what to do.

Do you have a typo somewhere ?  The error message says "/stroage" instead of "/storage".

Share this post


Link to post
13 hours ago, Djoss said:

Do you have a typo somewhere ?  The error message says "/stroage" instead of "/storage".

My word, that is embarrassing. That was it. Thank you.

Share this post


Link to post

Dear fellow unraiders, 

 

FileBot repo: jlesage/filebot

 

I have the license file (.psm) in the /config path of the unraid filebot docker, but it is still not recognizing it. I get this in the logs:
"[amc] LicenseError: Unauthorized" 

 

The file states the license is valid until January 2021 and the permissions are 777 for the file. I have reinstalled the docker and the issue persists. 

 

Any help 

Share this post


Link to post
On 9/9/2020 at 5:53 AM, guruleenyc said:

Dear fellow unraiders, 

 

FileBot repo: jlesage/filebot

 

I have the license file (.psm) in the /config path of the unraid filebot docker, but it is still not recognizing it. I get this in the logs:
"[amc] LicenseError: Unauthorized" 

 

The file states the license is valid until January 2021 and the permissions are 777 for the file. I have reinstalled the docker and the issue persists. 

 

Any help 

Could you provide the output of:

docker exec FileBot /opt/filebot/filebot -script fn:sysinfo

 

Share this post


Link to post
20 hours ago, Djoss said:

Could you provide the output of:


docker exec FileBot /opt/filebot/filebot -script fn:sysinfo

 

Here you go:

 

script fn:sysinfo
FileBot 4.9.1 (r7372) JDK8
JNA Native: 5.2.2
MediaInfo: 18.08.1
p7zip: p7zip Version 16.02 (locale=en_US.UTF-8,Utf16=on,HugeFiles=on,64 bits,24 CPUs Intel(R) Xeon(R) CPU           X5670  @ 2.93GHz (206C2),ASM,AES-NI)
unrar: UNRAR 5.61 freeware
Chromaprint: 1.4.3
Extended Attributes: OK
Unicode Filesystem: OK
Script Bundle: 2020-08-14 (r671)
Groovy: 3.0.3
JRE: OpenJDK Runtime Environment 1.8.0_242
JVM: 64-bit OpenJDK 64-Bit Server VM
CPU/MEM: 24 Core / 22 GB Max Memory / 228 MB Used Memory
OS: Linux (amd64)
HW: Linux 7b4e03ef6b56 4.19.107-Unraid #1 SMP Sun Mar 8 14:34:03 CDT 2020 x86_64 GNU/Linux
STORAGE: btrfs [/] @ 34 GB | fuse.shfs [/output] @ 5 TB | btrfs [/config] @ 283 GB | fuse.shfs [/storage] @ 5 TB | fuse.shfs [/watch] @ 5 TB | btrfs [/etc/resolv.conf] @ 34 GB | btrfs [/etc/hostname] @ 34 GB | btrfs [/etc/hosts] @ 34 GB
DATA: /config
Package: DOCKER
License: Unauthorized
Done ヾ(@⌒ー⌒@)ノ

Share this post


Link to post
1 hour ago, guruleenyc said:

Here you go:

 

script fn:sysinfo
FileBot 4.9.1 (r7372) JDK8
JNA Native: 5.2.2
MediaInfo: 18.08.1
p7zip: p7zip Version 16.02 (locale=en_US.UTF-8,Utf16=on,HugeFiles=on,64 bits,24 CPUs Intel(R) Xeon(R) CPU           X5670  @ 2.93GHz (206C2),ASM,AES-NI)
unrar: UNRAR 5.61 freeware
Chromaprint: 1.4.3
Extended Attributes: OK
Unicode Filesystem: OK
Script Bundle: 2020-08-14 (r671)
Groovy: 3.0.3
JRE: OpenJDK Runtime Environment 1.8.0_242
JVM: 64-bit OpenJDK 64-Bit Server VM
CPU/MEM: 24 Core / 22 GB Max Memory / 228 MB Used Memory
OS: Linux (amd64)
HW: Linux 7b4e03ef6b56 4.19.107-Unraid #1 SMP Sun Mar 8 14:34:03 CDT 2020 x86_64 GNU/Linux
STORAGE: btrfs [/] @ 34 GB | fuse.shfs [/output] @ 5 TB | btrfs [/config] @ 283 GB | fuse.shfs [/storage] @ 5 TB | fuse.shfs [/watch] @ 5 TB | btrfs [/etc/resolv.conf] @ 34 GB | btrfs [/etc/hostname] @ 34 GB | btrfs [/etc/hosts] @ 34 GB
DATA: /config
Package: DOCKER
License: Unauthorized
Done ヾ(@⌒ー⌒@)ノ

Please verify/confirm that /mnt/user/appdata/FileBot/license.psm is the right license.  If yes, you should contact FileBot support directly, since the issue seems to be the license itself.

Share this post


Link to post
On 9/11/2020 at 7:25 AM, Djoss said:

Please verify/confirm that /mnt/user/appdata/FileBot/license.psm is the right license.  If yes, you should contact FileBot support directly, since the issue seems to be the license itself.

The license.psm is the file I received from them directly and the contents show it does not expire until January 2021. I'll try and find their contact info... 

Share this post


Link to post
On 9/11/2020 at 7:25 AM, Djoss said:

Please verify/confirm that /mnt/user/appdata/FileBot/license.psm is the right license.  If yes, you should contact FileBot support directly, since the issue seems to be the license itself.

The issue resolved itself after replacing the license file. No obvious differences noticed in file. 

Thank you, 

 

Share this post


Link to post

UPDATE: I resolved it by removing the docker, deleting the appdata folder and reinstalling with restore of license key. 

 

Any idea why I am getting this error and nothing is processing? 

 

 

[amc] java.lang.IllegalArgumentException: DUPLICATE not in [MOVE, COPY, KEEPLINK, SYMLINK, HARDLINK, CLONE, DUPLICATE, TEST]
[amc] at net.filebot.StandardRenameAction.forName(Unknown Source)
[amc] at net.filebot.cli.ArgumentBean.getRenameAction(Unknown Source)
[amc] at net.filebot.cli.ScriptShellBaseClass.getRenameAction(Unknown Source)
[amc] at net.filebot.cli.ScriptShellBaseClass.rename(Unknown Source)
[amc] at Script1$_run_closure66.doCall(Script1.groovy:364)
[amc] at Script1.run(Script1.groovy:350)
[amc] at net.filebot.cli.ScriptShell.evaluate(Unknown Source)
[amc] at net.filebot.cli.ScriptShell.runScript(Unknown Source)
[amc] at net.filebot.cli.ArgumentProcessor.runScript(Unknown Source)
[amc] at net.filebot.cli.ArgumentProcessor.run(Unknown Source)
[amc] at net.filebot.Main.main(Unknown Source)
[amc]
[amc] Error (o_O)

Edited by guruleenyc

Share this post


Link to post
 

The cli version of Filebot (/usr/bin/filebot.sh) can be used via the "docker exec" command or via the container's shell.  Is it what you want?

The filebot.sh is not in that path. Where can I find the amc script or how do I change the output folder to output\TV instead of output\TV Shows ? 

 

 

Edited by guruleenyc

Share this post


Link to post

IllegalArgumentException
java.util.concurrent.ExecutionException: java.lang.IllegalArgumentException
at net.filebot.ui.rename.RenamePanel$AutoCompleteAction$1.done(Unknown Source)
Caused by: java.lang.IllegalArgumentException
at net.filebot.ui.rename.EpisodeListMatcher.match(Unknown Source)
at net.filebot.ui.rename.RenamePanel$AutoCompleteAction$1.doInBackground(Unknown Source)
at net.filebot.ui.rename.RenamePanel$AutoCompleteAction$1.doInBackground(Unknown Source)

28/09/2020 15:11:40 got closure, reason 1001
28/09/2020 15:11:40 rfbProcessClientNormalMessage: read: Connection reset by peer
28/09/2020 15:11:40 client_count: 0
28/09/2020 15:11:40 Restored X server key autorepeat to: 1
28/09/2020 15:11:40 Client 127.0.0.1 gone
28/09/2020 15:11:40 Statistics events Transmit/ RawEquiv ( saved)
28/09/2020 15:11:40 ServerCutText : 1 | 8/ 8 ( 0.0%)
28/09/2020 15:11:40 FramebufferUpdate : 179 | 0/ 0 ( 0.0%)
28/09/2020 15:11:40 LastRect : 24 | 288/ 288 ( 0.0%)
28/09/2020 15:11:40 tight : 675 | 247912/ 18019192 ( 98.6%)
28/09/2020 15:11:40 TOTALS : 879 | 248208/ 18019488 ( 98.6%)
28/09/2020 15:11:40 Statistics events Received/ RawEquiv ( saved)
28/09/2020 15:11:40 PointerEvent : 196 | 1176/ 1176 ( 0.0%)
28/09/2020 15:11:40 FramebufferUpdate : 180 | 1800/ 1800 ( 0.0%)
28/09/2020 15:11:40 SetEncodings : 1 | 52/ 52 ( 0.0%)
28/09/2020 15:11:40 SetPixelFormat : 1 | 20/ 20 ( 0.0%)
28/09/2020 15:11:40 TOTALS : 378 | 3048/ 3048 ( 0.0%)
28/09/2020 15:11:40 destroyed xdamage object: 0x20002c

Share this post


Link to post

Can you tell me how filesystem monitoring works for the /watch directory? Is there an interval? I know there is a pause before processing, but it seems that it takes quite a while for AMC to realize there is a directory change and process it.

Edited by TX_Pilot

Share this post


Link to post
On 9/25/2020 at 6:22 PM, guruleenyc said:

UPDATE: I resolved it by removing the docker, deleting the appdata folder and reinstalling with restore of license key. 

 

Any idea why I am getting this error and nothing is processing? 

 

 

[amc] java.lang.IllegalArgumentException: DUPLICATE not in [MOVE, COPY, KEEPLINK, SYMLINK, HARDLINK, CLONE, DUPLICATE, TEST]
[amc] at net.filebot.StandardRenameAction.forName(Unknown Source)
[amc] at net.filebot.cli.ArgumentBean.getRenameAction(Unknown Source)
[amc] at net.filebot.cli.ScriptShellBaseClass.getRenameAction(Unknown Source)
[amc] at net.filebot.cli.ScriptShellBaseClass.rename(Unknown Source)
[amc] at Script1$_run_closure66.doCall(Script1.groovy:364)
[amc] at Script1.run(Script1.groovy:350)
[amc] at net.filebot.cli.ScriptShell.evaluate(Unknown Source)
[amc] at net.filebot.cli.ScriptShell.runScript(Unknown Source)
[amc] at net.filebot.cli.ArgumentProcessor.runScript(Unknown Source)
[amc] at net.filebot.cli.ArgumentProcessor.run(Unknown Source)
[amc] at net.filebot.Main.main(Unknown Source)
[amc]
[amc] Error (o_O)

Try again to set the "Automated Media Center: Action" in container's settings.  Do not use copy-paste: sometime, with Windows, invisible characters are added...

Share this post


Link to post
On 9/25/2020 at 7:25 PM, guruleenyc said:

The filebot.sh is not in that path. Where can I find the amc script or how do I change the output folder to output\TV instead of output\TV Shows ? 

Look at "Automated Media Center: TV Series Format" in container's setting. 

See https://www.filebot.net/naming.html for more details.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.