Jump to content
Djoss

[Support] Djoss - FileBot

173 posts in this topic Last Reply

Recommended Posts

Thanks man. I'll give it a shot. I chose hardlink though because I've read that it will create a copy of the files, then I could delete the original set and they would still seed. Will they still seed if i use --action move?

Share this post


Link to post

ah okay, for this a hardlink could be the right way but don't know as i don't use torrent. If discspace is not a problem you can use the copy function. 

Share this post


Link to post
18 hours ago, hgN said:

Maybe I misunderstood you or you didn’t know what I try to achieve So my plan is to automate my DL and renaming workflow. I don’t want to enter the Filebot UI after each download. Therefor I use the FB CLI command filebot.sh --funnyrenaming-flags etc pp. inside the Filebot container. 

Now when a DL is finish I want to use the JD Event Script to call this filebot command but as the containers don’t see each other it’s of curse not possible therefor I use the bypass with SSH.

Ok I see.  In this case I currently don't see another way to trigger FileBot.  Are you using the AMC script to do the renaming?

Share this post


Link to post
7 hours ago, Djoss said:

Are you using the AMC script to do the renaming?

yes. 

ok maybe i try to create a own image if i found a bit time :)

Share this post


Link to post

Adding support for the AMC script is still in by todo list...

Share this post


Link to post

Ran into a strange issue using the [{crc32}] attribute during the matching/fetching process.

When you do the initial fetch it is only adding the brackets [] to the file name.  Not the actual crc info inside of the brackets.

 

But before you go and select rename....you can go to the edit format option.  Then without changing anything just click "use format".

It updates the name correctly with the crc32 like its supposed to. 

 

I thought it might be a error in my format....so i deleted it and just used {n} [{crc32}] and got the same results as described above.

 

Thanks
Urlryn

Share this post


Link to post
20 hours ago, Urlryn said:

Ran into a strange issue using the [{crc32}] attribute during the matching/fetching process.

When you do the initial fetch it is only adding the brackets [] to the file name.  Not the actual crc info inside of the brackets.

 

But before you go and select rename....you can go to the edit format option.  Then without changing anything just click "use format".

It updates the name correctly with the crc32 like its supposed to. 

 

I thought it might be a error in my format....so i deleted it and just used {n} [{crc32}] and got the same results as described above.

 

Thanks
Urlryn

Do you have any message in the container's log related to this?  If not, I would suggest to report the issue on the FileBot forum.

Share this post


Link to post
12 hours ago, Djoss said:

Do you have any message in the container's log related to this?  If not, I would suggest to report the issue on the FileBot forum.

I will try and take a look sometime this week!  I'll post anything I find up.

Also quick question...how do you see what version is currently installed?  Console you can just do filebot -version from cmd line. but wasn't sure how to pull that within docker or the UI.


Thanks

Urlryn

Share this post


Link to post
11 hours ago, Urlryn said:

I will try and take a look sometime this week!  I'll post anything I find up.

Also quick question...how do you see what version is currently installed?  Console you can just do filebot -version from cmd line. but wasn't sure how to pull that within docker or the UI.


Thanks

Urlryn

You can look at the container's log.  The FileBot information is displayed during startup.

Share this post


Link to post

Does this container also support any headless folder watch based renaming based on a AMC script?

Share this post


Link to post
On 4/27/2019 at 3:33 AM, Diggewuff said:

Does this container also support any headless folder watch based renaming based on a AMC script?

Not yet!

Share this post


Link to post
On 4/30/2019 at 8:48 PM, Djoss said:

Not yet!

i really would appreciate if it would sometime in the future since coppits doesnt really gets updated anymore it seems and your webui is way better.

Share this post


Link to post
On 5/16/2019 at 12:44 PM, DaLeberkasPepi said:

i really would appreciate if it would sometime in the future since coppits doesnt really gets updated anymore it seems and your webui is way better.

Yes this will for sure be done :)

Share this post


Link to post
Posted (edited)

I see that the creator of FileBot rednoah has a docker image with the "filebot-watcher" implemented.

 

docker run --rm -it -v $PWD:/volume1 -v data:/data rednoah/filebot:watcher /volume1/input --output /volume1/output

 

I've tried to make this work with out any success.

here is my docker config;

image.thumb.png.3cf8e4bd6aa60d3aea1d141afc027521.png

 

But after I start the docker image the log just shows this;

image.png.e5a27f76e10761cf76f24688ee85b501.png

 

Anyone else have any luck? Am I doing something wrong?

 

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Update

So I played with this a bit more and have it working now. Not sure this is all correct but its working;

Here is the docker config;

image.thumb.png.11ff302cbcb1323cb4ae22c9b94c8efc.png

 

The "Post Arguments:" commands reference a config file "/data/args.txt" that contains this; (Thanks to this post:https://www.filebot.net/forums/viewtopic.php?t=5422)

****************************************************************************

music=n
excludeList=/data/amc_exclude.txt
clean=y
artwork=n
extras=n
unsorted=y
pushover=XXXXXXXX
subtitles=en
musicFormat=Music/{n}/{album+'/'}{pi.pad(2)+' - '}{artist} - {t}
seriesFormat=TV/{plex.tail}
movieFormat={plex}

****************************************************************************

 

And YES I did have to buy a universal license for FileBot for this to work.

Thanks

Edited by Merkas
Resolved

Share this post


Link to post
Posted (edited)

Hey There,

 

Maybe I am just dumb, but every time I got to rename files it says a license is required.  Am I missing something?

 

Any help would be appreciated.

 

Edit:  NVM I see your update saying a license is now required, and instructions to the old Donation version.  Going to give the dono a shot before committing.  Thanks for the great Docker!

Edited by WhatPlantsCrave

Share this post


Link to post
On 7/9/2019 at 10:24 PM, Merkas said:

I see that the creator of FileBot rednoah has a docker image with the "filebot-watcher" implemented.

 

docker run --rm -it -v $PWD:/volume1 -v data:/data rednoah/filebot:watcher /volume1/input --output /volume1/output

 

I've tried to make this work with out any success.

here is my docker config;

image.thumb.png.3cf8e4bd6aa60d3aea1d141afc027521.png

 

But after I start the docker image the log just shows this;

image.png.e5a27f76e10761cf76f24688ee85b501.png

 

Anyone else have any luck? Am I doing something wrong?

 

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Update

So I played with this a bit more and have it working now. Not sure this is all correct but its working;

Here is the docker config;

image.thumb.png.11ff302cbcb1323cb4ae22c9b94c8efc.png

 

The "Post Arguments:" commands reference a config file "/data/args.txt" that contains this; (Thanks to this post:https://www.filebot.net/forums/viewtopic.php?t=5422)

****************************************************************************

music=n
excludeList=/data/amc_exclude.txt
clean=y
artwork=n
extras=n
unsorted=y
pushover=XXXXXXXX
subtitles=en
musicFormat=Music/{n}/{album+'/'}{pi.pad(2)+' - '}{artist} - {t}
seriesFormat=TV/{plex.tail}
movieFormat={plex}

****************************************************************************

 

And YES I did have to buy a universal license for FileBot for this to work.

Thanks

Has this been stable for you?

 

I use Coppit's container, but every once in a while it flakes out and i have to rebuild it.

Share this post


Link to post
On 5/24/2019 at 2:40 AM, Djoss said:

Yes this will for sure be done :)

Nice, is this still something that will happen?

Share this post


Link to post
On 10/10/2019 at 7:38 AM, Sic79 said:

Nice, is this still something that will happen?

Yes, it's finally there :)

 

Share this post


Link to post
9 hours ago, Djoss said:

Yes, it's finally there :)

 

Nice to hear, thank you :)

Share this post


Link to post

Is the AMC script capable of symlinking? I have Radarr and Sonarr setup, but I really miss the symlinking abilities of SickGear and Couchpotato. If I could get the symlinking functionality back for both Radarr and Sonarr , I would be so happy.

 

I'm also a little lost on how to call the script. I set the parameters for your docker but in all the examples of the script ive seen, theres also an /input and /output on the script as well. How would I do that for two separate apps? I would appreciate any help, im a little overwhelmed right now.

Edited by DazedAndConfused

Share this post


Link to post
On 10/17/2019 at 2:47 PM, DazedAndConfused said:

Is the AMC script capable of symlinking? I have Radarr and Sonarr setup, but I really miss the symlinking abilities of SickGear and Couchpotato. If I could get the symlinking functionality back for both Radarr and Sonarr , I would be so happy.

Yes, the script can symlink.

On 10/17/2019 at 2:47 PM, DazedAndConfused said:

I'm also a little lost on how to call the script. I set the parameters for your docker but in all the examples of the script ive seen, theres also an /input and /output on the script as well. How would I do that for two separate apps? I would appreciate any help, im a little overwhelmed right now.

It seems that I forgot to document the input and output folders... But this is now done.  Update the template by clicking the "Check for updates" button at the bottom of the Docker page.  Then, edit the container settings and you will have the ability to map the input and output folders.

Share this post


Link to post

It looks like the last Variable is labeled as custom, but is actually for choosing Subtitle Language.  I've tried adding the -non-strict argument after creating the AMC_CUSTOM_OPTIONS key, but it doesn't seem to be working for me.

 

I'm doing so in response to this error without -non-strict:

 

[amc] CmdlineException: Multiple options: Advanced auto-selection requires -non-strict matching

Share this post


Link to post
6 hours ago, Nomar1245 said:

It looks like the last Variable is labeled as custom, but is actually for choosing Subtitle Language.

I fixed the template.  Just update it (click the "Check for updates" button at the bottom of the Docker page).

 

6 hours ago, Nomar1245 said:

I'm doing so in response to this error without -non-strict:

 

[amc] CmdlineException: Multiple options: Advanced auto-selection requires -non-strict matching

 

If will add the -non-strict option by default.  It seems to be required is most cases...

Share this post


Link to post

UPDATE:

There is actually a bigger problem that I just realized.

When I start Filebot docker in UNRAID, it stops almost instantaneously.

Why can I not start Filebot docker?

 

 

 

*****OLD POST

Hello,

I cannot find filebot.conf file in order to activate webGUI to yes

 

I was running filebot by jlesage on UNRAID v6.7.x without issues. Then I updated Filebot, then updated UNRAID OS to 6.8, and was using filebot for few days. Then filebot wouldn't restart one day. Then I tried updating filebot, didn't work. Then I deleted filebot, and folder under appdata/filebot, then reinstalled filebot.

 

I cannot run filebot in Web UI, because I cannot find filebot.conf file anywhere in appdata folder on UNRAID, in order to set WebUI to "yes".

 

Where do I find filebot.conf, to set web UI to "yes"?

Alternatively, what am I doing wrong so much that I cannot access WebUI on default port 7813?

 

Below is image from folder "appdata"

 

Thanks.

 

 

filebot.jpg

Edited by emod

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.