[Support] telly - IPTV on Plex Live TV


Recommended Posts

yeah if I have telly setup on it's own (without tvhproxy) it is available and I can edit the channels etc, I am still around 200 channels though so nowhere near the 400 cache problems area! 

 

Is there a way I can get those templates/settings you showed on the previous post?

 

Cheers again!

Link to comment

Hi, I get this Error: "m3u files need to have specific formats, see the github page for more information"

My plde.m3u has this content

 

#EXTM3U

#EXTINF:-1 tvg-id="" tvg-name="SHOW" tvg-logo="http://xxx.xxx.tv:8080/logos/usa%20cbs%20hd.png" group-title="United States",SHOW
http://p2.xxx.com:8080/live/11052017/11052017/97.ts

 

 

OK. SOLVED, Tom helps me. False URL Link in the config.

Edited by suender
Link to comment
  • 2 weeks later...
  • 2 weeks later...

i got it working

docker run 
-d 
--name telly 
-p 6077:6077/tcp 
-v /home/lbeavisc/appdata/telly/tmp:/tmp 
-e PLAYLIST="http://live.eternaltv.net:25461/get.php?username=USERNAME&password=PASSWORD=m3u_plus&output=ts" 
-e USEREGEX="USA|USA-PREMIUM MOVIE" 
-e STREAMS=1 
-e FRIENDLYNAME="Tuner1" 
-e DEVICEID="12345678" 
-e TEMP="/tmp" 
-e PUID=1000 
-e PGID=1000 
-e LISTEN=172.17.0.11:6077 
tombowditch/telly

i added the puid and pgid and quotes on the temp dir and added the docker container ip

Link to comment

Hi Guys,

 

using a url with more than 4500 channels I have lots of issues. I tried to slim down with the USEREGEX option but not really working for me. I decided to edit my m3u file and add only 20 channels (to see if it works). I check it and with VLC is working with no issues, so I copied in /mnt/cache/appdata/telly/channel and I started the docker.

At this point is not working at all and I am not able to start the docker (is perfectly working if I paste the url even than I have issues with the channels).

Any suggestion?

Link to comment

I've seen hints that you can run two instances of Telly to provide Plex with two tuners so you can watch one show and record another.  I tried setting that up by installing Telly docker twice with different names and setting them to different ports.  I wasn't successful in getting that to work.  When I look at the response from hitting the Telly URL for each port, I get an identical response so I don't think Plex is seeing them as different sources:

 

1 0 http://0.0.0.0:6077 urn:schemas-upnp-org:device:MediaServer:1 telly Silicondust HDHR-2US HDHR-2US uuid:12345678

 

I have one set up as port 6077 and one as 6078.

 

Is is possible to set up two instances of Telly that Plex will see as two different tuners?  I don't see anything more in the docker template that would allow me  to differentiate the two...

Edited by elmn8r
Link to comment
  • 2 weeks later...

Since two days I try to get this docker working. I do receive the same error always:

 

[telly] [info] booting telly v0.5
[telly] [info] Reading m3u file /mnt/user/Daten/Plex/Test.m3u...
[telly] [error] unable to read m3u file, error below
[telly] [error] m3u files need to have specific formats, see the github page for more information
[telly] [error] future versions of telly will attempt to parse this better
panic: Unable to open playlist file

goroutine 1 [running]:
main.main()
/go/src/app/main.go:193 +0x1b62

The only thing regarding the m3u file I found on Github is a missing comma after the '-1'. But I do have these commas in there.

 

Looking at the source code (link below) Telly should output more specific outputs. Is it possible that this docker has not been updated?

 

https://github.com/tombowditch/telly-m3u-parser/blob/master/m3u.go

 

What's wrong with my attempts? What's the exact m3u-format this docker needs?

 

Many thanks in advance.

 

 

#EXTM3U
#EXTINF:-1,Das Erste HD
http://xxx.xxx.xxx.xxx:xxxx/folder/folder/file.ts
#EXTM3U
#EXTINF:1,Das Erste HD
http://xxx.xxx.xxx.xxx:xxxx/folder/folder/file.ts
#EXTM3U
#EXTINF:-1,Das Erste HD
rtp://xxx.xxx.xxx.xxx@:xxxx@xxx.xxx.xxx.xxx:xxxx

 

Link to comment
On 5/5/2018 at 3:08 PM, manolodf said:

It is, but you do have to assign them different Device ID, and I even have different name and Device Auth in there.

Hey , I was wondering how you did this? my provider supports 4 simultaneous streams and I'm looking to get 4 up!

 

any help would be great thanks!

Link to comment
  • 2 weeks later...
On 5/10/2018 at 3:09 AM, tayshun12 said:

Hey , I was wondering how you did this? my provider supports 4 simultaneous streams and I'm looking to get 4 up!

 

any help would be great thanks!

 

Tayshun12,

 

manolodf(thanks for that!!) actually gave us the solution earlier in the thread.  I didn't catch on right away.  You have to edit your template and add the Name, DeviceID, and DeviceAuth variables.  The values can be whatever you want them to be as long as they are unique to each device.

 

On 3/13/2018 at 7:13 PM, manolodf said:

5aa85ae3e3651_Screenshot2018-03-1318_10_18.thumb.png.4c20e41c9bdb144553d5254360fbfc45.png

So maybe there is a new template, otherwise just add the variables but I have unique Device IDs and name and stuff. 

 

On 3/13/2018 at 7:18 PM, manolodf said:

I think I custom created those, can you check and see if the new template has those variables?    Otherwise just add the Device ID Variable to your template, im thinking maybe your template is older or it is not something that has made it to the official template yet. 

5aa85c3352d7f_Screenshot2018-03-1318_17_45.thumb.png.39075f4f92c1df2cb288e6730a68910e.png5aa85d05299c0_Screenshot2018-03-1318_20_01.thumb.png.07f0d6a7918592fcb12790473e9c7b2d.png5aa85d3618819_Screenshot2018-03-1318_22_04.thumb.png.f7b72951b8a196c43fa1949837cf77ef.png

 

Link to comment

You have to install an instance of Telly for each "tuner" you want to use.  For each of them, you have to edit the Telly docker template.  At the bottom there is a selection to add path, port, variable, or device.  Use this function to add Name, DeviceID and DeviceAuth variables for each Telly docker and make the values for each docker instance unique to the others.  For example, Telly1 DeviceID could be 123, Telly2 DeviceID could be 456, Telly3 DiviceID could be 789, etc. Same for the other variables.

Link to comment
  • 3 weeks later...

Good afternoon,

 

I was hoping someone could help me with configuration.  I have plex and telly installed as dockers on UNRAID.  Plex has been working well with live tv from my HDHomeRun Prime and a cable card.  I am looking to move from the cable card to an IPTV Service.  I was able to get a m3u url for testing purposes and I know all of the channels and everything works in VLC.  I installed Telly and i believe I configured it to everyones suggestions at the beginning of this thread however I am not able to get Plex to view telly for more than 1 minute.  When i go to set up telly within plex it shows up for about 1 minute then it dissappears and wont show up again unless I reboot plex and telly.

 

Is this something anyone else has run in to and if so how can I go about fixing it.

 

Thank you for the help!

Link to comment
  • 2 weeks later...
On 5/22/2018 at 3:35 PM, elmn8r said:

You have to install an instance of Telly for each "tuner" you want to use.  For each of them, you have to edit the Telly docker template.  At the bottom there is a selection to add path, port, variable, or device.  Use this function to add Name, DeviceID and DeviceAuth variables for each Telly docker and make the values for each docker instance unique to the others.  For example, Telly1 DeviceID could be 123, Telly2 DeviceID could be 456, Telly3 DiviceID could be 789, etc. Same for the other variables.

 

Unfortunately this does not work for me. After I restart Plex, I see the other telly (one I have already configured) for  a short time but when I attempt to add it, it vanishes. Also, I have manually added DEVICEID, FRIENDLYNAME and auth, as they were not in the version from the app store on Unraid. But the Tuner just is named HDHomerun(telly) and does not carry over the FRIENDLYNAME; even after multiple restarts of both Plex and the server itself. So I guess Plex does not recognize the other ID and name, even though it should, right?

Link to comment
  • 3 weeks later...

Is anyone running plex on a seperate server to their unraid box running the telly docker? I am getting playback error unable to tune channel in plex and I think its because the telly docker is setting the base URL that it lessens on to localhost rather than the IP of my unraid server. This is what I get from the telly docker log:

 

[telly] [warning] You are listening on all interfaces but your base URL is localhost (meaning Plex will try and load localhost to access your streams) - is this intended?
[telly] [info] advertising telly service on network
[telly] [debug] Advertising telly as HDHomerun (telly) (12345678-AE2A-4E54-BBC9-33AF7D5D6A92)
[telly] [info] listening on 0.0.0.0:6077

 

I have tried adding a variable of -base with a value of 192.168.1.10:6077 to the docker as telly should support the -host= command to set the base URL, but this does not seem to work and I still get the same warning in the docker log.

 

Anyone have any thoughts?

 

Thanks!

Link to comment
On 6/12/2018 at 6:10 PM, SinCityMedic said:

Good afternoon,

 

I was hoping someone could help me with configuration.  I have plex and telly installed as dockers on UNRAID.  Plex has been working well with live tv from my HDHomeRun Prime and a cable card.  I am looking to move from the cable card to an IPTV Service.  I was able to get a m3u url for testing purposes and I know all of the channels and everything works in VLC.  I installed Telly and i believe I configured it to everyones suggestions at the beginning of this thread however I am not able to get Plex to view telly for more than 1 minute.  When i go to set up telly within plex it shows up for about 1 minute then it dissappears and wont show up again unless I reboot plex and telly.

 

Is this something anyone else has run in to and if so how can I go about fixing it.

 

Thank you for the help!

Yes, I'm not sure why this happens but you get around it by adding it manually(click on the Enter it's network address manually link) and provide the IP address and port of your Telly instance.  It should allow you to continue once that's done.

Link to comment
On 6/20/2018 at 7:43 PM, RedXon said:

 

Unfortunately this does not work for me. After I restart Plex, I see the other telly (one I have already configured) for  a short time but when I attempt to add it, it vanishes. Also, I have manually added DEVICEID, FRIENDLYNAME and auth, as they were not in the version from the app store on Unraid. But the Tuner just is named HDHomerun(telly) and does not carry over the FRIENDLYNAME; even after multiple restarts of both Plex and the server itself. So I guess Plex does not recognize the other ID and name, even though it should, right?

 

 

Plex will recognize them once you have the Telly instances set up properly.  It seems that the KEY value is case sensitive.  It MUST be all caps as manolodf shows us in his screen shots.  Also, make sure your using unique values for each of the keys you're adding...

Link to comment
  • 1 month later...

Hi,

 

I recently updated Telly and now it won't start. When I check the logs this is what I see.

 

time="2018-08-13T01:25:57Z" level=info msg="Starting telly (version=, branch=, revision=)"
time="2018-08-13T01:25:57Z" level=info msg="Build context (go=go1.10.3, user=, date=)"
time="2018-08-13T01:25:57Z" level=warning msg="using default m3u option, 'iptv.m3u'. launch telly with the --iptv.playlist=yourfile.m3u option to change this!"
time="2018-08-13T01:25:57Z" level=panic msg="error getting m3u" error="open iptv.m3u: no such file or directory"
panic: (*logrus.Entry) (0xaf0d60,0xc42032a370)
 

I have no clue what that means, would someone be able to assist me please.

Link to comment

as the error explains, it doesnt find the m3u anymore ...

 

i added this to extra parameters and the error is gone, described on the docker page.

 

-e 'TELLY_IPTV_PLAYLIST'='/mnt/channel/channels.m3u'

 

while /mnt .... needs to fit your needs ;)

 

seems since the latest update the PLAYLIST Key isnt recognized anymore ...

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.