[Support] telly - IPTV on Plex Live TV


116 posts in this topic Last Reply

Recommended Posts

  • Replies 115
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Name: telly - an IPTV proxy for Plex Live TV Docker Hub: https://hub.docker.com/r/tombowditch/telly/ Git: https://github.com/tombowditch/telly unRAID template: https://github.com/tombowditch/doc

can we get a simple script to feed the EPG? IE in the telly docker add 2 more paths, One for the IPTV EPG download and the other for the .xml location. So telly would pull the EPG.gz and extract the x

This doesn't seem to be available anymore, any chance it could be re-uploaded?  thanks in advance

Posted Images

may a question to the variable stream

 

nevermind what i put there, Plex always recognizes 1 Tuner, when i now would start recordings with more then 1 stream at once ... does this even work ?

 

hard to test currently here as its almost not working at all ... i guess i would have to cleanup cause i kept another tuner there (Enigma2) and telly even as primary almost never works here, i will test this when time with only telly as tuner, but would be senseless if there would be only 1 stream possible ...

Link to post

ok, after some tests i dont get it working properly with TVH as backend.

 

mostly channels dont load, plex stops with cannot tune into channel.

 

some logs from telly, no idea if they are helpful ...

 

time="2018-08-14T05:04:00Z" level=info fields.time="2018-08-14T05:04:00Z" ipAddress=192.168.1.2 latency="136.519µs" method=GET path=/lineup.json status=200 userAgent="Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.106 Safari/537.36"
time="2018-08-14T05:04:00Z" level=info fields.time="2018-08-14T05:04:00Z" ipAddress=192.168.1.2 latency="14.652µs" method=GET path=/stream/aHR0cDovLzE5Mi4xNjguMS4yOjk5ODEvc3RyZWFtL2NoYW5uZWxpZC80MzkyMjM2NTE/dGlja2V0PWVlZjA2MDE4MzhjZjY3YWFlMmZkOTg3YzU3YzNhOTRjNzE1NDYyZTEmcHJvZmlsZT1wYXNz status=404 userAgent=Lavf/58.9.100
time="2018-08-14T05:04:06Z" level=info fields.time="2018-08-14T05:04:06Z" ipAddress=192.168.1.2 latency="45.483µs" method=GET path=/device.xml status=200 userAgent="UPnP/1.0 DLNADOC/1.50 Platinum/1.0.5.13"
time="2018-08-14T05:04:21Z" level=info fields.time="2018-08-14T05:04:21Z" ipAddress=192.168.1.2 latency="29.08µs" method=GET path=/device.xml status=200 userAgent="UPnP/1.0 DLNADOC/1.50 Platinum/1.0.5.13"
time="2018-08-14T05:04:36Z" level=info fields.time="2018-08-14T05:04:36Z" ipAddress=192.168.1.2 latency="28.637µs" method=GET path=/device.xml status=200 userAgent="UPnP/1.0 DLNADOC/1.50 Platinum/1.0.5.13"
time="2018-08-14T05:04:47Z" level=info fields.time="2018-08-14T05:04:47Z" ipAddress=192.168.1.2 latency="176.77µs" method=GET path=/lineup.json status=200 userAgent="Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.106 Safari/537.36"
time="2018-08-14T05:04:51Z" level=info fields.time="2018-08-14T05:04:51Z" ipAddress=192.168.1.2 latency="60.764µs" method=GET path=/device.xml status=200 userAgent="UPnP/1.0 DLNADOC/1.50 Platinum/1.0.5.13"

 

what makes me wonder, some channels work sometimes, some never ... i use the .m3u from 192.168.....:9981/playlist provided by tvheadend,

anything to edit there to get it working ?

 

currently i dropped back to the enigma HR Tuner proxy from my receiver, there i get ~ 100% working coverage.

TVHProxy also had some issues sometimes specially when recording, coveres ~ 90%, others are dropped recordings.

 

as i would prefer TVH as its on the same mashine it would be nice to switch away from enigma, thats why i tryed telly now.

 

may an idea what could be the reason ?

 

For an Tipp, thanks ahead ;)

 

Telly config

image.thumb.png.d5e657bc310221874f28bae7083d991f.png

 

Docker run command

 

Command: root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name='telly' --net='bridge' -e TZ="Europe/Berlin" -e HOST_OS="unRAID" -e 'TELLY_IPTV_STREAMS'='8' -e 'TELLY_IPTV_PLAYLIST'='/tmp/channels.m3u' -e 'TELLY_WEB_BASE_ADDRESS'='192.168.1.2:6077' -e '--discovery.ssdp'='true' -e 'TELLY_LOG_REQUESTS'='true' -e 'TELLY_FILTER_REGEX_MODE'='true' -e 'TELLY_WEB_LISTEN_ADDRESS'='0.0.0.0:6077' -p '6077:6077/tcp' -v '/mnt/user/appdata/telly/':'/tmp':'rw' 'tombowditch/telly' 

a8751c05a83f38ca20a47354a3a972a582c6c7ad85c2e1e1c900507c0daf4a37

The command finished successfully!

Link to post

Is it possible to run Telly (192.168.1.10) and Plex (192.168.1.11) on separate machines?  I have Telly setup using --web.listen-address=192.168.1.10:5004 and it seems to be working as it  pulls from my M3U file.  After setting up Plex DVR to point to 192.168.1.10:5004, Plex finds all the channels and loads EPG but won't play any channels.  When I visit 192.168.1.10:5004/lineup.json I can see all the channels but they have a 127.0.0.1 address which is wrong as it's referencing the localhost here rather than the address I specified so Plex cannot access the channels.

 

The reason I want them on separate machines is I run Telly over internet VPN for privacy but don't Plex on the same machine as it breaks Plex remote access.

 

edit:  just added the --iptv.direct to rempove obfuscating the address and it works.  So it looks like it doesn't work because it's presenting the localhost address?

further edit:  had to also change the --web.base-address as well and it now works

 

Many thanks!

Edited by richierich
Updated post
Link to post

hi, noob here, I've been trying to add telly to my unraid via CA, and was able to do it a couple of days ago, but now I get an error

 

 

 

Pulling image: tombowditch/telly:latest


TOTAL DATA PULLED: 0 B

 

 

Command:root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name='telly' --net='bridge' -e TZ="America/Los_Angeles" -e HOST_OS="unRAID" -e 'STREAMS'='1' -e 'PLAYLIST'='http://api.xxxx.tv/vget?username=XXXX&password=XXXX&format=ts' -e 'USEREGEX'='' -p '6077:6077/tcp' -v '/mnt/user/appdata/telly/tmp':'/tmp':'rw' 'tombowditch/telly' 

Unable to find image 'tombowditch/telly:latest' locally
/usr/bin/docker: Error response from daemon: pull access denied for tombowditch/telly, repository does not exist or may require 'docker login'.
See '/usr/bin/docker run --help'.

The command failed.

 

 

 

 

I removed some details from provider, can anyone help ? Thank you !

Link to post

The repo has changed, it is now tellytv/telly. There is also a new branch dev. If you want to use the dev branch use the tag tellytv/telly:dev or if you need ffmpeg tellytv/telly:dev-ffmpeg. If you use the new beta/dev tags then you need to create a new xml but it a simple one. Also you will need to create a telly.config.toml and add it to your mapped folder for example /mnt/user/appdata/telly.

 

You can find info or a base config file at https://github.com/tellytv/telly/tree/dev. Here is a screenshot of my xml for the new beta for people that need it.

 

TTDh2EM.png

Link to post

First, I would like to thank you Porkie, I used your first xml to run my first telly and it worked last week. Second, I see the changes that you have highlighted are significant enough for me to take the time to learn how to create a docker manually, since I have never done that, I'll take the day and try to learn how to do that today. Thank you !

Edited by djangostar
Link to post
  • 2 weeks later...

Hi all

 

I got this message when i try to installed the program

 

/usr/bin/docker: Error response from daemon: pull access denied for tombowditch/telly, repository does not exist or may require 'docker login'.
See '/usr/bin/docker run --help'.

 

 

What should i do ?

 

thx

Link to post
9 hours ago, mbc0 said:

it is looking dead I am afraid. It was great until the code changed and looks like it has gone.  I have been using xteve for about a month which does the same as telly and more I have never had an issue with it so give it a try!

I think it may have just went low-profile. Their discord is active.

Link to post
On 9/11/2018 at 7:18 AM, mbc0 said:

it is looking dead I am afraid. It was great until the code changed and looks like it has gone.  I have been using xteve for about a month which does the same as telly and more I have never had an issue with it so give it a try!

Would be awesome if someone could help out the non-techies by creating a docker for xteve or the new telly.  I'll help anyway I can to test it...

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.