Jump to content
guygg

Possible docker request - Bitwarden

9 posts in this topic Last Reply

Recommended Posts

Not sure what forum would be right for this, but thought I'd see if there were any of the docker repository geniuses around here that had taken a look at Bitwarden, which is an open source alternative to the likes of Lastpass, Dashlane and such. It has a self-hosting option via DockerHub. I messed a bit with trying to manually add it via CA's mechanism for adding an app via DockerHub, but being the first time I'd tried to do that, I was clearly in over my head. Maybe somebody who knows what the heck they're doing with Docker templates and unRAID that might be interested in something like Bitwarden might give it a look-see? :)

 

https://bitwarden.com/

  • Like 1
  • Upvote 1

Share this post


Link to post

Wrong forum, I guess... but +1

 

The docker compose instruction is unfit for the way UNRAID has implemented docker.

Share this post


Link to post

+1 on this.

Just noticed NerdPack plugin has Docker-Compose......if we have that installed, would we then be able to correctly install BitWarden?

 

Update: Ended up just installing it as a Docker on a Linux Mint VM.

Edited by Stupifier

Share this post


Link to post

Someone figured it all out! Check here....extremely simple install of BitWarden Docker. Was able to get Bitwarden up and Running in a few minutes on UnRAID

 

https://www.reddit.com/r/selfhosted/comments/8usixz/let_me_introduce_you_to_bitwarden_rs_selfhosted/

https://hub.docker.com/r/mprasil/bitwarden/

 

  1. Use the Community Applications plugin
  2. Go to Apps Tab and make sure DockerHub searching is enabled in the settings
  3. search for bitwarden and click to install on the container for "mprasil/bitwarden"
  4. Setup configuration like this screenshot.......

 

UnRAID Docker Configuration Example

Edited by Stupifier

Share this post


Link to post

I cannot get this to work...

 

When I try to make an account I get an error...

 

Problem generating keys

 

Anyone else have an issue like this?

 

Share this post


Link to post

got it working and added a reverse proxy via lets encrypt but can't seem to get the iPhone app to work externally but it works with internal LAN address.

 

 

Edited by ffhelllskjdje

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.