[Plugin] Mover Tuning


474 posts in this topic Last Reply

Recommended Posts

  • Replies 473
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

CA Mover Tuning       A simple little plugin (mainly created for my own purposes) that will let you fine tune the operation of the mover script On scheduled runs of mover, o

I would suggest removing the plug in, then moving everything.   I'm working on getting a Dev box up and running so I can continue working on this for the new Beta.

Haven't forgotten about this.  Will circle back in a few weeks once things settle down with the new release and try and add this in.

Posted Images

How can I get the 6.8 version back?  I did not see the "do not install for 6.8" note on the recent update (that is for the 6.9 rc), so I updated to the 6.9 version in error.  I've now removed that 6.9rc version, but do not see the 6.8 version (or ANY version) available any more.

Link to post

I think you can re-install the old plug-in from May by going to the history of the github and posting this URL (May 11th version of the plug-in script) into the URL for install plug-in.  However, I have not tried this.

 

https://raw.githubusercontent.com/hugenbd/ca.mover.tuning/6c146ad3ad63d162488d7e965c011d48d3e47462/plugins/ca.mover.tuning.plg

Edited by hugenbdd
raw view of plg file not github view.
Link to post
54 minutes ago, hugenbdd said:

I think you can re-install the old plug-in from May by going to the history of the github and posting this URL (May 11th version of the plug-in script) into the URL for install plug-in.  However, I have not tried this.

 

https://raw.githubusercontent.com/hugenbd/ca.mover.tuning/6c146ad3ad63d162488d7e965c011d48d3e47462/plugins/ca.mover.tuning.plg

Seems to be working fine. Thank you!

Link to post

I started getting a message from Fix Common Problems stating that my version of mover is not compatible with my version of UnRAID. I have a second server running 6.9 RC 2 that is not showing me that error. I did install Mover from the link posted above on the 6.8.3 server to make sure that I had not gotten updated and I am still getting the message in Fix Common Problems. Should I disable/uninstall Mover on 6.8.3 for now, or disregard the message?

Link to post

Sounds good. I will reenable the schedule and keep an eye on it.

 

Should I be concerned that I haven't seen any errors that Mover is not compatible with my UnRAID 6.9 server? It isn't too big of a deal since that server has little usage and is almost entirely a testbed, other than it does run pihole for me.

Link to post

Hello - 

 

Now I'm having an issue w/ mover and if I'm reading this right its because mover doesn't know where to put the files?  How can I fix this?  Here's a screen shot of my settings - 

image.thumb.png.4b832885be605ee09cbf491a31b1cded.png

 

and this is what the syslog says - 

Dec 26 04:30:16 Skynet crond[2002]: exit status 255 from user root /usr/local/sbin/mover &> /dev/null

 

I've included full diagnostics.  I noticed this after I figured out my issue with the other issue.  I can invoke mover manually but that sort of defeats the purpose right?  

 

skynet-diagnostics-20201226-1326.zip

Link to post
On 12/26/2020 at 7:48 AM, hugenbdd said:

I think you can re-install the old plug-in from May by going to the history of the github and posting this URL (May 11th version of the plug-in script) into the URL for install plug-in.  However, I have not tried this.

 

https://raw.githubusercontent.com/hugenbd/ca.mover.tuning/6c146ad3ad63d162488d7e965c011d48d3e47462/plugins/ca.mover.tuning.plg

Thanks for doing this!  Uninstalled new version and copy pasted that URL into "Install Plugin" under Plugins and worked perfect!

Link to post
On 12/26/2020 at 4:48 AM, hugenbdd said:

I think you can re-install the old plug-in from May by going to the history of the github and posting this URL (May 11th version of the plug-in script) into the URL for install plug-in.  However, I have not tried this.

 

https://raw.githubusercontent.com/hugenbd/ca.mover.tuning/6c146ad3ad63d162488d7e965c011d48d3e47462/plugins/ca.mover.tuning.plg

 

I awoke this morning to my cache being 100% full (which can lead to Plex DB corruption for me) with this error:

Quote

Dec 31 07:00:01 R710 root: Stack trace:
Dec 31 07:00:01 R710 root: #0 /usr/local/emhttp/plugins/ca.mover.tuning/mover.php(139): DirectoryIterator->__construct('/boot/config/po...')
Dec 31 07:00:01 R710 root: #1 {main}
Dec 31 07:00:01 R710 root: thrown in /usr/local/emhttp/plugins/ca.mover.tuning/mover.php on line 139

I guess Mover wasn't working at all!  Your fix got me back running.  I guess I need to turn auto updates off for this plugin.

Link to post

I'm running 6.9-RC2 and the 6.9-RC2 Plugin verison.

 

Currently there is an option to move based on Filled Percentage and an option to move based on File Age. I know the older version used to require Move based on Fill Percentage then you could set how old the files are or it would move everything if an age wasn't added.  Does that still apply?

 

IS SSD Percentage 20%

If yes ----------20 days old --- Run Mover

if no ----------- 20 days old --- Do nothing

 

I'm asking because I used to have a 240GB SSD and I had it set to move if 20% and move files that are 20-Days old.

Now I have a 1TB SSD so I would have to set my Percentage much lower say 5-10% and 20-Days old. 

 

For me keeping the files on the SSD for 20-Days is more important than how full the SSD is. My youngest kid constantly watches the same videos over and over and 2+ weeks has been a perfect balance. Then after the 20-Days its safely moved to the Array for protection. 

Link to post

Kizer

It operates the same way (as the old one)

 

However, in this beta... if ANY cache pool is over the percentage threshold then it invokes mover for all pools. (I plan to change this in the near future).

 

Days old only comes into play once you hit a certain percentage used.  It's possible that if percentage threshold is not hit, then your files on cache just keep aging until the percentage threshold is hit.

 

I have a 2TB cache drive.  I have my percentage used threshold set to 65% and 35 days...  So TV/Movies stay on cache for at least 35 days.  Sometimes longer if I had a busy download day in the past 35 days....

 

Just take note that if you don't have mirrored cache drives.. then your files are not protected by the array/parity drives.  I am not worried as I backup to google drive nightly, and can just retrieve my files from there in case of a cache disk going bad.

 

 

 

Link to post

Thanks for the info. I figured it was acting just like it did before. 
 

I just set mine to 20days because I figured it was a good amount of time for myself and my kinds to watch whatever is new and I’m rolling the dice on if my SSD dies. 
 

When I had a 240GB and did a lot of ripping it nearly got full seeing my dockers and Plex data share the same space. I was at the 3GB available and realized I’ve out grown the 240GB. So the 20-days almost kicked my butt. Lol. 
 

Fast forward with a 1TB a bit and I had some issues and realized support between 6.83 and 6.90Beta-35 went away after an auto update on the script so I this morning took the leap to 6.90-RC2 so I could use this again. 

Link to post

New Version released.

 

###2021.01.08

- Added version check to Install script.

- Removed threshold percent check in mover perl script.

- Added threshold percent check to age_mover bash script.

- age_mover bash script now check for global threshold percent or the a manual entry in the ca.mover.tuning.cfg file. (example: /boot/config/plugins/ca.mover.tuning cachetv="65")

    - "cachetv" being the name of the pool.

    - if using single digits leading zero required. (i.e. cachetv="01" for 1 percent)

- Removed cache disk check in perl script to remove warning on scheduler page.

- Several hard coded echo statements to help in trouble shooting/debug. These will be removed later but may cause an email to be generated and sent to you.

Link to post

@hugenbdd

 

plugin: updating: ca.mover.tuning.plg

 

plugin: updating: ca.mover.tuning.plg

Parse error: syntax error, unexpected '' (T_ENCAPSED_AND_WHITESPACE), expecting '-' or identifier (T_STRING) or variable (T_VARIABLE) or number (T_NUM_STRING) in Standard input code on line 11
plugin: run failed: /usr/bin/php retval: 255

 

when updating

Link to post
33 minutes ago, alturismo said:

@hugenbdd

 

plugin: updating: ca.mover.tuning.plg

 


plugin: updating: ca.mover.tuning.plg

Parse error: syntax error, unexpected '' (T_ENCAPSED_AND_WHITESPACE), expecting '-' or identifier (T_STRING) or variable (T_VARIABLE) or number (T_NUM_STRING) in Standard input code on line 11
plugin: run failed: /usr/bin/php retval: 255

 

when updating

 

Try now... I updated the install script.

Link to post

Hi, I am on 6.9.0-rc2 with plugin 2021.01.03 and receive this error with no files being moved:

Jan 12 11:06:08 Tower emhttpd: shcmd (168): /usr/local/sbin/mover |& logger &
Jan 12 11:06:08 Tower kernel: mdcmd (88): set md_write_method 1
Jan 12 11:06:08 Tower kernel:
Jan 12 11:06:08 Tower root: *********************************MOVER START*******************************
Jan 12 11:06:08 Tower root: mover: started
Jan 12 11:06:08 Tower root: Share Config: /boot/config/shares/Share1.cfg
Jan 12 11:06:08 Tower root: Pool Pct Used: 4 %
Jan 12 11:06:08 Tower root: Threshold Used: no
Jan 12 11:06:08 Tower root: "0
Jan 12 11:06:08 Tower root: 0
Jan 12 11:06:08 Tower root: "0
Jan 12 11:06:08 Tower root: no
Jan 12 11:06:08 Tower root: "1
Jan 12 11:06:08 Tower root: no
Jan 12 11:06:08 Tower root: "1
Jan 12 11:06:08 Tower root: no
Jan 12 11:06:08 Tower root: "1
Jan 12 11:06:08 Tower root: es
Jan 12 11:06:08 Tower root: xt
Jan 12 11:06:08 Tower root: no
Jan 12 11:06:08 Tower root: ="
Jan 12 11:06:08 Tower root: es
Jan 12 11:06:08 Tower root: es
Jan 12 11:06:08 Tower root: no
Jan 12 11:06:08 Tower root: no
Jan 12 11:06:08 Tower root: ="
Jan 12 11:06:08 Tower root: es
Jan 12 11:06:08 Tower root: /usr/local/emhttp/plugins/ca.mover.tuning/age_mover: line 171: [: no: integer expression expected
Jan 12 11:06:08 Tower root: Mover not Needed.
Jan 12 11:06:08 Tower root: mover: finished
Jan 12 11:06:08 Tower kernel: mdcmd (89): set md_write_method auto
Jan 12 11:06:08 Tower kernel:

NOTES:
I have based on age and size turned off, but this error only happens when using the file ignore option. Disabling it moves files from cache to array but moves files I don't want it to.


Rolling back to the plugin version before this (2020.12.27) works as intended.

Edited by classiccrime
Link to post
1 hour ago, classiccrime said:

Hi, I am on 6.9.0-rc2 with plugin 2021.01.03 and receive this error with no files being moved:


Jan 12 11:06:08 Tower emhttpd: shcmd (168): /usr/local/sbin/mover |& logger &
Jan 12 11:06:08 Tower kernel: mdcmd (88): set md_write_method 1
Jan 12 11:06:08 Tower kernel:
Jan 12 11:06:08 Tower root: *********************************MOVER START*******************************
Jan 12 11:06:08 Tower root: mover: started
Jan 12 11:06:08 Tower root: Share Config: /boot/config/shares/Share1.cfg
Jan 12 11:06:08 Tower root: Pool Pct Used: 4 %
Jan 12 11:06:08 Tower root: Threshold Used: no
Jan 12 11:06:08 Tower root: "0
Jan 12 11:06:08 Tower root: 0
Jan 12 11:06:08 Tower root: "0
Jan 12 11:06:08 Tower root: no
Jan 12 11:06:08 Tower root: "1
Jan 12 11:06:08 Tower root: no
Jan 12 11:06:08 Tower root: "1
Jan 12 11:06:08 Tower root: no
Jan 12 11:06:08 Tower root: "1
Jan 12 11:06:08 Tower root: es
Jan 12 11:06:08 Tower root: xt
Jan 12 11:06:08 Tower root: no
Jan 12 11:06:08 Tower root: ="
Jan 12 11:06:08 Tower root: es
Jan 12 11:06:08 Tower root: es
Jan 12 11:06:08 Tower root: no
Jan 12 11:06:08 Tower root: no
Jan 12 11:06:08 Tower root: ="
Jan 12 11:06:08 Tower root: es
Jan 12 11:06:08 Tower root: /usr/local/emhttp/plugins/ca.mover.tuning/age_mover: line 171: [: no: integer expression expected
Jan 12 11:06:08 Tower root: Mover not Needed.
Jan 12 11:06:08 Tower root: mover: finished
Jan 12 11:06:08 Tower kernel: mdcmd (89): set md_write_method auto
Jan 12 11:06:08 Tower kernel:

NOTES:
I have based on age and size turned off, but this error only happens when using the file ignore option. Disabling it moves files from cache to array but moves files I don't want it to.


Rolling back to the plugin version before this (2020.12.27) works as intended.

Can you post a pic of your schedule page or let me know what you have in the file ignore box so I can try and reproduce on my end.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.