[Plugin] Mover Tuning


Recommended Posts

10 minutes ago, jonathanm said:

The only reason for a cache : no share to have files on the cache is something misconfigured, or have files placed there on purpose that shouldn't be moved.

It's also possible that a share got changed from yes to no without mover running.  Leaving them orphaned.  

 

I don't think its best to be built into the plug-in.  Probably better to use something like Midnight Commander.  

 

However, I can still be convinced to look into it for a good reason.

Link to comment
8 minutes ago, jonathanm said:

The only reason for a cache : no share to have files on the cache is something misconfigured, or have files placed there on purpose that shouldn't be moved.

Perhaps in your setup sure, but I don't consider it a misconfiguration. I have large files that when created or downloaded need/benefit from my speedy cache device. But if files are copied to the share from other devices on the network, there is no reason to use the cache device (as they are quite large) so prefer them to go straight to the array. These files are created on the cache, then they get moved to the share folder, which, won't move them to the array the way it works, and then the mover also won't pick them up.

I could exploit the bug (IMO) that the min free space required for a share also applies to the cache device as well, and set that value to be larger than the cache size (that only works while you have large enough free space on some data drives).

Link to comment
2 minutes ago, hugenbdd said:

It's also possible that a share got changed from yes to no without mover running.  Leaving them orphaned.  

 

I don't think its best to be built into the plug-in.  Probably better to use something like Midnight Commander.  

 

However, I can still be convinced to look into it for a good reason.

Also this too, that can happen.

Link to comment
  • 3 weeks later...

Apologies if this has already been covered in this thread but I was struggling with what to search for.

 

Is there a way to prioritize a share so that Mover acts on it more frequently than the default Mover settings? My situation is that I have the settings to generally not have the Mover run unless the cache is running low on disk space. But, I have Nextcloud uploads going to cache and I'd like those to get moved to the array a bit more often than all the other stuff on the cache.

Link to comment

Not from my plug-in.

 

If you have a lot of experience you can create your own command line and pipe the output to the mover binary.  

 

Something like below in a cron entry. (User scripts plug-in).  However... you won't have any of the supporting code around it.  i.e. to see if mover is currently running.

 

find "/mnt/cache/<YOURSHAREHERE>" -depth | /usr/local/sbin/move -d 1

 

 

 

 

Link to comment
21 hours ago, hugenbdd said:

Not from my plug-in.

 

If you have a lot of experience you can create your own command line and pipe the output to the mover binary.  

 

Something like below in a cron entry. (User scripts plug-in).  However... you won't have any of the supporting code around it.  i.e. to see if mover is currently running.

 

find "/mnt/cache/<YOURSHAREHERE>" -depth | /usr/local/sbin/move -d 1

 

Ah, no worries. Probably a bit outside my technical abilities at this stage. Thanks!

Edited by mudsloth
Link to comment

Possibly.  I don't have 6.10 yet.  I'm still on 6.9.1

I'll update my dev box this week.

 

What might have happened is that 6.10 provided a new mover script.  Overwritting the plug-in's script which just points to the plug-in's new script or the original script.  You might be able to get the plug-in working by removing then re-installing the plug-in.

 

Link to comment
33 minutes ago, hugenbdd said:

Possibly.  I don't have 6.10 yet.  I'm still on 6.9.1

I'll update my dev box this week.

 

What might have happened is that 6.10 provided a new mover script.  Overwritting the plug-in's script which just points to the plug-in's new script or the original script.  You might be able to get the plug-in working by removing then re-installing the plug-in.

 

Ahh, I see! No luck on removing / re-adding. Didn't try a reboot between those two, however.

Link to comment
36 minutes ago, hugenbdd said:

What might have happened is that 6.10 provided a new mover script.  Overwritting the plug-in's script which just points to the plug-in's new script or the original script.  You might be able to get the plug-in working by removing then re-installing the plug-in.

Unraid update would have required a reboot. In fact, the new version isn't loaded until the next boot.

 

After the new version loads, the built-in mover script is in RAM just like the rest of the OS.

 

Then any installed plugins are applied.

  • Like 1
Link to comment
1 hour ago, hugenbdd said:

Possibly.  I don't have 6.10 yet.  I'm still on 6.9.1

I'll update my dev box this week.

 

What might have happened is that 6.10 provided a new mover script.  Overwritting the plug-in's script which just points to the plug-in's new script or the original script.  You might be able to get the plug-in working by removing then re-installing the plug-in.

 

not sure if this helps but, I verified /usr/local/sbin/mover is the plugin and mover.old is the original. calling mover by itself doesn't work as intended but running /usr/local/emhttp/plugins/ca.mover.tuning/mover.php with the parameters I want does. not sure where the disconnect is happening.

Link to comment
28 minutes ago, classiccrime said:

not sure if this helps but, I verified /usr/local/sbin/mover is the plugin and mover.old is the original. calling mover by itself doesn't work as intended but running /usr/local/emhttp/plugins/ca.mover.tuning/mover.php with the parameters I want does. not sure where the disconnect is happening.

Is it the button in the scheduler page that isn't working or when it is run at it's scheduled time?

 

(Sorry, will play around with tonight/tomorrow)

Link to comment
50 minutes ago, classiccrime said:

not sure if this helps but, I verified /usr/local/sbin/mover is the plugin and mover.old is the original. calling mover by itself doesn't work as intended but running /usr/local/emhttp/plugins/ca.mover.tuning/mover.php with the parameters I want does. not sure where the disconnect is happening.

Forgot.. (I have to many options in the plugin....)

 

But do you have this set? (Second to last question)

Move Now button follows plug-in filters: Yes

Link to comment
  • 3 weeks later...
20 minutes ago, hugenbdd said:

Try setting this to 0 and not 1.

Move files that are greater than this many days old:

 

You can also run in test mode and review the files it will be selecting.  (see the log file)

 OK i just changed that setting and hit start so i will see what happens

thank you 

Link to comment
26 minutes ago, hugenbdd said:

Try setting this to 0 and not 1.

Move files that are greater than this many days old:

 

You can also run in test mode and review the files it will be selecting.  (see the log file)

  so it gets to 60gig free space and stops moving 

 

Link to comment
1 minute ago, Vader666 said:

ok i will change that 

 

also not sure how to check the logging and what files are left.  super new to all of this 

 

 

 

Mover Logging : Enabled. (Up top, schedule area)

 

You can see in your last pic the "mover started.      Mover Finished". at the bottom.  That will expand to a lot more.

 

You will need to browse the individual cache drive or use the console and issue ls commands on the cache.

https://www.tecmint.com/15-basic-ls-command-examples-in-linux/

 

also

https://www.techrepublic.com/article/linux-directory-navigation-tips-and-tricks/#:~:text=To change to your home,and then press [Enter].

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.