(SOLVED) unable to convert Cache disk pool from RAID1 to RAID0


6 posts in this topic Last Reply

Recommended Posts

My issue sounds the same as a recent post here, but the solutions didn't work. The command recommended in the FAQ

-dconvert=raid0 -mconvert=raid1

looks to issue the command properly in the syslog but does nothing. No errors are printed in the syslog or in the WebGUI. I restarted the server, re-issued the command, and still no conversion.

 

my btrfs balance status:

 

Data, single: total=1.95TiB, used=1 .94TiB System, single: total=32.00MiB, used=240.00KiB Metadata,g single: total=5.00GiB, used=3.69GiB GlobalReserve, single: total=512.00MiB, used=0.00B

No balance found on '/mnt/cache'

There were no errors after a btrfs scrub:

scrub status for 5bc529a5-e3b4-4eec-9c77-265b61962b61
	scrub started at Thu May  3 23:56:56 2018 and finished after 09:18:32
	total bytes scrubbed: 1.94TiB with 0 errors

My 2-disk (5 TB WD Black Caviar each) RAID1 pool is <25% full after deleting 2.5TB of incomplete downloads. The other suggestion in that post was to update the OS, which I have v6.5.1.

 

A command suggested to get allocated space of the cache pool here:

btrfs fi usage /mnt/cache

prints

Overall:
    Device size:           9.10TiB
    Device allocated:           1.95TiB
    Device unallocated:           7.15TiB
    Device missing:             0.00B
    Used:               1.95TiB
    Free (estimated):           7.15TiB    (min: 7.15TiB)
    Data ratio:                  1.00
    Metadata ratio:              1.00
    Global reserve:         512.00MiB    (used: 0.00B)

Data,single: Size:1.95TiB, Used:1.94TiB
   /dev/sdn1     998.00GiB
   /dev/sdo1     994.00GiB

Metadata,single: Size:5.00GiB, Used:3.69GiB
   /dev/sdn1       1.00GiB
   /dev/sdo1       4.00GiB

System,single: Size:32.00MiB, Used:240.00KiB
   /dev/sdo1      32.00MiB

Unallocated:
   /dev/sdn1       3.57TiB
   /dev/sdo1       3.57TiB

which makes me think my newly-created RAID1 cache pool is acting as a cache pool. I only want a pool for performance, so I'm hoping to get it setup for RAID0. I've also never seen the warning "Cache pool BTRFS too many profiles" that's been said as normal to see.

diagnostics-20180504-2213.zip

Edited by AndrewT
marked solved thanks to johnnie.black for the conversion cmd & John_M for evaluating conversion success
Link to post

Wow, that might've worked! Immediately after entering that into terminal, the WebGUI had a orange menu pop up indicating

unRAID Cache disk message: 05-05-2018 11:16
Warning [TOWER] - Cache pool BTRFS too many profiles
WDC_WD5001FZWX-00ZHUA0_WD-WXA1D6542HUS (sdn)

 

 

This warning almost seems indicative of RAID conversion activity :)

 

After 5 min, nothing yet has printed to stdout or stderr, but I can see the command still running with `htop` and both disks in the Main WebGUI show active read/write speeds (170 ~MB/s max). I'll update as solved after it completes which could take awhile for 2x5TB disks, but that's odd it didn't work in the WebGUI.

Link to post

If you leave it running and open another terminal you can check on its progress with

btrfs balance status -v /mnt/cache

When the balance is complete this command will return, a little confusingly,

No balance found on '/mnt/cache'

and the command running in the other terminal window will end and display the prompt again.

You can check the state of the pool with

btrfs fi usage /mnt/cache

and when the balance is complete you'll see that the Data section reports RAID0 and the Metadata section RAID1.

 

Perhaps the reason it didn't work in the GUI is a browser-related issue?

Link to post
15 hours ago, John_M said:

Perhaps the reason it didn't work in the GUI is a browser-related issue?

Only noticed now, OP has an extra space in the command:

 

-dconvert=raid0 -mconvert=raid 1

should be

 

-dconvert=raid0 -mconvert=raid1

 

 

Link to post

Thanks @johnnie.black! I'm using Chrome Version 63.0.3239.132 (Official Build) (64-bit) on a vanilla Ubuntu 18.04 OS and have entries saved, so I see the space wasn't lacking in my cmd in the WebGUI. I edited my original post to avoid another person copy/pasting the wrong cmd. There might be an issue with my browser/OS still, because copy/pasting cmds with "code" formatting in this forum doesn't work despite no unusual formatting appearing when I put it into Sublime Text first. For example, the two cmds @John_M print usage errors and the text is clearly correct.

When copy/pasting this happens:

btrfs fi usage /mnt/cache
btrfs filesystem: unknown token 'usage'

But when typing the cmd manually it works as expected:

btrfs fi usage /mnt/cache
Overall:
    Device size:		   9.10TiB
    Device allocated:		   2.04TiB
    Device unallocated:		   7.05TiB
    Device missing:		     0.00B
    Used:			   2.04TiB
    Free (estimated):		   7.06TiB	(min: 3.53TiB)
    Data ratio:			      1.00
    Metadata ratio:		      2.00
    Global reserve:		 512.00MiB	(used: 0.00B)

Data,RAID0: Size:2.03TiB, Used:2.03TiB
   /dev/sdn1	   1.02TiB
   /dev/sdo1	   1.02TiB

Metadata,RAID1: Size:5.00GiB, Used:3.78GiB
   /dev/sdn1	   5.00GiB
   /dev/sdo1	   5.00GiB

System,RAID1: Size:32.00MiB, Used:176.00KiB
   /dev/sdn1	  32.00MiB
   /dev/sdo1	  32.00MiB

Unallocated:
   /dev/sdn1	   3.53TiB
   /dev/sdo1	   3.53TiB

 

I prefer terminal over the WebGUi so I'm thankful you gave the full command to execute. This cmd worked as expected (within screen) to convert the Cache pool from RAID1 to RAID0, so I'll mark this [Solved]:

btrfs balance start -dconvert=raid0 -mconvert=raid1 /mnt/cache
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.