Jump to content
Husker_N7242C

USB Passthrough, Docker Won't Stop and Memory Management

1 post in this topic Last Reply

Recommended Posts

Hi everyone,

 

@johnnie.black has helped me twice this year already so I thought I'd see if I could ask for a hand to get a few issues resolved?

 

1. USB Pass-through - Johnnie picked-up this issue in my logs in March but I didn't think it was a problem for me then.... I was wrong.

The symptoms are;

a) I can't use a wireless keyboard and mouse with a VM, either assigned to the VM at boot or after boot. It works unless i stop moving the mouse or typing for more than 5-10 seconds then it drop-outs and requires re-assigning using the hot-plug USB plugin.

b) I have a USB 3.0 controller in a PCIe port that I'd like to pass-through to the VM. This works intermittently but mostly not at all. I've followed the instructions on YouTube here (www.youtube.com /watch?v=UilWLtMYd-U ) *space added to URL to prevent big preview box*. Sometimes the VM won't boot with the controller attached and other times it works but only certain USB devices hot-plug successfully or only certain physical ports work. I'm hoping that the logs reveal something useful.

c) I have tried 2 different USB racing wheels (G25 and Momo Force) and they won't pass-through to the VM. They are shown in USB hot-plug Plugin and the G25 even will be shown as "setting up device" when I assign it to the running Windows VM however it too immediately drops-out from what I can see. I've tried it plugged into the various motherboard USB sockets, the controller card, tried assigning in the plugin and.or at boot. No luck at all

d) A wired keyboard and mouse works fine. I just have one set plugged in, this works for the UNRAID GUI pre VM boot and then the VM grabs them when it boots. When the VM shuts down it hands them back to the UNRAID GUI fine (I generally boot the GUI at the moment to allow starting of the VMs etc without another device handy)

 

2. Docker won't stop - I use the Zoneminder docker to record my security cameras. It's been fine until recently but not occasionally crashes (just the docker) and the UNRAID Web-GUI cannot stop the docker. I have to reboot the entire system to restart the Zoneminder docker.

 

3. Memory - I only have 24GB of RAM and about 40% is used at boot by dockers and a Windows Server VM. I then boot my 'PC' (another VM with graphics pass-through) and end up at about 65-70% RAM utilisation, so 30% free with all my normal dockers and VMs running.

The problem is that the memory utilisation seems to grow while the system is running! This leads to the VMs pausing, crashing or the entire UNRAID crashing. If my main PC VM hasn't been booted in a while I get left without enough RAM to boot it or have to reduce it's memory to boot it (or reboot the system).

Can someone help me with a management strategy/settings to keep the memory usage down or prevent this situation where the VMs get "squeezed-out". I've installed the page-file plugin but I don't think that it helps the VMs. I can't see a way to keep memory usage at the level of a fresh boot. I would consider adding more memory but I don't think that this would actually solve this long-term.

 

I really appreciate any help and this community is the main reason I persist and keep trying to learn and muddle my way through UNRAID.

 

 

nas-diagnostics-20180514-1543.zip

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now