Jump to content
Symon

Threadripper no Turbo Boost / XFR

10 posts in this topic Last Reply

Recommended Posts

Posted (edited)

Hi all

 

I use UnRaid together with a Threadripper 1950 for quite some time now and it works quite well so far. However, I recently discovered that the CPU frequency of the cores would never go higher than the base frequency of 3.4 GHz although it should be able to go up to 4 GHz according to the CPU speccs. Now this seems to be a problem with the internal frequency governor not knowing to correct max frequency if I googled this correctly. The same behaviour seems to happen with the Ryzen CPUs. 

 

I used this to check the frequency
watch grep \"cpu MHz\" /proc/cpuinfo

 

The only solution that has been recommended so far is overclocking the CPU to achieve a higher frequency. Unfortunately, this seems to notably increase the power consumption of this CPU. However, I tried this and got the speed up to 3.8 GHz (4.0 was unstable) but was wondering if this is really the only solution to this problem?

 

Is this problem given by the Linux Kernel of UnRaid? Is there a chance that this will be fixed in the near future or is OC the only way to achive this?

 

Maybe there is also something that can be changed in the configuration of UnRaid that I'm not aware of?

 

Thanks for any input or help

Symon

 

Edited by Symon
  • Like 1

Share this post


Link to post

Did you ever find out something? I'm having the same problem with my Ryzen 1700

Share this post


Link to post

I have the Intel Turbo boost enabled with ondemand governer through the tweaks plugin.

 

My Ryzen 2700 now clocks up to 4.2 GHz easily.I’m not sure if that is XFR or Precision Boost.

 

UnRaid 6.6.1 on a x470 Taichi with stock BIOS setting.

 

48751E02-F90A-4863-A6C5-B8C414CFF005.thumb.jpeg.52eb65915af69f0882d06cb14265791d.jpeg

Share this post


Link to post

@mAYH3M, does it clock back down under idle?
That was my concern with changing the performance settings, also having a 1950x I don't want it pegged at max freq. all the time for obvious reasons.

Share this post


Link to post

@tjb_altf4 Clocks back to 1.2 GHz when idle.In the picture core 8-16 cores are pinned to Plex and under load while others are idle.

  • Upvote 1

Share this post


Link to post

OK now that I'm home I can see I already had those settings on my 1950x (legacy from my previous server setup I think) and it moves between approx 2MHz to 3.7MHz

Note I'm still on 6.5.3 and there has been a lot of development in later kernels which may do better again.

 

Interested to see what others such as OP get.

Share this post


Link to post

@tjb_altf4 I suppose your Threadripper is OC to 3.7?

The best setting I've found so far is to OC the base frequency (mine is currently 3.875 @ 1.25V) and use the "on demand" setting in the Tips and Tweaks plugin such as the frequency will go down when not needed... 

 

It's kind of difficult to decide in between speed / power consumption while maintaining a stable system which won't overheat :) 

 

Also, the newest version of UnRaid seems to have a negative impact on the performance of the cpu which is probably due to the security patch which has been reapplied :( 

 

Edited by Symon

Share this post


Link to post

Not overclocked, pretty much stock factory bios settings other than the xmp ram profile.

 

What motherboard are you using?

Share this post


Link to post

To be honest, it seems Unraid fluctuates on/off with CPU governors when it comes to Ryzen.  I have a 1950x myself and every update it seems to toggle between a driver being found and forcing Performance Mode.  

Share this post


Link to post
On 10/11/2018 at 12:39 AM, tjb_altf4 said:

What motherboard are you using?

I'm using an Asus Rog Zenith Extreme. Last time I checked without OC the CPU, the frequency wouldn't go above 3.4 GHz. 

Maybe someone from @limetech can tell us which component is reponsible for the UnRaid internal frequency governor and how it's supposed to work.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now