Jump to content
binhex

[Support] binhex - Krusader

673 posts in this topic Last Reply

Recommended Posts

My first sever and first Docker so apologies if the question is not clear or the answer is obvious: Followed tutorial  as per old Spaceinvader One video (on deprecated Docker). The custom action bars option is toolbars settings "text under the icons" is not persistent on re-boot. Is it intended ? 

Share this post


Link to post

Krusader is only showing the USB drive, not my internal drives. when I click on the open available media, nothing seems to happen.

 

I assume its looking at the USB because it list it as a 32GB device :)

 

thanks for the help.

jb

Share this post


Link to post
7 minutes ago, benwaynet said:

Krusader is only showing the USB drive, not my internal drives. when I click on the open available media, nothing seems to happen.

 

I assume its looking at the USB because it list it as a 32GB device :)

 

thanks for the help.

jb

Post your docker run command as explained in this very first link from the Docker FAQ:

 

https://forums.unraid.net/topic/57181-docker-faq/#comment-564345

 

Share this post


Link to post

Hey everybody,

 

any ideas on that:

 

2019-12-22 11:49:08,598 DEBG 'start' stderr output:

** (process:138): CRITICAL **: 11:49:08.598: polkit_system_bus_name_new: assertion 'g_dbus_is_unique_name (name)' failed

(process:138): GLib-GObject-CRITICAL **: 11:49:08.598: g_object_unref: assertion 'G_IS_OBJECT (object)' failed

 

I currently running a copy job from an unassigned drive to the array. The copy job window gone in the webui and even the brwoser had to be restarted for getting acces again to my unraid.

I already copied 6TB with krusader (3 Harddrives) and had any problems till now.

Thanks, mindfest

Share this post


Link to post

I have been running this docker for quite some time, after following SI's tutorial, with no issue.   However, today, I updgraded my Unraid license to "Pro" and started receiving the too many registry keys error.  So, I went into Krusader to delete the old key and I suddenly cannot access my boot drive (mapped as /FLASH per SI's video).  I am uncertain as to what I've done incorrectly.  

 

Below is my docker run command and a screenshot inside Krusader when I try to access the /FLASH folder.

 

Any assistance is much appreciated.

dockerRun.JPG

krusader.JPG

Share this post


Link to post

You can't do that anymore with 6.8 unless you edit Krusader and check off the "privileged" box

Share this post


Link to post

Ah, so I need to turn "privileged" off?

 

[EDIT: I just turned privileged off and tried again. No luck.  So, I re enabled privileged again, still no luck.  I'm certain I'm making an error somewhere here...]

Edited by ChappyEight
Add more info.

Share this post


Link to post
16 minutes ago, ChappyEight said:

Below is my docker run command and a screenshot inside Krusader when I try to access the /FLASH folder.

 

Any assistance is much appreciated.

I had to set Krusader to run as 'root'.  You can do this by editing these two variables as shown below:

 

image.thumb.png.d7a78bf058074a0e4e713f35fca9887e.png

Remember that being user 'root' gives the power to do just about anything when anyone is using Krusader!

image.png

Share this post


Link to post
22 minutes ago, ChappyEight said:

Ah, so I need to turn "privileged" off?

 

[EDIT: I just turned privileged off and tried again. No luck.  So, I re enabled privileged again, still no luck.  I'm certain I'm making an error somewhere here...]

 

7 minutes ago, Frank1940 said:

I had to set Krusader to run as 'root'.  You can do this by editing these two variables as shown below:

 

My bad...  Serves me right for giving advice off the top of my head...

Share this post


Link to post

This seems useful, i have been moving files from a server via smb and i notice that it takes a lot longer then need be, i though smb3 was smart enough to detect when files are being moved from one share to another locally but seems to only work when you move files from inside a share to another path inside the same share.

 

Anyway, i want to uset his docker, i am however very concerned with the security of having unencrypted VNC on the network be the root admin to all the array file management. If anyone is listening they could snag the vnc password and then access all the data on the array or even worse, delete it!

 

How can i go about securing this docker more, though it is highly unlikely someone would be listening to my lan traffic, i just want to make sure something as easy as listening for unencrypted traffic isn't the weakest link in my security if a hacker should get into my network for whatever reason. Can this vnc be secured with a certificate?

 

Or perhaps, is there a way to disable the delete commands inside Krusader? I only want to use Krusader strictly for moving files internally on the array, no delete needed. Even better would be to password protect the delete commands so you have to enter password everytime you try to delete something. Ideas?

Edited by je82

Share this post


Link to post
9 minutes ago, je82 said:

i though smb3 was smart enough to detect when files are being moved from one share to another locally but seems to only work when you move files from inside a share to another path inside the same share.

It is (and does).  I can easily exceed line speed when moving files from share to share (and if I look at what Windows thinks is going on with the network, no data is being transferred to the desktop)  You should be able to more or less hit the same write speed (all else being equal) when doing this via Krusader

Share this post


Link to post
1 minute ago, Squid said:

It is (and does).  I can easily exceed line speed when moving files from share to share (and if I look at what Windows thinks is going on with the network, no data is being transferred to the desktop)  You should be able to more or less hit the same write speed (all else being equal) when doing this via Krusader

Strange. I don't know why it appears to run via network, i have one share called \\NAS\Incoming and one share called \\NAS\Media moving 300gb from Incoming to Media which both are on the array via a thirdparty on smb3 it goes at 100mb/s (gigabit) which is the speed i am connected with.

 

I edited my main post, please see:

Quote

Or perhaps, is there a way to disable the delete commands inside Krusader? I only want to use Krusader strictly for moving files internally on the array, no delete needed. Even better would be to password protect the delete commands so you have to enter password everytime you try to delete something. Ideas?

I would be interested in something like this. Possible?

Share this post


Link to post
20 hours ago, je82 said:

Anyway, i want to uset his docker, i am however very concerned with the security of having unencrypted VNC on the network be the root admin to all the array file management.

If you can't get this container secured to your satisfaction, you could do as I do and not run it unless you are actually using it. Not the greatest answer, but it certainly limits the exposure.

 

Another "security through obscurity" trick is to have another inconsequential container set to use the same port as this one, or even a second copy of this container, duplicated EXCEPT for the permissions of the mount point. Set the no permission container to auto start, then when you need to edit files you shut down that container and start up the dangerous one, when done restart the other.

 

That way the fully privileged container can't be started unless the auto run container is stopped.

 

The starting and stopping could be scripted, and triggered by a shortcut on your daily driver. Click an icon, do your file maintenance, click another icon, server secured.(ish)

Share this post


Link to post

Hi,

New to unraid, Ive been following space invader one how to videos, followed how to install krusader, although I have access to my iso and domain shares in unraid, I can not see my /UNRAID folder in krusader, Im not sure what I have done wrong, any suggestions would be greatful.

Thanks in advance.

Share this post


Link to post

I am going to assume that    /UNRAID  points to your Flash/Boot Drive.  You will probably have to set Krusader to run as 'root' rather than 'nobody'.   You do this as shown below:

On 12/23/2019 at 10:44 AM, Frank1940 said:

I had to set Krusader to run as 'root'.  You can do this by editing these two variables as shown below:

 

image.thumb.png.d7a78bf058074a0e4e713f35fca9887e.png

Remember that being user 'root' gives the power to do just about anything when anyone is using Krusader!

 

It would be a good practice to always have Krusader 'stopped' except when you are actually using it.  (Anyone can access it using any browser when it is running if they know how!)

Share this post


Link to post
On 12/10/2019 at 5:47 AM, Wence said:

My first sever and first Docker so apologies if the question is not clear or the answer is obvious: Followed tutorial  as per old Spaceinvader One video (on deprecated Docker). The custom action bars option is toolbars settings "text under the icons" is not persistent on re-boot. Is it intended ? 

I have the same question. It's only a couple extra clicks to re-enable but it would be great if there was a way to remove this annoyance.

Share this post


Link to post
55 minutes ago, rragu said:
  On 12/10/2019 at 5:47 AM, Wence said:

My first sever and first Docker so apologies if the question is not clear or the answer is obvious: Followed tutorial  as per old Spaceinvader One video (on deprecated Docker). The custom action bars option is toolbars settings "text under the icons" is not persistent on re-boot. Is it intended ? 

55 minutes ago, rragu said:

I have the same question. It's only a couple extra clicks to re-enable but it would be great if there was a way to remove this annoyance.

Mine are staying there through a restart.   Try this:    Right-click in the Panel where the icons with test under are. Select 'Configure Toolbars' and you will see this setup.  Select one of the Toolbar items and click 'Change Text'.   Now make sure that the indicated check box is not checked. 

 

 

1777463519_Annotation2020-01-10114131.jpg.094b5ca50ba64a208c379dd1a6a27d93.jpg

 

I  have also have turned  'Lock Toolbar Positions' to  "on" in the first right-click box. 

Share this post


Link to post
30 minutes ago, Frank1940 said:

Mine are staying there through a restart.   Try this:    Right-click in the Panel where the icons with test under are. Select 'Configure Toolbars' and you will see this setup.  Select one of the Toolbar items and click 'Change Text'.   Now make sure that the indicated check box is not checked. 

 

 

1777463519_Annotation2020-01-10114131.jpg.094b5ca50ba64a208c379dd1a6a27d93.jpg

 

I  have also have turned  'Lock Toolbar Positions' to  "on" in the first right-click box. 

I checked the entry for each bookmark and made sure the checkbox in the screenshot above is UNchecked. And I have Lock Toolbar Positions turned on.

 

Still no luck. Every time I restart the docker, I go back to having only a row of folder icons with no text.

Share this post


Link to post

Good day, would anyone kindly share their server block for krusader in letsencrypt? this is what Im trying to use, but I get "noVNC encountered an error:"

server {
    listen 443 ssl;

    root /config/www;
    index index.html index.htm index.php;

    server_name subd.mydomain.duckdns.org;

    include /config/nginx/ssl.conf;

    client_max_body_size 0;

    location / {
        auth_basic "Restricted";
        auth_basic_user_file /config/nginx/.htpasswd;
        include /config/nginx/proxy.conf;
        proxy_pass http://192.168.1.100:6080/vnc.html?autoconnect=true;
    }

    location /websockify {
        proxy_pass http://192.168.1.100:6080/vnc.html?autoconnect=true;
        proxy_http_version 1.1;
        proxy_set_header Upgrade $http_upgrade;
        proxy_set_header Connection "upgrade";
        proxy_read_timeout 86400;
    }
}  

 Thank you

Share this post


Link to post

@binhex first thank you for providing and mainting this docker. I have a request for which I do not understand it's complexity so pardon me if it sounds cheeky. 

Would it be viable to add a straight webui interface to this docker? 

The image mentioned earlier (https://hub.docker.com/r/djaydev/krusader) does allow straight webui connection without vnc or anyhting else. However, it lacks some of the functionality present in your image. 

If this was a not overly complicated modification, it would be a welcome addition.

Thank you.

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.