[Support] binhex - Krusader


Recommended Posts

sorry if this is a dumb question but I'm not seeing anything in search ....I use unraid for photography and I want to connect a 4 SD card reader to my system ....I have tested this and I see the cards show up in Unassigned disk and binhex....I am able to copy files over to my photo share just fine..now when its time to change a card ...binhex still shows the files of the last card...I tired to refresh button and restart the docker. I even remove the card reader and I still see the info in binhex...I'm I using the wrong app for what I'm trying to do?

Edited by drichard
Link to comment

@drichard  i have had similar with 6TB and bigger drives

my resolved issue for now was

1.  for this   Restart the docker each time

 

2..  use the other Krusader  i found this one had issues.. but the "Krusader"  docker  one  and set the PUID the other P   to 0  the the key 5 6 

and that has seemed to to fix the issues your having  

give it a try see what happens if it works..

 

but i fell in same issue  and that worked for me  it was frustrating  

Link to comment
16 minutes ago, comet424 said:

@drichard  i have had similar with 6TB and bigger drives

my resolved issue for now was

1.  for this   Restart the docker each time

 

2..  use the other Krusader  i found this one had issues.. but the "Krusader"  docker  one  and set the PUID the other P   to 0  the the key 5 6 

and that has seemed to to fix the issues your having  

give it a try see what happens if it works..

 

but i fell in same issue  and that worked for me  it was frustrating  

so I installed the other krusader but I'm not seeing puid ....can I trouble you for a screen shot please

Link to comment
28 minutes ago, drichard said:

so I installed the other krusader but I'm not seeing puid ....can I trouble you for a screen shot please

my bad its because i remember from the this krusader or other dockers 

its USER ID and Group ID  i set them to 0  

 

try that...  

sorry about that i wasnt looking at my screen  i just did from remembering..  i not best at this unraid i only been using a couple years now so no expert here

u1.PNG

u2.PNG

Edited by comet424
Link to comment
  • 2 months later...
  • 3 weeks later...

hello 

 

i have crashes with krusader when i copy files from a synology 

 

2020-12-30 03:01:52,449 DEBG 'start' stderr output:
error 3: BadWindow (invalid Window parameter) request 20 minor 0 serial 490
error 3: BadWindow (invalid Window parameter) request 15 minor 0 serial 491

2020-12-30 03:01:52,449 DEBG 'start' stderr output:
error 3: BadWindow (invalid Window parameter) request 20 minor 0 serial 492
error 3: BadWindow (invalid Window parameter) request 15 minor 0 serial 493
error 3: BadWindow (invalid Window parameter) request 20 minor 0 serial 494
error 3: BadWindow (invalid Window parameter) request 15 minor 0 serial 495
error 3: BadWindow (invalid Window parameter) request 20 minor 0 serial 496
error 3: BadWindow (invalid Window parameter) request 15 minor 0 serial 497
error 3: BadWindow (invalid Window parameter) request 20 minor 0 serial 498
error 3: BadWindow (invalid Window parameter) request 15 minor 0 serial 499
error 3: BadWindow (invalid Window parameter) request 20 minor 0 serial 500
error 3: BadWindow (invalid Window parameter) request 15 minor 0 serial 501
error 3: BadWindow (invalid Window parameter) request 20 minor 0 serial 502

2020-12-30 03:01:52,449 DEBG 'start' stderr output:
error 3: BadWindow (invalid Window parameter) request 15 minor 0 serial 503
error 3: BadWindow (invalid Window parameter) request 20 minor 0 serial 504
error 3: BadWindow (invalid Window parameter) request 15 minor 0 serial 505
error 3: BadWindow (invalid Window parameter) request 20 minor 0 serial 506
error 3: BadWindow (invalid Window parameter) request 15 minor 0 serial 507
error 3: BadWindow (invalid Window parameter) request 20 minor 0 serial 508

2020-12-30 03:01:52,450 DEBG 'start' stderr output:
error 3: BadWindow (invalid Window parameter) request 15 minor 0 serial 509
error 3: BadWindow (invalid Window parameter) request 20 minor 0 serial 510
error 3: BadWindow (invalid Window parameter) request 15 minor 0 serial 511
error 3: BadWindow (invalid Window parameter) request 20 minor 0 serial 512
error 3: BadWindow (invalid Window parameter) request 15 minor 0 serial 513
error 3: BadWindow (invalid Window parameter) request 20 minor 0 serial 514
error 3: BadWindow (invalid Window parameter) request 15 minor 0 serial 515
error 3: BadWindow (invalid Window parameter) request 20 minor 0 serial 516

2020-12-30 03:01:52,450 DEBG 'start' stderr output:
error 3: BadWindow (invalid Window parameter) request 15 minor 0 serial 517
error 3: BadWindow (invalid Window parameter) request 20 minor 0 serial 518
error 3: BadWindow (invalid Window parameter) request 15 minor 0 serial 519
error 3: BadWindow (invalid Window parameter) request 2 minor 0 serial 539
error 3: BadWindow (invalid Window parameter) request 20 minor 0 serial 540

 

 my settings : https://d.pr/i/zsmuZp

 

any idea?

 

thanks

Link to comment

Bug Report: Krusader is unable to access a large number of files from my backup disk, however these files are accessible when using a full-fledged OS.  ALSO unable to open large zipped tarball.

Details: I have an old HDD which was slowly failing, so long before I discovered Unraid I created a tarball of it on a known good drive.  Now I have my test of Unraid up and running, and am trying to move those files into my array.  My first attempt has been to use Krusader.  I have fixed the common issue of mounting unassigned devices in RO-Slave mode.

Try 1: Open tarball directly in Krusader.  Krusader is unable to open the tarball.  It's approximately 300GB.  After trying to open and letting it run overnight, it failed with a generic error.

Try 2: Manually unzip onto another known good HDD, mount that to Krusader, and start to copy files and folders over.  Resulted in the following:

  • Many of the files copy over without issue. 
  • However, many others do not copy over at all.  I've had the following results:
    • Krusader gives the dialog box "unable to access file XYZ"  with option to skip, skip all, or retry.  Retry does nothing, skip brings up the next one, so I typically do skip all.
    • Sometimes Krusader gives the same dialog box but only includes the option to retry or cancel.  Retry does nothing, cancel ends the operation.  My first thought was that this dialog box was because this particular item was the last in the queue, but this was not the case.  Sometimes, this applies to an entire directory.

Files that Krusader cannot access are all types, including audio, video, text, word documents, images.  Some cases involve every file in a directory.  Other cases involve just a file or two in a large directory.

My initial suspicion was that this was due to bitrot on the old HDD corrupting some of the files.  HOWEVER, as a final attempt I accessed the unassigned drive over the network using SMB from my Linux Mint PC, and I was able to open a sampling of "faulty" files without issue.

The only clue that I have is that LibreOffice complained when opening one of the "faulty" word documents that it was open by another person.  This may be on account of my mounting the drive in Read-Only mode, or perhaps file metadata has a "file has been opened" flag?

 

These files have always lived on ext3/ext4 drives.

 

My next attempt is to boot a VM and pass the unassigned drive and the Array into the VM.  I really want to avoid doing a full network round trip for this much data.

Thank you!

 

Link to comment
1 hour ago, SwiftArrow said:

I really want to avoid doing a full network round trip for this much data.

Midnight Commander (mc from the command line) is built-in to Unraid. It is a TextGUI file manager similar to the various "Commander" applications from the DOS days. Easy to use and what I always use to work with files directly on the disks. Google Midnight Commander.

  • Like 1
Link to comment

Not sure if this belongs in here but ran into a small snag this evening.  After preclearing (it passed) via USB and shucking a 10TB Seagate Expansion Drive (Ironwolf Pro), I'm trying to offload certain folders from a mount drive (mnt3) to the new drive (mnt5).  Using binhex-krusader, I used the move to the other pane option and saw my speeds in 6.9.0rc2 go from 225 MB/s down to 60 MB/s.  I've got reconstruct write enabled so I'm not sure why this is happening.  In this case, I'm trying to move all of my TV media from two drives to the new one to clear up some space.  I've done this without issue in an older version and got 220 MB/s read/write for both.  At one point, on the first attempt, I ended up getting three beeps after the web gui dropped off on me.  I tried again and didn't have this issue.  I did a smaller test (28GB of data) and it did the same; dropped from 225 MB/s to 60MB/s with a lot of drive chatter.

 

Any ideas?

 

Thanks all!
 

Link to comment

setting my first UNRAID up to use for Plex, trying to copy media from a 2TB hard drive via USB and/or SATA to my array, but it keeps stalling out or locking up. It either shows that it has "stalled" in krusader or it just locks the whole system up and then i have to power down and restart. I have tried so many different configurations trying to narrow down the problem. I am a novice at running UNRAID so it's been somewhat difficult for me to troubleshoot. i can do a small transfer of up to 50gb worth of data and it seems to work, but once i try to do a whole batch of MKVs, it locks up or stalls out. any help would be greatly appreciated.

bojangles-diagnostics-20210110-1458.zip

Link to comment
13 minutes ago, normnailz said:

setting my first UNRAID up to use for Plex, trying to copy media from a 2TB hard drive via USB and/or SATA to my array, but it keeps stalling out or locking up. It either shows that it has "stalled" in krusader or it just locks the whole system up and then i have to power down and restart. I have tried so many different configurations trying to narrow down the problem. I am a novice at running UNRAID so it's been somewhat difficult for me to troubleshoot. i can do a small transfer of up to 50gb worth of data and it seems to work, but once i try to do a whole batch of MKVs, it locks up or stalls out. any help would be greatly appreciated.

bojangles-diagnostics-20210110-1458.zip 85.85 kB · 0 downloads

just happened again...frustrated and disappointed as I have been trying to copy over files all weekend, but have been more diagnosing than actually copying.

Screen Shot 2021-01-10 at 3.22.46 PM.png

Link to comment
53 minutes ago, normnailz said:

just happened again...frustrated and disappointed as I have been trying to copy over files all weekend, but have been more diagnosing than actually copying.

 

I may be a little quick jumping in here (as I don't use the Unassigned Devices plugin) but I would like to suggest that you google   'unraid.net krusader and unassigned devices' and look at the results of that search.  You could also try a modified search using 'unraid.net problems krusader and unassigned devices'...

Link to comment

great, thanks for the response @Frank1940, i will do some more digging, but I have looked through most of those search results and they were concentrated more on not seeing devices, which has not been an issue for me. I can see unassigned devices without issue. the problem i am having is when I try to copy from an unassigned drive to my array, i run into my system locking up or krusader giving me a "stalled" message. either way, both require a restart and trying to pick up where it left off before it crashed. 

 

oh and it just stalled again at 17% of a 735gb transfer

Edited by normnailz
Link to comment

Fellow Forum Members,

Krusader installation is kicking my butt. I am following Spaceinvader's Krusader installation video but what makes it difficult is how his version does not match the version I am installing from Binhex. Right now I'm trying to backup my boot drive as Spaceinvader shows in his video.

 

However, when I try to move the FLASH folder from one pane to the other pane belonging to my share folder LEGOS I get a "Could not enter folder /Flash" error shown in the graphic below. I have logged in as ROOT user and I still get this error.  I have also included a second screen capture showing my current Krusader settings.  What change do I have to make to fix my Krusader setup so it works correctly? Is there a Krusader installation Video that shows the BinHex version and not the older SpaceInvader version because that will help me out tremendously?

 

Lastly, the "/mount/user" and "/media" container values BinHex includes does not match to SpaceInvader's version. What container value do I add if I create an UNRAID folder like SpaceInvader shows?  I ask because I do not see the Unassigned Devices "disks" folder or array hard drives like SpaceInvader shows in his video.    Any help will be greatly appreciated.  Thank you.

 

22 Krusader error.JPG

 

20 Krusader Changes Applied.jpg

Edited by binar
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.