[Support] Linuxserver.io - Calibre-Web

Recommended Posts

I cannot for the life of me get Calibre-Web to see ebook-convert. I pulled the binary from a Calibre install, tossed it into /config within the container, and pointed Calibre-Web to the path to it. It's still reporting as not installed.


I consoled into the container to run "ebook-convert --version" to see if it was actually functional at all and it returned an error regarding missing modules. Does it require dependcies? Does Calibre as a whole have to be installed within the container?

Edited by Phastor
Link to comment
  • 3 weeks later...

Hi everyone,

I am new to Calibre-web and all code related stuff so please bear with me chaps!


I have started doing my own research on how to set everything up but the challenge here is I am not code oriented so I am struggling to understand the instructions on the Github post and it is taking me forever to progress any single step. Even though I am running Windows for it, I think some of the stuff I need is common to Linux or what needs to be used.


Having in mind the vast majority of you are far ahead from my baby steps so counting on your proven expertise, that would be great if you could guide me through a quick start, some tutorials, useful links somebody with zero idea of coding can understand or maybe even pointing me at the right community or link to find out how to do it.


What I need to achieve, in general terms, is:

  1. Wirelessly convert + sync books to match Kindle e-books accepted formats.
  2. Setting up different users with different permission levels so I can invite family and friends to access my Calibre library
  3. Accessing the UI through a standard URL (non-local hosted) so the assigned users can access everywhere.

So my questions to get there are:

  • Ho to set up "Remote login", which I have enabled from the admin panel but not sure how to access with another user in another device inside my home. Not sure if I need to extra tweak something to achieve that. Kind of lost at this point.
  • Understand the differences between localhost and a hosted Calibre-web site. I have seen around a couple of libraries under custom domains so I would like to know pro's and con's of both methodologies (security issues included) and how to operate with them. Ideally, as I said before, I value the capacity of sharing my Calibre library with family and friends. (I have seen a post before with some piece of code to set a reverse proxy but I really don't know where to write it or what it is really for 😅)
  • SMTP email settings for send to kindle devices. Not sure about this. Can I do this from an email address account I have already i.e.: Gmail or does it need to be something else?

If any of you could throw some light on this I would be everlasting thankful 😀


Many thanks in advance for all your input, feedback, comments and guidance.

Hope you all have a great day!


Link to comment
  • 1 month later...

Seems like I am not the only one for whom the thing won't convert using the standard setting? I just get a forever spinning circle on a tab called ePubJS Reader


Also, when I access it on my iOS browser - some epubs will open in Books and some won't. No idea why.

Edited by tknx
Link to comment
  • 2 weeks later...
  • 3 weeks later...

I am trying to set this up and I keep getting the error "DB location is not valid, please enter correct path" when trying to enter the path to my calibre books and database.  I can see the books and the db in the directory and I have set it the same way in the container configuration.  But it still won't work.  Any suggestions?





Edited by pcgirl
Link to comment
On 3/9/2019 at 12:40 AM, jas0r said:

Has anyone received an internal server error when selecting a menu category? I am getting the below error when I select author, series or category. 

I have tried rebuilding the database with no luck and it works fine in calibre. 


Internal Server Error

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application.

I am having the same issue.   Did you ever resolve this? 

Link to comment
  • 2 weeks later...
  • 3 weeks later...
On 10/10/2019 at 4:12 AM, Huy said:

I'm trying to set up this Calibre-Web docker and am using the ls.io version of the Calibre docker. I can reach the Calibre web-UI easily on my ip:8080, however I cannot reach the Calibre-Web web-UI on ip:8083. What could have gone wrong?

i am having the same problem ... has anyone solved it?

Link to comment
On 6/14/2019 at 7:11 PM, Phastor said:

I cannot for the life of me get Calibre-Web to see ebook-convert. I pulled the binary from a Calibre install, tossed it into /config within the container, and pointed Calibre-Web to the path to it. It's still reporting as not installed.


I consoled into the container to run "ebook-convert --version" to see if it was actually functional at all and it returned an error regarding missing modules. Does it require dependcies? Does Calibre as a whole have to be installed within the container?

Hey did you solve your problem?

How did you pull the binary from the calibre install? I am trying to find it. 

So I got a bit further and am getting the following error:


Calibre converterExcecution permissions missing

I tried the chmod and chown commands, but it did nothing and the error presists after rebooting. 

Thanks again for your help!

Edited by Beryllium
Link to comment
  • 2 months later...

I'm looking for help with using a reverse proxy into Calibre-web. I'm using the Linuxserver letsencrypt docker, which works fine with my Nextcloud docker (and duckdns docker).


I'm using a duckdns sub-domain; let's call it "ddcalibreweb". I've edited the calibre-web.subdomain.conf file so that I have the line

server_name ddcalibreweb.*;

I'm stuck at the admin part in the Calibre-web UI. Under Basic Configuration / Feature Configuration there's a check box for Allow Reverse Proxy Authentication, which I've checked. Then an entry is required for Reverse Proxy Header Name. What should I fill in there?

Link to comment

This docker is great! I only have one issue, when clicking on any of the books, the book details show only "...", and there are no 'add to shelf' or 'download' buttons, which I presume to normally be present. Am I doing something wrong? In the library folder there is a metadata database file.



EDIT: Downloaded docker from different source, that one worked fine.



Edited by Pmobilee
Link to comment
  • 2 weeks later...
On 2/25/2020 at 4:43 PM, musicking said:

Anyone have any issues running the 0.6.6 version that just came out? Mine won't start and have since went back to 0.6.5 and was able to upgrade through the web UI. I can post logs and more info later if I'm the only one experiencing this.

same here - had to roll back to 0.6.5-ls50

Link to comment

FIXED: I had to a) stop calibre-web; b) delete the app.db file , and c) restart calibre-web.




I installed this Calibre-Web after being informed by Fix-Common-Problems that my previous Calibre docker was deprecated. 


I can't log in to the Calibre-Web Server. When I try the default admin/admin123 I get this message "Wrong Username or Password".


Not sure how to proceed. I assume it's a PEBCAK error, but I can't see ehere I've gone wrong.


I thought I'd be able to update the secrets file, but not sure what to put in there, or format. It's currently empty:

root@1e58b165290d:/config# cat client_secrets.json 

FYI I am running UnRaid 6.8.2. Here is a pic of login screen:


Edited by jaso
Edit = Updated with solution to my problem
Link to comment

The Jquery Web-UI is a bit too fancy for my ebook reader (Kobo Aura H2O). I can see some bits of the UI quite clearly but the bright blue bar that contains the downloads link renders as a grey blob on the Kobo. Nonetheless on the kobo I can't actually initiate a download to my e-reader.


Dees anyone know if there is there is a simpler, old-fashioned URL I could hit to view a much simpler version of the UI?



Edited by jaso
edit = added pic
Link to comment
1 hour ago, CHBMB said:

I'm running latest and it's working fine, I've pushed two fixes in the last week for this container.

I just tried the latest version again and I need to rollback to 0.6.5-ls50 (didn't try other builds, just picked this one first) for the UI to load. 


I get this error in the logs with the latest version:

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File "/app/calibre-web/cps.py", line 34, in <module>
from cps import create_app
File "/app/calibre-web/cps/__init__.py", line 68, in <module>
config = config_sql.load_configuration(ub.session)
File "/app/calibre-web/cps/config_sql.py", line 348, in load_configuration
update({"restricted_tags": conf.config_mature_content_tags}, synchronize_session=False)
File "/usr/local/lib/python3.6/dist-packages/sqlalchemy/orm/query.py", line 3910, in update
File "/usr/local/lib/python3.6/dist-packages/sqlalchemy/orm/persistence.py", line 1692, in exec_
File "/usr/local/lib/python3.6/dist-packages/sqlalchemy/orm/persistence.py", line 1873, in _do_exec
values = self._resolved_values
File "/usr/local/lib/python3.6/dist-packages/sqlalchemy/orm/persistence.py", line 1839, in _resolved_values
desc = _entity_descriptor(self.mapper, k)
File "/usr/local/lib/python3.6/dist-packages/sqlalchemy/orm/base.py", line 402, in _entity_descriptor
"Entity '%s' has no property '%s'" % (description, key)
sqlalchemy.exc.InvalidRequestError: Entity '<class 'cps.ub.User'>' has no property 'restricted_tags'
Traceback (most recent call last):
File "/usr/local/lib/python3.6/dist-packages/sqlalchemy/orm/base.py", line 399, in _entity_descriptor
return getattr(entity, key)
AttributeError: type object 'User' has no attribute 'restricted_tags'
root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name='calibre-web' --net='br0.33' --ip='' --cpuset-cpus='8,9,13,24,25,29' -e TZ="Europe/London" -e HOST_OS="Unraid" -e 'TCP_PORT_8083'='8083' -e 'DOCKER_MODS'='linuxserver/calibre-web:calibre' -e 'PUID'='99' -e 'PGID'='100' -v '/mnt/user/':'/user':'rw' -v '/mnt/user/media/other_media/books/':'/books':'rw' -v '/mnt/disks/':'/disks':'rw,slave' -v '/mnt/user/media/other_media/books/':'/library':'rw' -v '/mnt/cache/appdata/dockers/calibre-web':'/config':'rw' 'linuxserver/calibre-web' 


Link to comment
  • 2 weeks later...
  • 4 weeks later...

Hi all, sorry I have a really dumb question: Am I suppose to be able to read an ebook with the Calibre-Web interface? I've read about the function but I'm not seeing it in the UI after clicking on a book. I see: Mark as read, Edit metadata, Download, and Send to Kindle. I also tried clicking and double-clicking on the book cover. And I've tried this with Firefox and Safari.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.