My first hobby “TOWER”


74 posts in this topic Last Reply

Recommended Posts

Friday, November 15, 2019 - The day I "cursed" nVidia.


So, still running unRAID 6.7.2 - but I had enough of trying to get the nVidia GT 1030 OC Phonenix card from Asus to work in the Dell T310 box, and tonight ran out to Microcenter and bought a low profile/low power MSI Radeon R7 240 2GB video card. Yes, I knew it wasn't going to be blazing fast, but then neither is my server. The card didn't need an extra power plug, just the power from the PCIe slot. And I just wanted something to work in the tower that would give me some decent graphics capabilities and not the accused "error 43." And sure enough, the Radeon is in - working on the first try with the VM, loaded up the updated Win10x64 drivers - and is broadcasting through TeamViewer at a decent 1280x1024 resolution. (Trust me, this is soooo much better than a Error 43 and default 800x600 resolution... I can at least run some programs again from the server!)


In particular, I was able to run Second Life (it's a fun virtual world game for me) and it actually looked pretty good. Not amazing, but "pretty good."


And although I just got a good hint from another poster about a potential fix for a VM using the nVidia 1030, I decided am going to let this server configuration "cook" for awhile "as is." Plus I can still use the 1030 in another box I am building for doing some video editing and graphics work.

Edited by rollieindc
Link to post
  • 2 weeks later...
  • Replies 73
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hi all,    First time poster. I recently dove into the world of IT last year and made a career change from like 15-18 years of sales with the intention of eventually ending up in Cyber Secur

Just as a hint 8x or 16x doenst make a noticable difference for GPU.

For bandwidth, you are 100% right.   Especially since this x16 slot has only x8 routing. And I am not looking at adding or expecting to use this build for any multi-GPU card acceleration fea

Posted Images

25 NOVEMBER 2019 - PLEX-ing my muscles, in MINECRAFT???!!!.


So, I picked up a lifetime subscription to Plex (on sale at 20% off) and upgraded my Plex server (Docker) from the LimeTech build to the Plex, Inc build - inside of Docker. Thanks to the excellent youtube video tutorial from SpaceInvaderOne - I was able to move over the Plex configuration and files within about 15 minutes. No muss, no fuss. (Reminder: 1 beer owed!) While I'm not seeing any real improvements in the way the new Plex docker handles the streams to my devices outside of my home network - I, at least, feel a little more in control of how Plex and Beets are organizing my music and video library. So I spent a lot of the weekend suffling multiple CDs and DVDs through ripping programs on laptops, loading up the music library. (Reminder to self, I need to back the library up on a spare portable HDD.) For what it's worth, I use CDex and EAC for most music CDs, and WInX DVD Ripper Platnium for my DVD movies. Not really seeing a need for 4K or 8K yet, but that's probably a future thing I will need to consider with whatever my next "server" I might need to get.


Plus, I am interested to see if the Plex's "TV" functionality is something that I can use with my server. Seems like it's just a small USB dongle and antenna away from pulling in "over-the-air" HDTV shows and into my server via Plex's DVR like capabilities. But I've found in the past that these kinds of solutions have always been finicky for me at best. Still, I am encouraged to consider it. And I do have the option of running a VM connected to one of the USB ports with the HDTV dongle, and having the same HDTV capabilities - and maybe even better. Considering that a new larger format, smart HDTV is somewhere in my future - as is a whole house renovation, I need to consider my options on how to Plex and how it will work with our existing/future DirecTV system. (Gahds, I hate ComCast!)


Also the MSI Radeon R7 240 video card is working nicely in the server under a Windows 10 VM. So it will likely be December before I find the time to work on the nVidia video card again. The Teamviewer remote desktop controller I am using is pretty good, but the Acer Chromebook that I am controlling it from - has some minor issues with "passthrough" of right and left mouse clicks from their implementation on the touchpad. I might try using an external mouse to see if that resolves that issue. But the idea of using a connected "lightweight" Chromebook is pretty attractive for when I travel (which I do a lot) compared to having to tote a larger laptop around. (I have to RDP into my work's VNC and VM in order to read emails!)


But overall, I like the "look and feel" of the server solution that I have now. Much more of what I originally envisaged when I started the project. A low cost, lightweight, simple NAS, with modest extensibilities - that had modestly good access to files, ability to back up into, and the ability to run VMs and Dockers/APPs. If I was doing this "professionally" - I'd probably want to use a platform like SuperMicro's motherboards and hardware, but this wasn't intolerable to work through either. But too, I'd want a much faster internet connection than I have now (Verizon DSL), and would love it if I could gain access to a FTTH connection - but the locale where I am doesn't offer that. =(


With "Black Friday" deals coming in, I will probably be looking for a few larger Enterprise HDDs. 6TB and 8TB SAS/SATA drives at lower prices are starting to show up on some recent sales - now that the 12GB enterprise drives are coming onto the market, so that might be were I increase storage capacity and replace the current parity drive. (Adding two 6 or 8TB drives would move me into the 20+TB range on a small, single (quad core) CPU server space - which I think is pretty amazing.)


And I don't think a second 1TB SSD for Cache makes sense - but would be interest in what others have to share about their experiences.


So, what's next for my server? Probably the following:

(green requires very few funds and is low risk to get, yellow requires funds/significant personal effort/increased risk to the current server)

  1. Adding HDTV DVR functionality to Plex or separate "over the air" HDTV VM, & how that will work w/DirecTV or future smart-TV 
  2. A couple larger hard drives (currently up to 13TB, but growing music and video library),
  3. Getting the nVidia to work in a Win 10 VM and remoting in,
  4. Adding a docker or two for cloud sharing & bit torrents,
  5. Upgrading the xeon processors from the X3440 to something like X3480 (2.53 to 3 Ghz speed bump for about $25).
  6. Working on some VMs to support DruPal functionality as a satellite node off my current externally hosted website, permitting "file drag and drop" document library "like" functionality.

After that, it's a new system really. I am sure I am getting close to maxing out the power supply on the T310. And this is otherwise max'd out for a NAS. Plus I'd rather not "bog" this system down trying to edit photos or videos natively from it. I got it as a NAS, and that's the main reason for it being... serving and making data available where ever I go. I have a heavyweight laptop and a heavyweight standalone PC for video and graphics editting that work well for me. Plus I can't see the need for a higher network connection, at least not for what my family does. Sure, I might wire for 10Gigabit around the home, but everything that I will link into it will likely be 10/100/1000 for a long time to come.


Plus I have other projects to work on that are not server related: 

  1. a new wireless (g/n/ac) router to be installed,
  2. a new high speed document scanner (ethernet IP based),
  3. a revamped/standalone Win 10/x64 dual xeon based video/photo editting system,
  4. a standalone Mac Pro 5.1 (dual xeon x56xx's) with 32GB ram and
  5. a standalone i7 Mac-Mini (likely will become the HTPC or the daughter's future workstation)!


And unRAID was the absolute BEST solution for this kind of centerpiece NAS server - with all that future functionality in mind. Yes, I would like to have the nVidia issue to be resolved, but that's not LimeTech's issue... that's really an nVidia driver issue. )=p


Also, my wife has recently recognized me as the "CIO" of our home based (not for profit) business. It's an IT staff of one. But I have my 11 year old daughter as a new intern trainee. And she will be wanting a minecraft server soon... and yes... the CIO will consider that as part of the future. But she has to get her school grades up first. She's definitely interested, that is, when she's not wanting me to teach her how to play softball and play catch with me. 😃


Edited by rollieindc
Link to post
  • 2 weeks later...



I started using TeamViewer remote desktop because it worked fairly well. I only had my one server, and I am not running it for a commercial service in any way shape or form. (I work for the government, and they frown on such things.) However, just moments ago as I was trying to resolve an issue with my Windows 10 VM, the software popped up with a "We're taking away your connection" ransom note. I thought this was a joke, but this is EXACTLY why I had seen so many others saying that TeamViewer was no longer their preferred system. Now I see why. Right in the middle of a effort, a "ransom note" - pay up, or we're turning off your ability to use your VMs. No if's, and's or but's. No way to contact anyone. No email. No chat option. You have to pay, or no more access. Pretty much a "F*ck you" by the TeamViewer team.


Sorry, NO ONE deserves this kind of treatment. Ever. So, "F*CK YOU TEAMVIEWER." If anyone comes into my office saying that they use the software for a required job in order to input data - I will now (physically) throw them out of my office, terminate their contract with me, and consider them "Non-conformal" to stated performance and security requirements.





Edited by rollieindc
Link to post
  • 4 weeks later...



So, the Dell T310 has mostly been stable, without much in the way of issues. Updated to 6.8.0 - and so far, so good. Drives are all up and with zero errors, well within temperature tolerances (less than 100*F). My two main issues have been the Plex Docker image, and the Windows 10 VM.


So the Plex Media Server docker (PlexInc version) runs for the most part well, and I added a SiliconDust HomerunHD Duo to be able to watch and record a couple of local stations I can't get on my DirecTV. But - I am still struggling with Plex being "in and out" of the remote connectivity part of it. I have it set for Port 32400, manually, and forwarded the port through my router - but for some reason, the connectivity drops every so often. I tried various fixes (uPnP on/off, manual port forwarding, etc) but nothing seems to prevent the drop outs. The system will sometimes "heal" the issue, but at other times - I got nothing. Starting to consider a Arch or Mint Linux VM to run Plex in, rather than the docker. I keep getting this weird feeling like the Plex Docker is not getting enough resources to run properly, and as a result, drops the remote connection.


The Windows 10 VMs are still being a persistent bugger too. Even with the AMD Radeon R7 240 2G Low Profile/Low Power video card installed - the VM gets lodged in this weird "broken" state. I am unsure, but I think part of it is the Windows 10 system trying to automatically upgrade the ethernet or video drivers. And of course, when that happens, I have to rebuild the VM from scratch - because no amount of tinkering will allow me to get the remote desktop back with teamviewer, Chrome remote desktop, or even the VNC (with the video controller changed back to the default setting.) For now, I have "updates" disabled, but am quite certain that some day soon - they are going to "whack" my system and have it go offline again.




Edited by rollieindc
Link to post

Hi there @rollieindc


I just wanted to share my semifinal dell t310


I have been running OMV 4 for more than a month with NextCloud docker and Windows 10 VM using VirtualBox without any issue.


I switched from ZFS to Snapraid with UnionFS on my 4x 8TB drives (7.22TB formatted) after watching this video TechnoDadLife. I set 3 drives for data and 1 drive for parity. so, I got 21TB of data protected.


I am running Windows 10 in VirtualBox to access my files on the server using TeamViewer since I cannot access the server directly because after very many tries, videos and forums I found out that I am behind a Carrier Grade NAT which prevent me from opening ports and forwarding them to my server. I am also using the Windows VM for downloading torrents using BitTorrent with remote access. I usually add torrents from my mobile using BitTorret Remote app on my Samsung Galaxy Note 9. I also use and app called SMBSync2 to backup folders and files on my mobile to my server on daily basis at night while I am sleeping.


I also install a 4x HDD cage in the lower part of the server and installed the 3x 3TB drives that I removed before. as you will see in the picture below. there the 4 original drives caddies and below I cut in the frame and install the other cage that I bought from AliExpress after modifying it.


I also got the SATA power splitter and SAS to SATA splitter and now all the 7 drives are working and 1x 240GB SSD kept for running Windows 10 VM and dockers. I have an extra 256GB NVME drive which I tested on the Dell T310. I installed it using a PCIE adapter without using extra SATA power or SATA cable from the H200 SAS to SATA splitter. It cannot be used as a booting drive but it can be used as an extra drive because it shows up with other drives after booting to the OMV. I plan to use this NVME drive instead of the 240GB SSD which will be done during this month as I plan to move to OMV 5 which will make me start from scratch.


I bought 2x Dell Broadcom 57810S Dual Port 10GbE PCI-e for around 80USD. One for the server and one for my PC. I connected both directly (since I don’t have a 10GBE switch) and tried transferring files from my PC NVME drive to the server NVME drive and I was getting around 950mb/s transfer speeds. But I was having stuttering issues on my PC because of it and I managed to fixed by upgrading the firmware of the NIC after very long search.



For now I am happy with what I have

Thank you for sharing your experience with us











Link to post
  • 2 weeks later...

I forgot to mention that I am using Emby docker instead of Plex docker as a media center to view my media on my Sony Android Smart TV and my other devices. I play them only on my home network. So, I do not need to buy the premier version as I do not need the extra features.


I used Plex docker for a period of time but noticed that it while playing videos from my server on my home network are not very smooth. Sometimes there will be lags and sometimes the video would stop for no reason. Some videos do not load properly and the picture and sound would be out of sync. Other issues also included not loading the subtitles files properly. I tried many solutions for the issues I faced but could not get rid of them completely.

So, I searched for an alternative and found Emby docker. It worked perfectly without any issues after my initial setup.


Just thought I would share this info with you as you are facing some problems with your Plex server.



Link to post
On 1/18/2020 at 10:12 AM, BuHaneenHHHH said:

Just thought I would share this info with you as you are facing some problems with your Plex server.

Thanks for sharing back!


I think you looked at a bunch of problems very systematically, and I like the lower bay drive cage adapter. That is very cool. Will keep that in mind if I need to add more drives.

And yeah, I always update my NIC card Firmware first thing after installing then. Been bitten by that issue far too many times. 


Emby sounds like a better solution for your set up. And for now, I am sticking with Plex in a docker. I solved most of my issues (remote access, stutter, etc.) with changing the NAT tables in my DSL modem and router.


You might also consider trying Chrome Remote Desktop. I had been using teamveiwer, and sure enough- their “claim“ was I was using it for commercial purposes- and locked me out of Remote connections into my own server before I could refute it. I then had to argue that I wasn’t, before they did anything, which was 72 hours later- and caused me issues while on travel. No weekend support either. Well, teamviewer is in my dustbin now, and won’t be reinstated until I see a better product than Chrome RDP.

I have been thinking about putting a windows VM on a separate SSD, and may still do that. But for now, my windows images seem snappy enough sharing the cache SSD. 


Am surprised you didn’t stick with unRAID as the base OS, but if what you have works- good for you. 


Stay in touch!

Link to post
  • 2 weeks later...

01FEB2020 Update - And upgraded to 6.8.2


So I upgraded from 6.8.0 to 6.8.2, and as usual, my Windows 10 VM RDP is "dead" (unreachable by Chrome RDP) again. No idea why this happens. This seems to be some weird Windows 10 update issue that causes the VM to be unreachable through the Chrome RDP. Annoying, but if I go back in and rebuild the image, it comes back again.


Otherwise, the system has been mostly rock solid. Drives seem happy, and the system temps have all been reasonable, including inside the bays and trays. Might add one more case fan just to reduce the temp a bit more. In the OS upgrade, the Plex migration was a bit of a hassle, but I also added a Silicon Dust HomeRunDR Duo Network TV system, and Plex seems perfectly happy to program and record local over the air (OTA) HD content. I have tried running the BEETS docker app to sort my music library, and am just getting annoyed by it rather than finding it to be helpful in finding anything in the indexs that make the music playable or searchable.




Edited by rollieindc
Link to post
On 1/18/2020 at 10:12 AM, BuHaneenHHHH said:

I used Plex docker for a period of time but noticed that it while playing videos from my server on my home network are not very smooth.

Just a note here, that using the /tmp for RAMDISK enabled my transcription and overall playability with Plex to be a lot smoother. Even with lower RAM available, I think this is still a wise thing to enable on any unRAID system for these kinds of issues.

Link to post
  • 2 weeks later...



Server has been running fine since the update to 6.8.2. Plex & VMs are running consistently and without any issues. Updated the Plex docker (Now at Version, and that seems to be working fine. And since I am away from home on travel next week, I am going to leave the configuration unchanged.

Link to post
  • 2 weeks later...



Server continues to  run fine since the update to 6.8.2. Did have the opportunity to increase storage, and added two 4TB WD Re enterprise drives, replacing the pair of 600GB Cheetah drives I had. Since I wanted to test out the robustness of the parity drive, I decided to pull the drive and "cold swap" them, allowing the new formatted drive to rebuild. This worked out rather well, and the drives rebuilt the "new" 4TB drive with zero errors in about 6 hours - and allowing for the 3.4TB of additional storage space. Since I have some extra 4TB WD Re enterprise drives, I will create a couple of "hot swappable/cold storage - ready spares" and will also be adding a second parity drive to the system for added drive protection. It was interesting to remove the drive, reboot the system, and see that the data on the removed drive was still available through the "emulated" drive capability enabled by the parity drive.


My Plex & VMs continue to run consistently and without any issues. I continue to update the Plex docker (now at Server Version, and that seems to be working fine. And it's really nice to be able to access the media on the server when I am away on travel.

Edited by rollieindc
Link to post
  • 3 weeks later...

Hi all, 


First time poster. I recently dove into the world of IT last year and made a career change from like 15-18 years of sales with the intention of eventually ending up in Cyber Security.(Just some background) It’s something I’ve been wanting to do for so long. I picked up my first server for FREE from my SAAS job when we were moving offices 4-5 months ago. T310 !! I can’t begin to tell you how great this thread is. I’ve read every single post ! I know I want a plex server & I want this to be the central of my home lab. I also wanted the capability to do some VM’s. I randomly stumbled on to this forum doing random google searches late at night earlier this week. 


Thank you for all the updates, you’ve inspired me and given me a lot of direction. I’ve even read things I didn’t think I’d want but now I do haha ! 


You are appreciated @rollieindc and everyone else.   

Link to post
On 3/21/2020 at 11:30 AM, GPL said:

Hi all, 


First time poster. I recently dove into the world of IT last year and made a career change from like 15-18 years of sales with the intention of eventually ending up in Cyber Security.(Just some background) It’s something I’ve been wanting to do for so long. I picked up my first server for FREE from my SAAS job when we were moving offices 4-5 months ago. T310 !! I can’t begin to tell you how great this thread is. I’ve read every single post ! I know I want a plex server & I want this to be the central of my home lab. I also wanted the capability to do some VM’s. I randomly stumbled on to this forum doing random google searches late at night earlier this week. 


Thank you for all the updates, you’ve inspired me and given me a lot of direction. I’ve even read things I didn’t think I’d want but now I do haha ! 


You are appreciated @rollieindc and everyone else.   



Thanks for the shout out! Much appreciated! You’re (and fellow T310 users) exactly why I wrote all those posts.  The Dell T310 is a pretty solid platform for a modest set of user needs.


My three regrets,

- the choice of 3 add in drive bays on top (I’d suggest something sturdier and trayless)

- nVidia graphics card not working in VMs

- not using OpenVPN (now much easier with 6.8.3 working inside of dockers) 


If you get a nVidia graphics to work in a VM, you gotta promise to share. I bet I’m just missing something trivial, and I’m still wanting to try that one fix offered previously- but since getting a cheap radeon to work, I had other priorities to focus on (like adding terabytes, working from home - avoiding nCOVID-19, and running BONIC to rosetta@home in a VM!)


Cheers, & welcome to the club!

Link to post
  • 3 weeks later...

Wednesday, 08 APRIL 2020 - Nothing much new.


So, mostly minor maintenance with unRAID 6.8.3. I am working at home remotely from my daytime job, so that keeps me busy for the most part. during the day. In between, I am loading up my Plex library ( with movies ripped from the DVDs we have, and make the occasional over the air (OTA) TV recording from the HomeRunHD Duo on the network. Mostly doing small stuff. I did install BOINC in a Windows 10 WM and ran that for a few "quadrillion" cycles. Simple software install to do protein folding in the hopes of finding vaccines for nCOVID19. I run my VMs with Chrome Remote Desktop software, and am able to that on anything from my iPhone 7, Chromebook, HP desktop or Dell Laptop.


I did hear that MacinaBox was not available on CA for some reason. I still grabbed a copy anyway and installed it.


Also became an Administrator on the "unRAID Family" group on facebook. (Link here) It's a good group, with some good insights - and some very needy people looking for advice.


Hope everyone is staying inside and by all means - STAY HEALTHY!

Link to post
  • 2 weeks later...

Wednesday, 21 APRIL 2020 - STAY AT HOME EDITION!


I am still working at home remotely from my daytime job, and mostly continuing to do minor maintenance with unRAID 6.8.3.


I ran into some interesting issues with a Western Digital "WD Re 4TB Datacenter Capacity Hard Disk Drive" (7200 RPM Class SATA 6Gb/s 64MB Cache 3.5 inch WD4000FYYZ) recently. It came up with a couple of read errors, which I think are cable interface issues. So I'll have to crack the case to see "what's up" soon. Smart Drive Report only shows "Extended offline Testing - Completed without error", but it had an earlier error of "READ FPDMA QUEUED" - which was dated long before I precleared & reformatted the drive. So, it's just something I will continue to watch for in the future. UNRAID said it recovered from "read" errors it had, and the drive appears to work well otherwise. So, I will see how it goes. I've currently only got a single Win 10 VM on it, and have that backed up separately, just in case. I also looked at it with the diskspeed docker app, and it appears to be working within expected read/write of all my other drives. It is in the hard drive "extension" that I added to the system, so it could be a power handling issue... more to follow up on with that later on.


(Late add:  I really need to add a RAID 1 m.2 nvme SSD for VMs, and get them off the cache and shares. I have a spare 4x PCIe slot, so that should provide power and enough space for anything I could come up with to run on a remote desktop. Am guessing that's at least a $150 add to the system when I tally it all up. 2 nvme + 1 interface card)


Plex ( threw a small hissy fit when I upgraded to the latest docker image (Version, but stopping and restarting the docker seems to have fixed issues.  It does seem a little more "laggy" at start up, so the cache and other database information may just need to "settle" to get it back to running it like normal. And these days, Dockers keep me busy for the most part. And I am having a fair bit better performance with it running MP4 encoding vice MKV encoded files. MKV is slightly smaller, and has "ok" versatility over a number of devices I broadcast to, but is not as versatile or flawless in playback as MP4.


I am also trying to read up and understand how letsencrypt docker works, however.  I need to watch some videos for that. So, just to be clear - I am running 95% as a local network NAS only. I have a couple of VMs that I come in via Chrome Remote Desktop, and Plex (lifetime subscription) that I use from remote locations - but I don't need (or want) a website running. I would like SSL certificates to be resolved correctly, and maybe address the VPN issues, but its not something I loose sleep over. And I just don't want my server hacked. I could attach it to a website I have (.com addy, where I own the domain and can access the DNS record, so I could make it, but again, I don't really 'need' that functionality. And if I did set it up, I'd want RSA/AES 256 encryption with a 30 character long random password - as a bare minimum.


And BOINC in the Windows 10 WM continues to run well. Still very simple software install to do protein folding in the hopes of finding vaccines for nCOVID19.  I did load MacinaBox, but not made a VM yet. I need to do that. No problem with getting a copy and installing it.


Hope everyone is staying inside and by all means - STAY HEALTHY!

Edited by rollieindc
tidy up the post
Link to post
  • 2 weeks later...

Thursday, 29 APRIL 2020 - Cabin Fever Edition


Still working at home remotely from my daytime job.


The previous issues with a Western Digital "WD Re 4TB Datacenter Capacity Hard Disk Drive"  appears to be working fine. Zero errors since cable checkup and reboot. May have been due to a Windows VM I was running. So, maybe dodged the bullet there.


Had some networking issues, and ended up bricking my TP-Link AC1750 router. I liked that thing. Will continue to see if I can "unbrick" it, but at this point, it won't even allow a TFTP link into it. Was trying to force a firmware update from OpenWRT. Had it working with DD-WRT, but it was a lousy firmware distro and gave me all sorts of issues. Thankfully, it was a Goodwill find, so its only $13 lost if it is "bricked."


Got Plex ( docker working more smoothly. Also was even able to Chromecast 1080p to a V1 wifi unit, and it looked good on the 1080p HDTV I have. "Lagginess" went away when I found that you can adjust the number of CPU Cores/Threads within the docker menu on the "CPU Pinning Docker" tab on the CPU settings on teh dashboard (e.g. https://tower.local/Dashboard/CPUset ). Much love & appreciation to whomever coded up that little helper - very clean and easy. Set my Plex to four threads as a default, and boom - no more lag. Didn't seem to use up any more CPU cycles... but I will be watching that. Nice bit is that it looks like you can adjust VMs and other programs just as easily.


Also have Monitorr running, which is a nice dashboard once you get it set up. (hint, set the /disk1/ as /../mnt/disk1/, see image attached to get the added disks included. If anyone knows how to add more services than what the docker allows, please - give me a reply! Could only show a few services and only 3 disks... not sure why that was so limited. Must be a setting I am missing.)


The BOINC software in a Windows 10 WM continues to chuck out computations for CoronaVirus folding daily. Glad I can give something back.


Hope everyone is staying inside and by all means - STAY HEALTHY & WEAR A MASK!



Link to post
  • 4 weeks later...

Tuesday, 26 MAY 2020 - nCOVID19 Edition, Day 71


Still working at home remotely from my daytime job. Local area is pretty much shut down at the moment, as we remain a "hot spot" of local infections, some over 50% in local population testing.


The past Western Digital "WD Re 4TB Datacenter Capacity Hard Disk Drive" has not had another single error, so I think it was the Windows 10 VM that gave it some "throwback" error in data.


Replaced my router (I'm on Verizon DSL, which stinks!) and solved most of my networking issues by using a DLink DIR-1950 router. No issues with Plex or other passthroughs with it.  Speaking of the Plex ( docker - it continues to work smoothly. Chromecasting 1080p with the V1.0 wifi unit is also eased up a lot. Have had a few issues with bandwidth and stability with the WIn10 VM running "BOINC" in the background. I think it's an issue of overall power consumption on the VM. It just doesn't like BOINC if I give it more than about 80% of the CPU clock and 80% of the CPU usage. I think the other Win 10 system level programs just have bandwidth issues when I do that.


Still have Monitorr and Netapp running, and got around the one issue of showing more services in Monitorr. Still can only show 3 disks though, and the other limited data on the system. But for that, there is the Netapp, so... who cares.  Starting to pole around with the Home Automation (HA) dockers. Have lots of cameras & hardware for those items. But for now, I am working to get base network stability re-established.


Hope everyone is staying inside and by all means - STAY HEALTHY & WEAR A MASK!

Link to post
  • 1 month later...

25 JULY 2020 - A long overdue 2 month update.


First, I'm doing "ok" with the Pandemic. No illness in the family. Had a colleague die from it, and another recover from it. Not my idea of fun.


I also have "ditched" Verizon DSL in favor of a Comcast 200/5mbs dry drop (internet only). After being on it for a month, I am "good" with the stability that I've finally been able to get. Yes, the 1TB data cap sucks, but I've not been bumping up against it (yet), so I am not too worried. And since I don't serve out of the house (and am not traveling) - Comcast 200/5 beats the 4.0/0.6 I was getting from Verizon.


But, it's been two months since my last post, and not much else has changed in my server system configuration or operation. I have taken the system down for a few days to reduce the heat load in the house, since we've been at 100F or higher this week. Still encountering a lot of issues with VM stability, but it's only when I use a graphics card in the VM and try to use a remote desktop app to access it. That kills the "standard" VNC connection, and I have to use a remote desktop like Remote Desktop for Chrome which was working - but would die with any windows 10 updates, and then I tried "Anydesk" - which appeared to crash my laptop.


And I won't use TEAMVIEWER ever again. Once badly burned, never again.


After that crash on the laptop, I did a short "flirt" on my laptop with Linux Mint and the xcfe desktop - I am back to running Windows 10 on my laptop in a "bare metal" configuration. I liked Linux Mint (and have it running as a VM on the server), but it just wasn't stable on my Dell Precision M6500 laptop. Even with 16GB of ram. It would "slog" from time to time, and the software loaders were terrible. So, back to Windows 10x64 (1909). I had Windows 7 on the laptop before, but with EOL on Win 7x64, I knew this day would come - and now that I am changed over, I'm not really missing anything about windows 7, except maybe the "gadgets" - which I know I could reload with "Rainmaker" - but honestly, why bother?


Back to the server: So I'm watching the 6.9.0 beta comments, and don't think I will be jumping over to it too quickly on my Dell T310 server. I'm basically happy with Plex and my couple of docker and VMs running (except the remote desktop issues) all under 6.83, and watching the discussions prior to 6.9 public release. I want them (Lime Tech) to work out the last of the bugs - and then - that's when I will move over. To be honest, I wish they'd allow implementation of a virtualbox VM system, as the VM on unRAID still seems plagued by instabilities on some platforms. I'm looking forward to some of the new VM engine improvements I've heard of.


I also have a new server box that I will transition to at some point, but the issue is more of "why". At this point, if I need more speed, I can pop the Xeon CPU in the current box out, and plug in a new CPU with a 40% bump in speed for about $50 - or in a new system I can replace the single Xeon with a dual CPU box and motherboard, with at least a 100% bump in performance, and with a lot more drive bays. But since the current system is not doing much from midnight to noon, I am wondering "Why change anything?" I'm a firm believer in "Let sleeping dogs lie". At some point I'll get bored with the performance, need a video editing rig, and something to process filters on lots of digital photos... but I am not (quite) there yet. Plus with the new 5Ghz systems coming out, there will be some "cheap" 4Ghz servers that will be out on the second hand market before long. That will be soon enough for me to change the server.


I think one of the other upgrades I will need to do is put in a SSD that will be an "unassigned drive" in the system, just to load the VMs from and run them from it. Although, I really do like the idea of a adding a new PCIe card that will handle multiple M.2 SSD drives. But not today, or this month. I have other important things to do... like make a backup image of all my server files. =)

Link to post
  • 2 weeks later...

08 AUGUST 2020 - System down for a bit.


Put the Dell T310 server on "Cold standby" as the temps in the basement were getting outrageous, and that's where my home office is. We're planning a house renovation, so this is a short term summer heat issue. So, sadly, nothing to report. Did finally give up on Verizon DSL and went to Comcast (200mbs) service. I'm not pushing the 1TB data cap yet, so no real concern there either. And if I did, I'd adjust the service to unlimited downloads via a business account. I am going to add another SDD to the system to run my VMs through, but that's a minor detail. I did pick up a HDMI to USB 2.0 video converter, which I will be downloading some older videos off VHS tape with. Quality seems good at 1080p30, although most of the tapes will probably look better at 720p30. At least it's something to play with and pass the time.

Link to post
  • 2 months later...

22 OCTOBER 2020 - System & Network re-configuring.


So I moved the Dell T310 server from "Cold standby" to our temporary rental house, that has Verizon FIOS (200mbs) service. So, sadly, nothing much to report - except more trials and tribulations setting up my network. Went to a new IP home address system. Systems came up ok, but the VMs are giving me issues, and only partially connecting to services. No idea why. Example, a google search will produce links, but clicking on any link ends up just hanging in FireFox like there is a DNS conflict - yet everything looks good when I ping at the same address. Weird! More later, I'm not done tweaking things yet...

Link to post
  • 2 months later...

I have a T310 sitting around, I'm curious if you have any power usage/consumption data?  If you posted it, sorry, I missed it reading through everything.  I might repurpose/bring mine back to life based on this thread.  I also have 1030 and 1050 low profile GPU's kicking around from previous SFF builds so I might see if I can make something work there too. Thanks!

Link to post
On 1/22/2021 at 12:07 AM, benak said:

I have a T310 sitting around, I'm curious if you have any power usage/consumption data? 

Nothing I can really share. I do have an APC UPS attached, and it seems to run around 150 watts on idle. If I get data from it, I’ll post it in this thread.

FWIW- The 1050 is a nice add -IF- you plan to do transcoding with Plex, otherwise, I’d not bother. The VM performance on the T310 is “less than stellar” of late with build 6.8.3. And I’m happier to just have a headless NAS, with a Win10x64 image for a VM running a qbitorrent, and a Plex Docker. If I had it to do over, I’d build on a more modern SuperMicro base. But hey, cheap hardware. 



So, I went back to look at my UPS Logs, and my system seems to pull between 180-210 watts, depending on loads. I'm running a couple of VMs (one with BONIC for nCOVID folding & qbitorrent), and a couple of Dockers (one is Plex), but nothing too heavy. If I was running harder, I could see this going up to 300 watts easily. I probably top 350 watts at start/spin up.  If I was concerned about power, I'd definitely go to a laptop (90watts, 3Ghz i7) with dual SSDs (m.4's in RAID) and a SATA external drive based expander with larger (>10TB) drives that could spin down. But to be honest, I'm still ahead of the game on cost with this system (I think.) If I was concerned about throughput, then I'd be getting a old Dell r720 rack mount. But I'm not sharing media, and I don't need the hastles of users complaining. This is a small business & my digital photo archive. I don't need power, I need reliability. This gives it to me at a decent price-point.

Edited by rollieindc
Update on power data
Link to post

Well I blew the dust off the machine, I have the H200 already and 4 1TB drives.  My unit only has the single power supply.  I'm not seeing very much in the way of extra power connections to add drives.... hmm I will need to re-read your posts.  Even with the slower SATA II connections on the MB I was hoping I could just try out a "JBOD" setup to see how it worked.


I have the Xeon 3430 and 4GB of RAM which both seem light if running VM's and such.  I'll see if I can fight through a few firmware updates, etc. and spin this up.  I have a low power Plex server already (HP 290) so I guess I don't need to mess with the video cards, more of a curiosity.


I'll probably look at power with my setup too while I'm going through this and share some numbers for others to see - newer hardware would probably pay for itself pretty quick where I am @ $0.20/kWh

Link to post
  • 1 month later...

Hi Rollieindc,


First off...Great Post!   Lots of colour and details.  Very informative!  Thank you.


I just picked up a T310 for a great price to turn into an unRaid server and I need to replace the PERC 6I. 


I was just curious if you looked at any other cards besides the H200 and H700?


How is the H200 working for you? 


Thanks for any thoughts you can provide.



Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.