My first hobby “TOWER”


Recommended Posts

17 minutes ago, rollieindc said:

Hi Jason! Sorry for the long period not posting... it's been a slog for me. But glad you got something out of this. So, to your questions: I looked at other cards, and the H200 has been the best so far for me. Nothing wrong with the H700, but I had some concerns about being able to flash it and use drives larger than 2TB as I recall. Plus, there was the use of the battery for cache back up that always concerned me. Not a huge issue, but I needed about 20TB for my system, so that made the Flashed H200 a better choice for me.


Going to do an update here shortly... but this COVID isolation has been a real slog for me.

Hey rollieindc,


No worries...totally understand.


I ended up buying a H200 flashed to IT mode as well. Snagged it off ebay.  My server has been up and running for months without issue...thanks in no small part to your post.


Thanks again.



  • Like 1
Link to comment

06 SEPTEMBER 2021 - The DELTA COVID Periodic Update Post


Personal update: Wow, where does the time fly? Oh, right, virtually while at work. Had two scares of COVID Delta in my office, so had to get tested for both (cue the brain swab music) and thankfully tested negative both times. Daughter also had two separate surgeries (mostly minor, but these days, nothing is really minor), and I had a visit to the ER with Kidney Stones (thankfully small and easy to pass.)


System Updates: So my Dell T310 has been working well (24/7/365) for the most part, and I've made a couple of minor upgrades on the server. I did move from the Xeon X3440 to a X3480 to boost the clock up to 3.06Ghz, via a Chinese eBay refurb CPU for $71. That seems to have helped with the overall utilization of tasks/data flow, without impacting the thermals (both chips are rated at 95W, so it was an easy swap and allowed me to put new thermal paste on the CPU.)


I also updated unRAID to 6.9, (now on 6.9.2) and that seems to be running without much of an issue. I do like the new options, user interface layout and overall system information flow. I am mostly still using the box for a NAS and a PLEX media server.

I also moved my BOINC from a virtual machine on Windows 10/x64 Pro to a Docker image. That was a significant boost in both compute speed within BOINC (Rosetta) and overhead (memory) reduction.


Oddity: I did notice the other day that the memory went from 32GB to 16GB "available" in the memory status. Not clear why that was, but I suspect it was a combination of VM and Docker usage. The memory returned after a re-boot, but I am going to be keeping an eye on it.


Unfinished work left to do: There's still some issues that I run into when I run a VM on unRAID, mostly that the graphics/GPU card seems to be unable to be passed correctly out using any VNC or remote desktop I've tried (and I've tried a bunch). I saw that there was a new option out for using Guacamole, so that might be something I try soon-ish. The VM runs basically fine using the included VNC graphics drivers available, but it's just not as "snappy" as using the GPU.


Other stuff: In the meantime, I also acquired a Mac Pro (Mid 2010) and upgraded Bootdrive (SSD), memory (32GB), MacOS X, and the CPUs (now dual HexCore x5680's @ 3.33Ghz each) in it - and even have it running Win 10/x64 as well as High Sierra or Mojave. I'll probably slap on OpenCore soon so I can just multiboot across any of the three OS's. I did go with the AMD RX580 GPU, after struggling with a nVIDIA 680 GPU, and glad I did. But that is another story for another time.


And I also upgraded my home's wireless from a DLink WiFi 6 router (DIR-1950) to a Google Wifi (not NEST) mesh system - connected to 200mbps Verizon FIOS. Didn't affect the server at all, but I try to keep track of what's going on with my network here.


That's about all I have right now. And I have to update the signature block...

Edited by rollieindc
  • Like 1
Link to comment
15 minutes ago, joleger said:

...thanks in no small part to your post.


That's exactly why I keep doing it, to save others trouble and let them "get on with it!" -  And am ecstatic to hear that you got the H200 flashed - and your system up and running, Jason! Let me know how you get along with it. If you start your own thread - I will want to follow it. Feel free to drop me a note here or via email anytime. Glad to share what I've learned and compare notes.

Edited by rollieindc
remove link
Link to comment
  • 1 month later...

Headline: 12 OCT 2021 And then...BOOM: "Automatic unRaid Non-Correcting Parity Check will be started"


Symptom: Running a Windows 10 Pro VM under 6.9.2 with a GPU passthrough causes system wide crash.


Goal: Be able to remote into a Win10VM with a headless GPU (MSI Radeon R7 240) and remote into it.


Preface: Yes, I've watched SpaceInvader's VM video guide about a dozen times and a few others and followed the passthrough process for a GPU. Yes, I've tried using nVidia cards (GT610, GT1030, etc) without any success - only seeing the dreaded "Error 43" pop up repeatedly. I decided to go Radeon and picked up a MSI R7 240 card at MicroCenter to give that a go. Easy, right? No. Far from it so far.


At this point, I'm seeking advice. I'm about to the point where I am considering a dedicated gaming laptop machine with a remote desktop access alternative vice trying to continue to use an unRAID VM with GPU passthroughs.


Background: I've been trying to remote into a Win10Pro x64 VM for about two years on my Dell T310 and had been "now and again" successful - but ONLY with using the VNC QXL controller. That seems to work, and I've had one running for about 6 months stablely (at least as much as Windows is stable.) Its not bad, but not able to handle a gaming program (SecondLife) that I enjoy playing. And ultimately, I want to be able to do this with a remote connection (tried Chrome Remote Desktop, which kinda-sorta worked) but most of the time - while the RedHat QXL controller was working fine - anytime I switch to using the R7 240 GPU as passthrough and remote connect into it, the system hangs in one way or another.


Still, I felt like I had been making slow progress by "tinkering" with the system in the hope I could get it to work.


But last night - I had an interesting new artifact start to occur (recently upgraded to unRAID 6.9.2), when I changed the VM to use the installed MSI Radeon R7-240 card - then things went really bad. At first it worked, but would lock up with any updates to the MSI video drivers. (Ugh) But I got past that - and now it just crashes the entire system from a fresh install when I change the VM over to use the GPU - and not just the VM - the entire server. When I reboot the server system, I get a "Automatic unRaid Non-Correcting Parity Check will be started" in the log file. And the last time it ran, it detected no errors. (Is it possible since I am running the VM from a disk share (disk5), something is going wrong there? Should maybe I pop in a separate "unassigned" HDD for the VM?)


Anyway - I've tried all sorts of VNC programs, MS Remote Desktop for Windows, and various means of connecting the card within the VM (although not Guacamole- "yet")... and just not sure what's the real issue. Not even sure what information to post that might be helpful (Feel free to post a link to the standard reporting protocol for the forum, that's probably where I need to start.)


One thing though, please do not recommend Teamviewer - I essentially was "blackmailed" by their system admin process to cough up the price of a commercial license (Hack-hack at $50.90/mo "Are you out of your [censored]" ) - and my VM system was unreachable for over a week - while I was basically told "Pay up deadbeat." So I finally deleted that VM, and vowed never to trust that program again to log into a VM.


Anyway.... still going to keep plugging at this problem, but if anyone is interested in helping out... drop me a line. I'd appreciate it. At least worth a beer (or KoFi).


(Added - Diagnostics Download)

Edited by rollieindc
Added diagnostics file.
Link to comment
  • 1 month later...


Headline: 22 NOV 2021 Upgrades & downgrades and Virtual Machines that just won't work



Symptom: Windows 10 Pro VM under 6.9.2 with a AMD R7-240 GPU passthrough causes issues.


Goal: Be able to remote into a Win10VM with a headless GPU (MSI Radeon R7 240).


Discussion: So, I managed to add a SSD into the system with use of a PCIe Card that could hold two 2.5 inch SSDs. Unfortunately, the SSDs I have are SAS, and the connector is SATA. So, have a SAS-SATA passthrough connector on the way. (And no, I don't want to Dremel the PCIe card, it's a nice one!) Until then I am using an older 240GB inland SSD and while the VM seems stable when running in on the QXL VNC/Redhat graphics driver, the moment I move it to the MSI Drivers - all heck breaks loose. Yes I used the original drivers, yes I tried the latests, yes I tried the beta drivers, yes I tried Chrome RDP, yes I tried Microsoft RDP. No I won't try teamview, as they "fouled" my system the last time and I will never give them or anyone else who routes my VM through their serves another chance. Interesting bit is, that it works at first - then some upgrade (windows or the AMD Radeon software) does an upgrade to the driver - and I am locked out from being able to get back into the machine until I go back to the redhat QXL and VNC drivers. And personally, that won't cut it for the work I need to do. Also it won't let me work the card as a second graphics card either, or the primary with the MSI/AMD GPU and the VNC as secondary.(And yes, I have checked and the I0MMUs are separate number/call slots)


Plans: At some point though, two Nimbus 400GB SAS SSDs will go into the system, the VM will move to it, and I will be beating the graphics into submission. In short, it's frustrating as heck. I might pull the card completely, and try another card (nVIDIA GT680 or 610) that I have, but the nVIDIA were similarly cursed with ERROR 43 problems. I might be up against it with this T310 in that the VM just will not allow a separate GPU to run on it. If that's the case, then I will start looking to offload this machine and move to a SuperMicro dual Xeon system that I have and can upgrade.

Edited by rollieindc
correct date, minor edit
Link to comment

Update: 23NOV2021 -

Seeing elsewhere on the forum - that it's recommend to use a Windows 10 VM with the Q35 4.2 version as the emulator to do GPU passthrough. Hopefully this fixes it - more after I try it out.


(And "nope", that didn't work either!)

Edited by rollieindc
minor update
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.