Jump to content

unRaid server wont boot - usb drive not detected


Recommended Posts



Just came back from vacation and noticed that my unRaid server was down. Rebooted the machine to find that the USB thumb drive that I’m using isn’t being picked up by my mobo anymore. 


Tried rebooting, unplugging, and a different usb port all with no success...  Is it possible to check the usb drive on my Mac to determine whether the usb drive is dead or the unRaid boot files are corrupted?


Any thoughts on how to continue debugging this? 


P.S. Believe I was running unRaid 6.5.2 using a 32GB Sandisk 3.0 usb thumb drive. 

Link to comment

Argg, looks like it's completely dead... doesn’t even show up when plugged into my Mac ?


I've bought a new usb drive and am in the process of installing a fresh version of Unraid on it and then will proceed with the steps outlined on the replace-key help page.


Is there a how to article somewhere that walks you through how to restore your server? I really don't want to loose any dockers/VMs if I can help it and especially not any data.

Link to comment

I only have the link from the email when I purchased the Unraid license. ?Is there any way to find out which drive was parity, cache, etc..?


Also reached out to Sandisk and the only thing they can do is replace the drive and try to recover the data for $275 + $100 if they need to fix the connection!!!


Arggg... what a nightmare!!

Link to comment

Cache should be easy to identify, unless you were using a large disk similar to those on the array, but assuming it was a single device it can be identified together with parity by assigning all disks as data disks, not assigning any parity, if you only had one parity disk it will be the unmountable disk, cache if needed can identified by browsing each disks content.

Link to comment
1 minute ago, unRaide said:

Regarding all my dockers and VMs is there any chance I’d be able to recover those or will i need to recreate everything from scratch?

You can use the existing ones, just make sure that in both the settings are correct, i.e., they are pointing to the existing folders/images, like the existing appdata folder, docker and libvirt images.

Link to comment
2 hours ago, johnnie.black said:

Was thinking that I believe the dockers will still need to be re-added, since the templates are saved on the flash drive, but not sure since dockers are not really in my wheelhouse.

All the templates for the various apps are stored on the flash drive.  


All of your appdata however is perfectly safe.  You just have to reinstall the apps via the apps tab, and set the appropriate paths and ports that you had before.  Once that's done, everything will carry on like nothing ever happened.

Link to comment



Thanks again for the continued help... have actually been working with a company to see if i could get any data off the USB drive but that didn’t work :(


Ok, so it looks like I am going to have to start with a new usb drive.


Trying to idiotproof this as much as possible here are the steps based on comments above and hopefully useful to anyone coming across a similar issue:

  1. Create new USB thumb drive using latest image from Unraid site
  2. Boot up the server using new thumb drive
  3. Server should boot and detect that the key is invalid. Array will be stopped
  4. Request a new key from replace key page and follow steps outlined there
  5. New key installed
  6. Try mounting all disks as data disks
  7. The unmountable disk should be the parity
  8. Browse data disks to find cache disk. Might require some digging as i was using the same disk type/size as an unassigned device for VMs
  9. Reinstall all apps/plugins by downloading them again from App Store and configuring them to point to the same data directory as before using the same settings. **Question**: I'm assuming I'll be able to browse the app data folders to view the previous configs as i dont remember what they were before?

Is there anything else I'm missing?



Link to comment

What’s the best way to restore all my shares?


Is there any config data that I can look at in my array/cache to view them all and the correct settings for each (ie cache settings, etc..) 


Should I just try and recreate then from scratch?

Link to comment

Ok, I've got the server back up and running and replace the registration key. 


My current storage config is:


4 x WD Red 8TB (3 for the array and 1 for the parity drive)

1 x Samsung nVme SSD 500GB (cache drive)

1 x Samsung nVme SSD 500GB (Unassigned device for VMs)


I have now assigned *all* my hard drives listed above as Array Devices to the Disks section as Disk 1-6, with no parity assigned and no cache disk assigned. 


@johnnie.black, per your comment above just want to confirm that I should now: 

  1. Start the array?
  2. See which drive is unmountable as that one is the parity drive
  3. Browse the SSD drives to see which one is the cache vs unassigned device
  4. Stop the array
  5. Re-assign the parity and cache drive
  6. Restart the array
  7. ...hold breath...
  8. Begin re-downloading / configuring dockers and plugins

Apologies for being overly dramatic here....just want to make sure that I have step 1 correct so I don't accidentally start the array and hose all my data :)

Link to comment

Thanks again, I'd be lost without your help!!!


Ok, I've figured out which drive is the parity and which one is the cache and stopped the array.


On the New Config page do I need to  select anything for "Preserve current assignments" or move ahead with None?


Also how do I check "parity is already valid"? Is that another tool or a setting somewhere?


Link to comment

Woohoooooo....I'm back up and running, tkuuuu Johnnie!!! ???



On 7/11/2018 at 12:21 PM, Squid said:

All the templates for the various apps are stored on the flash drive.  


All of your appdata however is perfectly safe.  You just have to reinstall the apps via the apps tab, and set the appropriate paths and ports that you had before.  Once that's done, everything will carry on like nothing ever happened.


Went to my dockers tab and noticed that all my dockers are running, a guess a lot of them were set to autostart. I've stopped them all and am now moving onto reinstalling them. @Squid, I'm assuming I simply need to select "Reinstall application using default values" and then update the template values as best as I remember? Is it possible for me to see what the previous settings were by looking at any files anywhere... or is that what was lost on the USBs config folder :)


Link to comment

I'm almost back up and running, just trying to sort out all my shares.


I ran the "Fix Common Problems" plugin and it seems like my AppData share is set to Cache = No when it should be Cache = Yes. I'm trying to figure out how to fix this as most of my files are already on the cache however the files that aren't are spread over all 3 disks it seems like.


Any ideas on how to correct this? Do I have to go in manually and copy every file that is on one of the disks to the cache?


Link to comment

Some quick follow-up...

  1. Do I need to stop/start the array for any of this?
  2. If a file on the array is newer will it overwrite an older one on the cache or is that what you meant by "delete the older one"?
    1. In which case I'd need to delete the older one and invoke/wait for the mover to run?
Link to comment


This topic is now archived and is closed to further replies.

  • Create New...