Jump to content
Sign in to follow this  

appdata folder corruption

4 posts in this topic Last Reply

Recommended Posts

Posted (edited)

Hi all,

i tried upgrading my cache drive this weekend using these instructions and failed miserably:



odd thing is, even tho the docker was off, the contents of appdata wasnt completely cleared off when i ran the mover.    I ended up manually tarring up and moving the residual contents the mover missed elsewhere.


when i replaced the cache drive, it copied back what it could thru the mover.   When the majority of docker didnt work (they were back to their default)  , i manually moved the remaining contents of appdata that seemed to be missed by the mover.  


now the new cache drive isnt booting as a cache drive.    (even tho its mounted under /mnt/disks/)


long story short, i think i completely messed up my appdata folder.     Copying any data  around is now extremely slow.      after the latest move i cant even get into the gui, i just get an nginix 504 error.    I still have shell access.    Am i completely screwed?


I do have a clean backup of the appdata folder but its from 2016.    any worth trying to restore that or will it be completely incompatable with unraid 6.5?   I know i should have made a clean backup of appdata before starting this process....  


Edited by DanDee
forgot to mention somthing

Share this post

Link to post
Posted (edited)

so it appears after reseating the drives, my speeds are ok again.   i must have knocked a cable loose while plugging in the new ssd.


It turns out the reason the majority of the dockers were back to their factory state is because when i originally set them up back int he day i mounted the appdata path under /mnt/cache instead of /mnt/user/


sadly, i will need to recreate most of my appdata folder.   not the end of the world, At least im in a better situation than i thought i was in.


one issue is, how do i re-mount my ssd as a cache drive?  I can mount it, but it always just mounts as a stand-alone drive under /mnt/disks/ .   To properly set it up as a cache drive do i need to preclear / format it first before given the option ?   there is a /mnt/cache folder still.   should i remove it or will a symbolic link to the ssd drive be created once properly mounted ?


one more thing

i notice when i restore the appdata folder, /mnt/cache/appdata gets populated even tho there is no cache drive present.   is the fact there are files being created in /mnt/cache/ the reason why i cant mount a cache drive?

Edited by DanDee
one more thing...

Share this post

Link to post
7 hours ago, DanDee said:

i notice when i restore the appdata folder, /mnt/cache/appdata gets populated even tho there is no cache drive present.

That data is going to be gone on reboot, if the drive isn't actually mounted there those files are in RAM.


When the array is stopped, you should be able to pull down the drive list in the cache slot and see your SSD.


Attach your diagnostics zip file downloaded after you try that to your next post if if doesn't work.

Share this post

Link to post

Docker idiosyncrasies. If the path best ng referenced in the mappings doesn't exist, it will get created

Your cache drive is now mounted via unassigned devices, but your containers are still referencing /mnt/cache

Sent via Tapatalk because I'm either at work or enjoying the summer

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this