Jump to content
Sign in to follow this  
alexfsr

6.5.3 Enabling SSL broke my server

8 posts in this topic Last Reply

Recommended Posts

Just upgraded from 6.3.3 and decided to enable SSL. The intention was to use a self-signed cert and keep the server inside my local network.

The moment i switched SSL to Yes i lost connection to my server. It redirects to "homenas.local" bullsh*t that windows cannot resolve because the f*ck is that???

I cannot connect to the server's web interface now. How do i disable this shit from a local terminal on the server machine itself to restore connectivity?

 

***The server has critical data on it and i'm super pissed.

Share this post


Link to post

You can always use the IP address instead of the hostname.

Share this post


Link to post
5 minutes ago, jonathanm said:

You can always use the IP address instead of the hostname.

I always do that. But after i enabled SSL it redirects to this "homenas.local" immediately and the browser throws an error because it can't find that (how could it, there is no such thing).

Share this post


Link to post

Just to be clear, you are saying https://192.168.x.x/ redirects?

Share this post


Link to post
1 minute ago, jonathanm said:

Just to be clear, you are saying https://192.168.x.x/ redirects?

hmmm. Manually putting in the https in front makes it work. wtf??

https://192.168.x.x/  works

192.168.x.x/   redirects

Share this post


Link to post
1 minute ago, alexfsr said:

hmmm. Manually putting in the https in front makes it work. wtf??

https://192.168.x.x/  works

192.168.x.x/   redirects

http:// returns a redirect to the https://fqdn, which in your case doesn't work properly. https:// has no such redirect in place.

Disable the https and you should be back to normal.

Share this post


Link to post
2 minutes ago, jonathanm said:

http:// returns a redirect to the https://fqdn, which in your case doesn't work properly. https:// has no such redirect in place.

Disable the https and you should be back to normal.

I did. But i do want to use SSL but use self-signed cert and just have it redirect 192.168.x.x to https://192.168.x.x

Share this post


Link to post

SSL only works with FQDN, it can't be set up for an IP.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this