Jump to content

(SOLVED) In Need of Guidance with Parity Errors

Rock G

Recommended Posts

Hello everyone, 


I have been using unRaid for a little over 6 months and ran into my first issue that I need assistance with. 

I regularly run a parity check once a month but ran into some errors 2 nights ago, about 200+ parity errors, and disk1 ended up being mounted read-only. I also noticed a ton of read errors and corrections on one of my cache drives. After some googling I started the array in Maintenance mode, ran a filesystem check followed by a filesysten check with repair on disk1. Also, and I believe this is where I went overboard cause I'm a maniac and potentially created more issues, I started messing around with my cache drives.

First I moved my shares off the cache drive to the array (appdata, system, downloads & domain), stopped the array, unmounted both cache drives, deleted each partition, reformatted in XFS, remounted then again formatted the cache disks after restarting the array. I then moved the same shares back to cache, restored appdata from backup then had to rebalance the cache drives because of dual profiles. After all of this I then restarted the parity check which usually runs for about 15-16hrs due to the size of my array. Fast forward this afternoon, I received an email notification that the parity check completed but now there are more errors, 615 to be exact. 


I have not done anything since the parity check completed aside from doing another diagnostic dump which I also did prior to running this 2nd parity check. 


Can someone please review both diags and provide guidance? I have a 2nd unRaid box which is basically a clone of Tower1 so worse comes to worse, I have my stuff backed up. I also just bought 2 new 12TB Ironwolf drives, (thanks to prime day!), which I was planned to use as an upgrade to both parity drives on Tower1 before all of this happened. With that said, I am fine blowing everything on Tower1 to start over then restore from Tower2 but I also welcome the learning opportunity in terms of troubleshooting and learning more about the system. 


Any feedback and guidance will be greatly appreciated. 



Link to comment

Thanks johnnie.black, I suspected cache1 contributed to the errors so I moved shares from the cache drive to the array then ran another parity check. It came back clean with no errors but as a precaution I followed your suggestion as well. I ran multiple passes of memtest and all passed error free. I also went ahead and replaced the sata cable on cache1 for good measure. 

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...