Can not type pipe '|' key via unraid vnc


iga

13 posts in this topic Last Reply

Recommended Posts

Hi guys,

 

I have a few linux vms created with unraid and I am struggling to find a way to type pipe(|) in terminal via unraid vnc, either the browser version of novnc or tightvnc viewer. the keyboard mapping are all default to us keyboard, they all turn '|' to '>' for either lubuntu, manjaro or mxlinux.

 

when I ssh in, everything works just fine.

 

Could anyone give some suggestions?

Link to post

I'm having the same issue and not only does typing the '|' character ('shift + \' ) produce '>' and not the expected '|'  but the '<' key ('shift + ,') also produces '>' and not the expected '<'.  typing the non-shifted characters works fine, \ and ,

 

I've tried the browser vnc, tight vnc and tiger vnc.

 

unraid 6.5.3

 

arch linux typing 'SHIFT + \' produces '>' and 'SHIFT + <' produces '>'

ubuntu 14.04 typing 'SHIFT + \' produces '>' and 'SHIFT + <' produces '>'

 

osx high sierra both 'SHIFT + \' and 'SHIFT +' , produce a '+' over top a '_' (a "plus-minus" symbol if you will)

 

windows 10 - the '\' and '|' can be typed fine, but 'SHIFT + ,' produce '|' instead of '<' and 'SHIFT + .' produce '|' instead of '>'

 

If any logs or anything are needed, please lmk

Edited by juanamingo
Link to post

I am also experiencing the same issue reported here.

 

 

ubuntu 16.04 typing 'SHIFT + \' produces '>' and 'SHIFT + <' produces '>'

 

I was setting up a new server when I experienced this issue.  I then tried booting an existing Ubuntu server that I've used for 2 years, initially setup in an unRAID VM with no issues with the pipe character.  When trying to type a pipe character, this old server also produced a > instead of |.  This appears to be an issue with either unRAID, or more likely the noVNC being used.

 

Link to post
  • 2 weeks later...
5 hours ago, eschultz said:

Probably in a week.  QEMU 3.0 was just released so we'll get that in to the public unRAID 6.6-rc release too.

Any chance that includes the HTML5 SPICE client and SPICE integration?
Spice is way more cohesive to a VM than VNC is.

Link to post
  • 2 weeks later...
  • 2 years later...
  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.