Jump to content

(solved) noVNC fails to connect to server (Win10 VM)

10 posts in this topic Last Reply

Recommended Posts

since I didn't get a single response yet, over in the KVM forum, I am cross-linking here in hope to reach a few more eyes:

my Windows 10 VM stopped working, and I wonder why, and how to get it working again.

I started this discussion in the KVM forum, but bc it gets so few views, I thought I'd link to it from here.

Edited by tillkrueger
change discussion title

Share this post

Link to post

Read through the posts on this page.   There are a number of ways to get this resolved.  You just have to find which one works  for you.  (Hopefully, MS has not made another change to make life difficult...) 

Share this post

Link to post
2 hours ago, Frank1940 said:

Read through the posts on this page.

sorry, on *which* page? did you intend to send a link, or was it your way of saying "just search this forum"? ;)


Share this post

Link to post

Not sure whether that discussion is what I am looking for.

See, I faintly remember having had the same issue last year, when setting up the VM for the first time, and I had to re-create the VM a few times, after first installing Windows 10, until it did work.

I don't want to have to install Windows 10 again and already have an 86GB vdisk1.img which worked really well until recently, so my question is what in my current settings might cause noVNC to immediately alert me that it failed to connect to the server...waiting for a few minutes to maybe let SMB "catch up", as it was suggested in the discussion you linked to, also has no effect.

I think there may be some setting that isn't quite correct...I attached a screen cap of my VM settings page.


Share this post

Link to post

The title to your thread may be misleading many people.  What I assumed was that you were having an issue with a Win10 VM being unable to connect to a User Share.  (A lot of folks don't even like getting involved with SMB issues because they can be a bag of worms...)  Apparently, your VM is not starting correctly which is an entirely different problem area. 


I have never run a VM so I am unable to help you figure out what is going on.  Hopefully, someone will take a look and will be able to help you.


EDIT:  You can change your title by editing your first post in this thread.  

Edited by Frank1940

Share this post

Link to post

maybe so, Frank1940, but just to be sure, I changed the title in hope of not misleading so many people.

like I said, it worked splendidly until recently, and suddenly I get this scene when noVNC opens.

I even deleted the VM definition and set it up again, but same error...it must be something really small, so I hope someone can help me figure it out.


Share this post

Link to post

I have always found that noVNC can have problems with some VMs for no apparent reason.     As a result I now always use a VNC client that is not browser base (I use realVNC) to access VMs on unRAID.

Share this post

Link to post

and right you are, itimpi...now that you mention it, that was kind of the problem last year as well, until I went thourgh half a dozen VNC clients until I settled on "Screens" to connect with my VM.

and low and behold, I was able to connect with Screens, yet again...only to find that there is something wrong with the actual VM itself, but at least I am now able to connect with it and will try to take it from here, maybe open another discussion if there is something specific I can't figure out.

thank you itimpi for reminding me! :)

Share this post

Link to post

just finished getting a Windows 10 VM to work again, although I did have to start installing from scratch...not sure what was wrong with my other one, but I had to trash it.

thanks to SpaceInvader One's excellent YouTube tutorial, this new one is running better than the previous ever did...what an excellent tutorial!

after midnight here in Germany, but so worth the few hours of work on this.
g'nite everyone, over and out...

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now