Jump to content

Ghost Docker container is not getting an I.P. for some reason?


plantsandbinary

Recommended Posts

Sorry this is a little long. **TL;DR at the bottom!**

 

I'm trying to use the official Ghost docker container on Unraid. As the CA version we have is not working with MySQL. That's another story.

 

First I find and install the container from the 'Docker hub':

 

btb6lOr.png

 

Then I install it, and set the network interface to the custom interface I made [web] where I run almost all of my containers with reverse proxy:

 

60Hz4oK.png

 

Installation is successful but the container isn't being served at the same I.P. address like the rest of my containers (it should be 192.168.1.50):

 

PDKERzW.png

 

 

The log shows that the installation was fine and database tables were made and the blog should now be accessible but it isn't:

 

ZhQU7yA.png

What extra steps do I need to do here? I'm trying to get this served under the Letsencrypt container that I already have installed.

Basically I have a domain (eg. server1.com) where I have a landing page with access to all my reverse proxy'd containers.

But I want to host this Ghost blog on a different domain (eg. ghostblog.com).

 

The problem is that without it being served at the same I.P. as the rest of my containers, nothing can connect to it. I can't access the Ghost landing page at all.

It does work however if I set the network type to Bridge and then type out a custom I.P. eg. 192.168.1.80

The problem then is that when I try and reverse proxy the container with a config like this in my server block:

 

    server {
        listen 443 ssl;
        server_name ghostblog.com;
        location / {
                proxy_set_header X-Real-IP $remote_addr;
                proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
                proxy_redirect off;
                proxy_set_header Host $http_host;
                proxy_pass http://192.168.1.80:2368;
        }
    }

 

I just get a generic "Bad Gateway" error.

 

I'd use the Community Applications docker image but it doesn't work any more because the mysql container it relies on hasn't been updated in ages. Also it requires a separate relational database, and it requires mailgun which I don't want to use. I should be able to use the official image without any problems.

 

How are other people doing this? I'd rather not set up VMs etc. and do it that way if possible.

_______________________________

TL;DR: I'm trying to set up the official Ghost docker container (not the CA one) to run Ghost on my Unraid server. But it won't give me an I.P. address unless I set the network to "Bridged" and assign it a custom I.P. but if I do that, I can't reverse proxy the container without getting a 502 Gateway Error. What's the solution here?

Link to comment
22 minutes ago, plantsandbinary said:

TL;DR: I'm trying to set up the official Ghost docker container (not the CA one)

Not that I know anything about Ghost, but the Ghost contained in the apps tab does point to the official repository, and the same repository that you linked to

Link to comment

I was going about this the wrong way. I got it sorted about 5 days ago, don't really remember how but I got a lot of help from redditors, and I am running my blog on a different domain which is exactly what I wanted and it works fine. I'm going to delete my mailgun account because I don't need it. Setting it up with MariaDB worked far better than MySQL.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...