Windows 10 SMB Share issues


37 posts in this topic Last Reply

Recommended Posts

I'm having issues being able to see any of the shares on my unraid server on my Windows 10 Desktop.  I've view dozens of forum posts on here and can't seem to find anything that works. This is after a wipe and reinstall to fix issues I was having with Windows 10.  Here are the bullet points and what I've done so far:

- Other Windows 10 computers can see and edit just fine. I've got a Windows 10 VM on another server that works just fine and it did so right from a fresh install.

- The Windows 10 machine that can't, won't even let me see the shares, when I double click on the host name "Tower" it gives me "Windows cannot access \\Tower"  Then it says "The network path was not found" Error Code 0x80070035

- I've tried browsing to the IP and to the Host name in windows explorer with the same result.

- I've turned off Windows defender ransomware protection

- Not running any other AV or firewall. I've turned off Windows firewall as well.

- Hooked up through Ethernet and verified it's set to "Private Network" not Public

- I can ping the Unraid server and after turning on SMB v1 in Windows, I can see it when I browse the network in Windows Explorer

- I can use remote desktop to get to another server just fine and view other network resources

- I've tried rebuilding permissions on the Unraid box with the "New Permissions" tool

- I can browse to the WEB gui on the windows 10 machine that can't view the shared folders.

- Set SMB settings Local Master to "Yes"

- Cleared all credentials in the Credential Manager

- Verified both the Windows 10 box and Unraid both are set to the exact same workgroup

- Windows is fully updated to 1803 build

- Unraid is updated to 6.5.3

- Tried changing the Workgroup name on the unraid server, it's set back to just the default "WORKGROUP" now

- Tried turning off SMB and Turning it back on

- Full reboot of the Unraid server

 

 

I've attached the diagnostics log file. 

 

Thanks for any help you can provide

 

tower-diagnostics-20180827-1615.zip

Link to post
1 hour ago, dcast777 said:

I'm having issues being able to see any of the shares on my unraid server on my Windows 10 Desktop.  I've view dozens of forum posts on here and can't seem to find anything that works. This is after a wipe and reinstall to fix issues I was having with Windows 10.  Here are the bullet points and what I've done so far:

- Other Windows 10 computers can see and edit just fine. I've got a Windows 10 VM on another server that works just fine and it did so right from a fresh install.

- The Windows 10 machine that can't, won't even let me see the shares, when I double click on the host name "Tower" it gives me "Windows cannot access \\Tower"  Then it says "The network path was not found" Error Code 0x80070035

- I've tried browsing to the IP and to the Host name in windows explorer with the same result.

- I've turned off Windows defender ransomware protection

- Not running any other AV or firewall. I've turned off Windows firewall as well.

- Hooked up through Ethernet and verified it's set to "Private Network" not Public

- I can ping the Unraid server and after turning on SMB v1 in Windows, I can see it when I browse the network in Windows Explorer

- I can use remote desktop to get to another server just fine and view other network resources

- I've tried rebuilding permissions on the Unraid box with the "New Permissions" tool

- I can browse to the WEB gui on the windows 10 machine that can't view the shared folders.

- Set SMB settings Local Master to "Yes"

- Cleared all credentials in the Credential Manager

- Verified both the Windows 10 box and Unraid both are set to the exact same workgroup

- Windows is fully updated to 1803 build

- Unraid is updated to 6.5.3

- Tried changing the Workgroup name on the unraid server, it's set back to just the default "WORKGROUP" now

- Tried turning off SMB and Turning it back on

- Full reboot of the Unraid server

 

 

I've attached the diagnostics log file. 

 

Thanks for any help you can provide

 

tower-diagnostics-20180827-1615.zip

 

I know this is obvious, but, it is not in your list of things you have tried.

 

Is Network Discovery turned on on that Windows 10 machine? 

 

I found that a Windows 10 update a couple of month ago had, for some reason, turned it off.  Re-enabling Network Discovery and SMB 1.0/CIFS server and client fixed that issue and I now check those after every major Windows update as they are often disabled by updates.

Link to post

 

40 minutes ago, dcast777 said:

Thanks for the suggestion. 

 

 

I wish it was a solution and not just a suggestion. 

 

It seems like there are one or two reports of this every couple of days now and many different solutions.  Eventually, Microsoft is going to just totally do away with SMB 1.0 support as they have done with Homegroups and then those for whom that was a solution (like me) will be hosed.  I wish unRAID worked more reliably with SMB 2/3, but, it seems to need SMB 1.0.

 

Windows 10 networking is such an adventure these days that it seems to need constant troubleshooting.

 

The fact that you can't even see the shares when accessing the server via IP address is baffling.

 

Link to post

Try one of these:

  1. Download latest driver of your network card, uninstall current driver, restart, reinstall driver.
  2. Use regedit to delete all entries of any memorized network (wired and wireless), restart.
  3. Reinstall Windows from scratch

The fact that your other VM / machine can access unRAID fine suggests your unRAID config is good. So all we can do is to try to force Windows to "forget" what it had that didn't work. All have worked for me at one point or another.

 

Why (3)? I have had a weird corrupted windows update (the major type - one that creates a windows.old folder) that suddenly caused things to inexplicably fail which was only fixed by reinstalling and reupdating from scratch.

Edited by testdasi
Link to post
  • 4 weeks later...

I am curious if you ever found a solution to your problem?

 

I am experiencing the same problem.  I literally fired up my first unraid system yesterday.  As yet I haven't even set a password, and the one share I have created is set to public.  I have zero problem accessing the share on 2 of my 3 windows 10 computers.  The 3rd, however, shows the server in explorer under Network, but when I try to open it I get the error message below.  I have also typing the server name in directly and get the same error message.

 

Windows cannot access \\Tower

Error code: 0x80070035

The network path was not found.

 

What is even more odd about 1 out of 3 computers not being able to open the server, is that the 3rd computer can see my other 2 servers just fine.  I also have a Synology NAS and Amahi server, which the offending computer can access without issue.  All 3 machines are Windows 10, but the computer unable to connect with unraid is running Windows 10 Pro while the other two are windows 10 home.  This is odd since you would expect the Pro machine to have the more robust networking abilities, if there is any difference between the two.

Link to post
9 hours ago, jkBuckethead said:

I am curious if you ever found a solution to your problem?

Here is a long thread in the Microsoft support forums about this specific error over a period of three years.  Various solutions are offered. Perhaps one of them will work for you.

 

https://answers.microsoft.com/en-us/windows/forum/windows_10-networking-winpc/windows-10-explorer-network-error-0x80070035-the/f30a1112-ffa7-4230-b843-ecc7ab8b5119

Link to post
14 hours ago, Hoopster said:

Here is a long thread in the Microsoft support forums about this specific error over a period of three years.  Various solutions are offered. Perhaps one of them will work for you.

 

https://answers.microsoft.com/en-us/windows/forum/windows_10-networking-winpc/windows-10-explorer-network-error-0x80070035-the/f30a1112-ffa7-4230-b843-ecc7ab8b5119

I've been down some crazy rabbit holes with windows before, but this one really takes the cake.  A little googling, and you quickly see that tons and tons of people have experienced this particular error.   There are dozens upon dozens of potential solutions, ranging from simple to extremely complicated and everything in between.  Reading posts of people's results couldn't be more random.  For every person that is helped by a particular solution, there are twenty people for whom it didn't work.  I myself had tried about a dozen of the best sure-fire fixes without any success.

 

I really didn't have much hope, but I took a look at the post linked above.  The thread started in August of 2015.  One common thread in error 0x80070035 posts is the 1803 windows 10 update so I decided to jump ahead to the end of the thread.  Low and behold, on page 5, the first post I read struck a chord for some reason.  Even though I was quite tired of trying random things without success, I decided to give this registry edit a try.  As soon as I added the key below I was able to access the unraid server.  I didn't even have to reboot.  HALLELUJAH!!!!

 

Try: (Solution)

https://www.schkerke.com/wps/2015/06/windows-10-unable-to-connect-to-samba-shares/

Basically the solution follows, but you'll need to use regedit:

add the new key HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters\AllowInsecureGuestAuth key, value set to 1

It's interesting to know one of my other computers that works doesn't have this key, but it has "AuditSmb1Access" which set to 0, which this computer doesn't have.  

 

I checked one of windows 10 home machines, and like the post above it does not have the AllowInsecureGuestAuth key, but does have the AuditSmb1Access key set to 0.  My windows 10 pro machine, the one the could not access my unraid server, had the AllowInsecureGuestAuth set to 0.  Setting this to 1 appears to have fixed my problem.

 

I'm not certain, but I suspect the different keys could be linked to one being Home and the other Pro.  Again I'm just guessing, but the name suggests that access was blocked because the share lacked a password.  I guess it's a security thing, but it's kind of an unexpected default setting.  I wonder what GUI setting this is associated with.  I don't recall ever seeing a windows setting to block access to open servers.  I don't even want to test and see how much frustration I could have saved myself if I had simply secured the share and set a password from the start.

 

  • Like 1
  • Thanks 5
Link to post
5 hours ago, jkBuckethead said:

I don't even want to test and see how much frustration I could have saved myself if I had simply secured the share and set a password from the start.

Look at it this way, you would have been masking a latent issue that could have bit you later. Now, you know.

Link to post
  • 3 months later...
  • 4 months later...
  • 2 weeks later...
  • 3 months later...

Struggled to find a solution and tried pretty much every step listed on the first 4 pages on the microsoft support site. This finally did it. Especially step 2

 

Step 1:

1.1) Press Windows+R (Open Run)

1.2) Execute gpedit.msc. It will open the Local Group Policy Editor.

1.3) Follow the dropdown options as:

       Local Computer Policy -> Computer Configuration -> Administrative Templates -> Network -> Lanman Workstation

Then Enable the Enable insecure guest logons

Try to access the devices over the network once.

If it does not works then Step 2 can be followed.

Step 2:

1.1) Press Windows+R (Open Run)

1.2) Execute gpedit.msc. It will open the Local Group Policy Editor.

1.3) Follow the dropdown options as:

       Local Computer Policy -> Computer Configuration -> Windows settings -> Security Settings -> Security Options

Then Disable the Microsoft Network client: Digitally sign communications(always)

While searching for solutions, I could found a lot of solutions and most of them have been included in this thread. As above steps worked for me, I thought of including them here.

Link to post
  • 1 month later...
On 9/24/2018 at 10:18 PM, jkBuckethead said:

I've been down some crazy rabbit holes with windows before, but this one really takes the cake.  A little googling, and you quickly see that tons and tons of people have experienced this particular error.   There are dozens upon dozens of potential solutions, ranging from simple to extremely complicated and everything in between.  Reading posts of people's results couldn't be more random.  For every person that is helped by a particular solution, there are twenty people for whom it didn't work.  I myself had tried about a dozen of the best sure-fire fixes without any success.

 

I really didn't have much hope, but I took a look at the post linked above.  The thread started in August of 2015.  One common thread in error 0x80070035 posts is the 1803 windows 10 update so I decided to jump ahead to the end of the thread.  Low and behold, on page 5, the first post I read struck a chord for some reason.  Even though I was quite tired of trying random things without success, I decided to give this registry edit a try.  As soon as I added the key below I was able to access the unraid server.  I didn't even have to reboot.  HALLELUJAH!!!!

 

Try: (Solution)

https://www.schkerke.com/wps/2015/06/windows-10-unable-to-connect-to-samba-shares/

Basically the solution follows, but you'll need to use regedit:

add the new key HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters\AllowInsecureGuestAuth key, value set to 1

It's interesting to know one of my other computers that works doesn't have this key, but it has "AuditSmb1Access" which set to 0, which this computer doesn't have.  

 

I checked one of windows 10 home machines, and like the post above it does not have the AllowInsecureGuestAuth key, but does have the AuditSmb1Access key set to 0.  My windows 10 pro machine, the one the could not access my unraid server, had the AllowInsecureGuestAuth set to 0.  Setting this to 1 appears to have fixed my problem.

 

I'm not certain, but I suspect the different keys could be linked to one being Home and the other Pro.  Again I'm just guessing, but the name suggests that access was blocked because the share lacked a password.  I guess it's a security thing, but it's kind of an unexpected default setting.  I wonder what GUI setting this is associated with.  I don't recall ever seeing a windows setting to block access to open servers.  I don't even want to test and see how much frustration I could have saved myself if I had simply secured the share and set a password from the start.

 

Changing the regkey to 1 worked for me. Thanks!

Link to post
On 9/25/2018 at 1:18 AM, jkBuckethead said:

I've been down some crazy rabbit holes with windows before, but this one really takes the cake.  A little googling, and you quickly see that tons and tons of people have experienced this particular error.   There are dozens upon dozens of potential solutions, ranging from simple to extremely complicated and everything in between.  Reading posts of people's results couldn't be more random.  For every person that is helped by a particular solution, there are twenty people for whom it didn't work.  I myself had tried about a dozen of the best sure-fire fixes without any success.

 

I really didn't have much hope, but I took a look at the post linked above.  The thread started in August of 2015.  One common thread in error 0x80070035 posts is the 1803 windows 10 update so I decided to jump ahead to the end of the thread.  Low and behold, on page 5, the first post I read struck a chord for some reason.  Even though I was quite tired of trying random things without success, I decided to give this registry edit a try.  As soon as I added the key below I was able to access the unraid server.  I didn't even have to reboot.  HALLELUJAH!!!!

 

Try: (Solution)

https://www.schkerke.com/wps/2015/06/windows-10-unable-to-connect-to-samba-shares/

Basically the solution follows, but you'll need to use regedit:

add the new key HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters\AllowInsecureGuestAuth key, value set to 1

It's interesting to know one of my other computers that works doesn't have this key, but it has "AuditSmb1Access" which set to 0, which this computer doesn't have.  

 

I checked one of windows 10 home machines, and like the post above it does not have the AllowInsecureGuestAuth key, but does have the AuditSmb1Access key set to 0.  My windows 10 pro machine, the one the could not access my unraid server, had the AllowInsecureGuestAuth set to 0.  Setting this to 1 appears to have fixed my problem.

 

I'm not certain, but I suspect the different keys could be linked to one being Home and the other Pro.  Again I'm just guessing, but the name suggests that access was blocked because the share lacked a password.  I guess it's a security thing, but it's kind of an unexpected default setting.  I wonder what GUI setting this is associated with.  I don't recall ever seeing a windows setting to block access to open servers.  I don't even want to test and see how much frustration I could have saved myself if I had simply secured the share and set a password from the start.

 

Thank you so much! I just did a clean reinstall of my Windows 10 laptop and I couldn't connect to any of my shares. That regedit did the trick. 

Link to post
  • 5 months later...
On 9/25/2018 at 3:18 PM, jkBuckethead said:

I've been down some crazy rabbit holes with windows before, but this one really takes the cake.  A little googling, and you quickly see that tons and tons of people have experienced this particular error.   There are dozens upon dozens of potential solutions, ranging from simple to extremely complicated and everything in between.  Reading posts of people's results couldn't be more random.  For every person that is helped by a particular solution, there are twenty people for whom it didn't work.  I myself had tried about a dozen of the best sure-fire fixes without any success.

 

I really didn't have much hope, but I took a look at the post linked above.  The thread started in August of 2015.  One common thread in error 0x80070035 posts is the 1803 windows 10 update so I decided to jump ahead to the end of the thread.  Low and behold, on page 5, the first post I read struck a chord for some reason.  Even though I was quite tired of trying random things without success, I decided to give this registry edit a try.  As soon as I added the key below I was able to access the unraid server.  I didn't even have to reboot.  HALLELUJAH!!!!

 

Try: (Solution)

https://www.schkerke.com/wps/2015/06/windows-10-unable-to-connect-to-samba-shares/

Basically the solution follows, but you'll need to use regedit:

add the new key HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters\AllowInsecureGuestAuth key, value set to 1

It's interesting to know one of my other computers that works doesn't have this key, but it has "AuditSmb1Access" which set to 0, which this computer doesn't have.  

 

I checked one of windows 10 home machines, and like the post above it does not have the AllowInsecureGuestAuth key, but does have the AuditSmb1Access key set to 0.  My windows 10 pro machine, the one the could not access my unraid server, had the AllowInsecureGuestAuth set to 0.  Setting this to 1 appears to have fixed my problem.

 

I'm not certain, but I suspect the different keys could be linked to one being Home and the other Pro.  Again I'm just guessing, but the name suggests that access was blocked because the share lacked a password.  I guess it's a security thing, but it's kind of an unexpected default setting.  I wonder what GUI setting this is associated with.  I don't recall ever seeing a windows setting to block access to open servers.  I don't even want to test and see how much frustration I could have saved myself if I had simply secured the share and set a password from the start.

 

This worked for me.

 

Very new to all of this, im not in IT and only became interested after binge watching you tube tech videos. Most of the troubleshooting was going over my head. I dont have a clue why this works or what the registory editor does, but now I can access my shares.

 

Thanks

Link to post
  • 6 months later...

My UNRAID server corrupted a vm a couple of days ago and I had to wipe that vm (i have 2 windows 10 vm's)

Once I'd finished setting up the vm I noticed one of my shares had become inaccessible after some tinkering it became intermittently accessible. I'd been pulling my hair out for hours.

I noticed it was only 1 share that was effected and it was the same on both vm's and my phone.

 

I stopped any docker that might use the share, then I renamed the effected share and set up a new share to replace it (making sure it was on the same harddisk to avoid long file transfer)

Then I used dolphin in docker to move all the files across (9tb on a 12tb drive took about 30 seconds) after that I checked everything had moved and deleted the broken share and restarted my docker apps

Link to post
  • 2 weeks later...

FWIW For anyone like me who spontaneously could no longer see your Tower on your local network from within a Windows 10 VM on the Tower, I poked around after reading through this thread and found that SMB 1.0 had been turned off, presumably by an update around November 10, 2020. All the other machines on my local LAN could see the Tower fine. 

I turned it back on and the Tower reappeared in my Network Places.

 

The blame doesn't appear to be with Lime Tech but with MSFT monkeying around with network settings in updates I hope that Lime Tech will put a permanent fix for this Windows issue in a future update.

Thanks.

SMB1.0 Capture.JPG

Link to post
34 minutes ago, MikeGNola said:

The blame doesn't appear to be with Lime Tech but with MSFT monkeying around with network settings in updates I hope that Lime Tech will put a permanent fix for this Windows issue in a future update.

The permanent fix for this issue is already in unRAID.  It's called WS Discovery (In SMB settings) and is Microsoft's replacement for network discovery that does not rely on SMB 1.0.  Microsoft has been trying to get rid of SMB 1.0 for years due to security issues and they will likely continue to disable it by default before eventually dumping it all together. 

 

I have completely disabled SMB 1.0 support on all  my WIndows machines and unRAID ever since unRAID began to support WSD many months ago in version 6.8.0.  It seems to work great and no more problems with SMB 1.0.

 

Here are the unRAID settings I currently have for WSD (disabling NetBIOS turns off SMB 1.0 support on unRAID):

image.thumb.png.429db9c39e800d0d47f33ea74310d332.png

Edited by Hoopster
Link to post
2 hours ago, Hoopster said:

The permanent fix for this issue is already in unRAID.  It's called WS Discovery (In SMB settings) and is Microsoft's replacement for network discovery that does not rely on SMB 1.0.  Microsoft has been trying to get rid of SMB 1.0 for years due to security issues and they will likely continue to disable it by default before eventually dumping it all together. 

 

I have completely disabled SMB 1.0 support on all  my WIndows machines and unRAID ever since unRAID began to support WSD many months ago in version 6.8.0.  It seems to work great and no more problems with SMB 1.0.

 

Here are the unRAID settings I currently have for WSD (disabling NetBIOS turns off SMB 1.0 support on unRAID):

image.thumb.png.429db9c39e800d0d47f33ea74310d332.png

Thanks! where'd you get the info on what to put for the WSD options? 

 

 

Strangely my array was fine - but started doing this after I started using rclone - i thought it was related to my NIC. but seems to be OK when I use IP address. 

Link to post
1 hour ago, axeman said:

where'd you get the info on what to put for the WSD options?

The WSD daemon (wsdd) is not perfect and every once in a while, it decides to peg one CPU at 100%.  That option was suggested in the troubleshooting thread on the matter as a way to minimize the issue.  It has done so for me and my server will go for months at a time without wsdd taking over a CPU.

Link to post

I'm unable to access any of my shares from a Windows 10 computer that updated last night -- worked fine before that.

I know about SMB1 (active) and Allowing Guest Logins in group policy (Enabled). Turn off-password protection is set to off. So the obvious issues are covered. 

I have noth NetBIOS and WSD enabled on both unraid machines.

I can access shares from other computers that did not update.

I can ping the unraid machines and they respond

Any suggestions?

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.