Windows 10 SMB Share issues


Recommended Posts

18 minutes ago, Naldinho said:

I'm unable to access any of my shares from a Windows 10 computer that updated last night -- worked fine before that.

I know about SMB1 (active) and Allowing Guest Logins in group policy (Enabled). Turn off-password protection is set to off. So the obvious issues are covered. 

I have noth NetBIOS and WSD enabled on both unraid machines.

I can access shares from other computers that did not update.

I can ping the unraid machines and they respond

Any suggestions?

Problem resolved -- If anyone ends up here with a similar issue the solution was to Allow Guest Logins in the registry. Despite this being allowed in Group Policy the value in the registry was set to zero. Changing that to one fixed the issue.

I'm confused as to why Windows has two independent ways to set this and why changing it in group policy doesn't automatically alter the registry edit but whatever it works now.

Link to comment
2 hours ago, Naldinho said:

I'm confused as to why Windows has two independent ways to set this and why changing it in group policy doesn't automatically alter the registry edit but whatever it works now.

I believe it has something to do with the class of Windows10 (Home, Pro, etc.) that you are running.  I seem to recall that the group policy editor does not work with certain classes.  (That's what makes SMB issues so much frustrating to try and solve.  What works for one person doesn't work for the next person!)

Link to comment
  • 2 months later...

I'm having the same issue 😔.

 

I tried this:

Quote

add the new key HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters\AllowInsecureGuestAuth key, value set to 1

It's interesting to know one of my other computers that works doesn't have this key, but it has "AuditSmb1Access" which set to 0, which this computer doesn't have.

 

Turning WSD support on

 

Making share SMB 1.0 is turned on in windows features.

 

Following this:

Quote

You can change this setting within your group policy settings.

Right click the Windows Icon at the bottom left of the task bar, or select the windows key + r

Within the run box, type “gpedit.msc”

Within the local Group Policy Editor, select “Administrative Templates”

Select “Network”

Select ”Lanman Workstation”

Double click “Enable Insecure guest logons” option

Tick the “Enable” option

Select OK

 

 

I am at a complete loss. I just cannot get windows to connect to Unraid 😔.

 

I have zero problem on my mac and only the usual Linux problems on my Ubuntu machine, but it does occasionally work. I'm starting to think that Unraid is just incompatible with windows.

 

 

 

 

Link to comment
1 hour ago, Richard J said:

have zero problem on my mac and only the usual Linux problems on my Ubuntu machine, but it does occasionally work. I'm starting to think that Unraid is just incompatible with windows.

 

The problem is almost always on the Windows end of the equation.  (A vast majority of the Unraid users are using SMB with Win10 successfully.)  Which version and class (home, pro, etc.) of Windows are you running?  (Run    winver      to find out.)  MS seems to have done something with version 20H2 that has stumped several people at this point.   (Someone will figure it out one of these days...)  

 

I would suggest that you start at the end of this thread and work your way backwards through it.  Be sure to check everything out.  (I seem to recall that Edit Group Policy is not available in all versions of Windows 10 so you may have to skip those when you come on those changes.)

 

     https://forums.unraid.net/topic/89452-windows-issues-with-unraid/

 

Be sure you have done these items:

 

     https://forums.unraid.net/topic/89452-windows-issues-with-unraid/page/8/?tab=comments#comment-906535

 

Link to comment
  • 2 weeks later...
On 9/25/2018 at 3:18 PM, jkBuckethead said:

I've been down some crazy rabbit holes with windows before, but this one really takes the cake.  A little googling, and you quickly see that tons and tons of people have experienced this particular error.   There are dozens upon dozens of potential solutions, ranging from simple to extremely complicated and everything in between.  Reading posts of people's results couldn't be more random.  For every person that is helped by a particular solution, there are twenty people for whom it didn't work.  I myself had tried about a dozen of the best sure-fire fixes without any success.

 

I really didn't have much hope, but I took a look at the post linked above.  The thread started in August of 2015.  One common thread in error 0x80070035 posts is the 1803 windows 10 update so I decided to jump ahead to the end of the thread.  Low and behold, on page 5, the first post I read struck a chord for some reason.  Even though I was quite tired of trying random things without success, I decided to give this registry edit a try.  As soon as I added the key below I was able to access the unraid server.  I didn't even have to reboot.  HALLELUJAH!!!!

 

Try: (Solution)

https://www.schkerke.com/wps/2015/06/windows-10-unable-to-connect-to-samba-shares/

Basically the solution follows, but you'll need to use regedit:

add the new key HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters\AllowInsecureGuestAuth key, value set to 1

It's interesting to know one of my other computers that works doesn't have this key, but it has "AuditSmb1Access" which set to 0, which this computer doesn't have.  

 

I checked one of windows 10 home machines, and like the post above it does not have the AllowInsecureGuestAuth key, but does have the AuditSmb1Access key set to 0.  My windows 10 pro machine, the one the could not access my unraid server, had the AllowInsecureGuestAuth set to 0.  Setting this to 1 appears to have fixed my problem.

 

I'm not certain, but I suspect the different keys could be linked to one being Home and the other Pro.  Again I'm just guessing, but the name suggests that access was blocked because the share lacked a password.  I guess it's a security thing, but it's kind of an unexpected default setting.  I wonder what GUI setting this is associated with.  I don't recall ever seeing a windows setting to block access to open servers.  I don't even want to test and see how much frustration I could have saved myself if I had simply secured the share and set a password from the start.

 

 

Just got a brand new laptop running Windows 10 Pro and I can confirm that this registry change still fixes the issue.

Link to comment
On 1/27/2021 at 12:01 AM, Frank1940 said:

 

Type   winver   and tell us which version of Windows 10 Pro you have ---  2004 or 20H2

 

My new laptop has 1909 - I haven't updated to 20H2 yet.

 

I did a rebuild of my old laptop for use by my son and that didn't have any problems accessing Unraid - it's running 2004

 

Should I take this to mean that the issue has been fixed in 2004? Or is this just another Windows 10 quirk where some machines have issues while others don't ?

Link to comment
3 hours ago, SimonHampel said:

Should I take this to mean that the issue has been fixed in 2004? Or is this just another Windows 10 quirk where some machines have issues while others don't ?

No to the first question and Yes to the second.   MS usually manages to break something for somebody with every 'feature' update!  Right now, some folks are having a real issue with 20H2 and SMB.  I don't think it is everybody but it is a fair percentage.  That was the reason for the question.  It would be nice to hear from some folks who are using 20H2 and not having an issue with SMB.  I have locked myself onto 2004 for the present...

 

(When I did a 'feature' update a while back, I had a case where MS reversed some settings that I had made to allow me to use SMB in the way that I wanted to use it. Some 'security issue' that they thought I absolutely needed.  I had to go back and change some settings to get things working again.   Things like that don't make for a bunch of "happy campers"...) 

Link to comment
5 minutes ago, Frank1940 said:

Right now, some folks are having a real issue with 20H2 and SMB.  I don't think it is everybody but it is a fair percentage.  That was the reason for the question.  It would be nice to hear from some folks who are using 20H2 and not having an issue with SMB.  I have locked myself onto 2004 for the present...

 

Glad to hear I wasn't being silly by delaying the optional update to 20H2!

 

Right now things are working the way I need them, so I'm not going to push to the latest versions until I actually need to.

Link to comment
5 hours ago, Frank1940 said:

It would be nice to hear from some folks who are using 20H2 and not having an issue with SMB.

For the record I am using 20H2 and not encountering SMB issues.  
 

All my shares are, though, set to ‘Public’ so not sure if trying to switch to higher security might cause an issue.    Also I have no Unraid shares that are mapped to drive letters so no automatic connects from Windows - I use UNC type paths whenever I need to connect to an Unraid share.

Link to comment

Hey guys.

 

Thank you for your thoughts. First of all I found a solution. When navigating to the map network drive prompt (this pc>map network drive) I had been using the "Browse..." button to try to find my share. That is when I was getting the error message. Typing in the IP address of the server then /path allowed me to connect!

 

I'm not a Windows user really, I just have use it for a piece of exam related software (thank you covid). I set up access my shares on the mac by browsing the GUI and on Ubuntu by typing the IP and path. It never occurred to me that windows would have such a problem with the browse function until I watched a Spaceinvader One video (what a legend). He didn't use the "Browse..." button but typed out the path and recommended using an IP address rather than the server's name.

 

FYI, I am using Windows 10 Pro 20H2 (not a VM). I had a lot of issues getting my exam software to run smoothly and had to update to get it working. I have a few windows VM's scattered across my PC's and ran into the same problem, with the same solution.

 

Once again, Big thanks.

 

Richard

 

Edited by Richard J
Grammar
  • Thanks 1
Link to comment
On 9/24/2018 at 11:18 PM, jkBuckethead said:

 

Try: (Solution)

https://www.schkerke.com/wps/2015/06/windows-10-unable-to-connect-to-samba-shares/

Basically the solution follows, but you'll need to use regedit:

add the new key HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters\AllowInsecureGuestAuth key, value set to 1

It's interesting to know one of my other computers that works doesn't have this key, but it has "AuditSmb1Access" which set to 0, which this computer doesn't have.  

 

 

 

 

Wanted to bump this up, after a ton of searches this was what fixed my issue.  I had never edited a registry before, so I used this website to walk through it.  It's easy after you read the article on what you are doing.

 

https://www.lifewire.com/how-to-add-change-delete-registry-keys-values-2625145

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.