Jump to content
Sign in to follow this  
LeoMonkey

Do this system have any plugin for using Shadowsocks?

6 posts in this topic Last Reply

Recommended Posts

Hi, I am a beginner for the unraid, this a awesome system, which give me lots of fun.

 

    However, I met a problem when I using it and I can't find solution.

 

    The situation is, I live in China, which didn't effect me when daily using this system. But, when the new version of unraid comes, and I tried to upgrade it, it seems the Update Package was refused by GFW and the system can't upgrade by itself. Also, I didn't find the way to upgrade manually or change the mirror address to the local place.

 

    So I am thinking about, can I let unraid connect to VPS by shadowsocks or openvpn. I do know how to build a VPS server, which has lots of way in internet. However, I didn't find the way to set a VPN client in unraid, almost all are talking set VPN server, which is not my purpose.

 

    I do find a plugin called OpenVPN client, which provided by peter_sm. But for some reasons that I don't know, I have seem nothing after I download it, the plugin in the Settings just don't works.

 

    So I am looking for your guys' help, do anybody has way to fix my problem?

Thank you

Edited by LeoMonkey

Share this post


Link to post

You can always do a manual upgrade by downloading the zip file of the release and then copy all the bz* files from the zip to the root of the USB stick.

Share this post


Link to post
7 hours ago, itimpi said:

You can always do a manual upgrade by downloading the zip file of the release and then copy all the bz* files from the zip to the root of the USB stick.

So just replace all the files that named as "bz" in the front? Is this method still working when they have a great upgrade, like to 6.6.0.

    By the way I still need my unraid use proxy at sometimes, please let me know if you have ideas how to do that.

 

Thank you.

Edited by LeoMonkey

Share this post


Link to post
4 hours ago, LeoMonkey said:

So just replace all the files that named as "bz" in the front? Is this method still working when they have a great upgrade, like to 6.6.0.

    By the way I still need my unraid use proxy at sometimes, please let me know if you have ideas how to do that.

 

Thank you.

Yes, replacing the bz* files still works.   It is possible a new release might have additional bz* type files but if so make sure that you copy all of them over.  It is always recommended you make a backup of the existing contents before doing so to give you the (hopefully not needed) ability to revert to the previous release.

 

No idea about the proxy - that is not something I personally have any experience of.   Hopefully one of the networking experts will chime in on that.

Edited by itimpi

Share this post


Link to post
11 hours ago, itimpi said:

Yes, replacing the bz* files still works.   It is possible a new release might have additional bz* type files but if so make sure that you copy all of them over.  It is always recommended you make a backup of the existing contents before doing so to give you the (hopefully not needed) ability to revert to the previous release.

 

No idea about the proxy - that is not something I personally have any experience of.   Hopefully one of the networking experts will chime in on that.

Thank you. I am finally successful.

Actually I met some problem when I do it.

At first time, I copy the bz* file to the flash by smb share, and then reboot my NAS. however, I can't connect it again.

After I take the flash driver to my computer, it seems have some strange file in this driver, like called "KEK", "FSCK0000.REC".

So I rebulid this flash drvier to the latest version, replace the "config" from before, it works.

I guess it is because I have tried to use a docker called "binhex-krusader" edited my flash drive, and it made some wrong file in it.

Share this post


Link to post
27 minutes ago, LeoMonkey said:

Thank you. I am finally successful.

Actually I met some problem when I do it.

At first time, I copy the bz* file to the flash by smb share, and then reboot my NAS. however, I can't connect it again.

After I take the flash driver to my computer, it seems have some strange file in this driver, like called "KEK", "FSCK0000.REC".

So I rebulid this flash drvier to the latest version, replace the "config" from before, it works.

I guess it is because I have tried to use a docker called "binhex-krusader" edited my flash drive, and it made some wrong file in it.

The FSCK* file means file system corruption was detected on the USB drive.

Edited by itimpi

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this