Jump to content

Can I access drives without starting array?


RichardU

Recommended Posts

My USB device just failed. I'm using CA Backup/Restore Appdata so I should have a backup of the USB in /mnt/user/Backup/CA Backups/flashdrive. I can start the machine with a generic installation on a new USB device but then none of the drives are accessible.

 

So what is the best way to access /mnt/user/Backup/CA Backups/flashdrive ? I don't know my configuration, so I don't want to start the array without knowing what I'm doing.

 

Any ideas?

 

Thanks, Richard

 

Also, I just replaced my original USB device with a "new, better" one (that has now failed), so it's been there less than a year. I sent an email to unraid.

Link to comment

Thanks, johnnie.black

 

The directions from the other post are below. I tried this by opening a Terminal through the GUI, and created the directory with no problem. My drives are: sdh, sdi, sdj, sdk etc. However, when I try to mount any of them (e.g.  mount -o ro /dev/sdj /x) I get this:
 

mount: /x: wrong fs type, bad option, bad superblock on /dev/sdg, missing codepage or helper program, or other error.

 

I looked up this error, but didn't see any solutions outside of working within the array.

 

Any ideas? Or, would it make sense to throw a new drive in the system, and create an array with one drive and no parity, so I could explore the other drives using Unassigned disks?

 

Richard

 

Quote

 

With the array stopped first create a mount point, e.g.:

 


mkdir /x

 

then mount a disk read only:


mount -o ro /dev/sdX1 /x

Replace X with the correct letter, you can then browse /x using the console or e.g. midnight commander and safely check the disk contents.

 

1

 

Link to comment

Is the original flash completely trashed?  If not, there's a file on it called DISK_ASSIGNMENTS.txt in the config folder.  Load that file up in Notepad or something, start the server with the new flash, get a trial key, Assign the drives as per the text file,  Then you'll be able to access all your shares etc normally, and can restore the contents of the config on the flash from the backup on the array.

 

Personally, I have the USB backup destination going to a share on another computer on my network

Link to comment

For future reference, you can always download a zipped backup of your flash from Main - Boot Device - Flash - Flash Backup. Not as automatic as CA Backup of course. You should always get a new backup anytime you make configuration changes, but especially if you make any changes to the assigned disks.

 

It would be good to know more about the USB failure. If it isn't truly dead but just not working right now to boot unRAID or whatever, it would be simpler to keep using it so you don't have to do a license transfer.

 

If you still have problems getting your USB backup be sure to come back for more help on how to get going again. Things could turn out very badly if you assign the disk wrongly for example. See this other recent thread:

 

https://forums.unraid.net/topic/73908-its-all-broken-d/

 

Link to comment

Thanks turl, and thanks again to johnnie.black. The USB is well and truly dead (Sandisk Cruzer Ultra Fit USB 3.1 16GB). It will not be recognized by at least four computers. I reported it to Sandisk, and they sent me a postage paid label for replacement.

 

I replaced the USB with a Cruzer Fit (not Ultra) and put it in a USB 2 slot. I think I read somewhere they run cooler. Everything is back running fine now.

 

This is a case of no good deed going unpunished. My previous USB worked fine for 8 years, but it was big and over 8 years old so I thought I would wisely replace it with a fancy new low-profile USB. Worse, I put the same model new USB on my other unRaid server. Now I'm waiting for that one to fail. 

 

 

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...