Intel Fiber NIC Issues


Recommended Posts

Hi Everyone,


I have a PCI Intel 82599ES dual 10G fiber NIC installed in my UnRaid server along with the dual ethernet ports on my motherboard. They are bonded together under balance-alb (6) method. The two motherboard ethernet ports work well and that's how I use the server now, however when connecting the two fiber ports to my switch, they show "Not Connected" status in the UnRaid dashboard, despite my switch claiming two 10G devices are plugged into it.


The NIC is detected under Tool -> System Devices page, and the two ports are assigned ethernet addresses "eth0" and "eth1".

[8086:10fb]	01:00.0 Ethernet controller: Intel Corporation 82599ES 10-Gigabit SFI/SFP+ Network Connection (rev 01)
[8086:10fb]	01:00.1 Ethernet controller: Intel Corporation 82599ES 10-Gigabit SFI/SFP+ Network Connection (rev 01)

Any clue as to why they wouldn't connect? I'd love the extra bandwidth!

Link to comment
  • 1 month later...

I attempted to try some different configurations as follows:

  • Disabled bonding, bridging enabled - No change to connectivity on the fiber NICs, they still show as "Not Connected" in the UnRaid GUI as well as show no connection when running ifconfig. The switch still reports that the ports are plugged in at 10G speeds however.
  • Disabled bonding and bridging - This killed all connectivity to the server. I wasn't able to connect over network any more and had to boot in GUI mode to change my settings back.

  • Disabled bridging, bonding enabled - Same as always, no fiber NIC connection but still a working connection via my copper NIC.

I'm pretty stumped as to what could be causing these NICs to not get an IP/talk to the switch in some way. Maybe there are driver issues? Are there other settings that need changing?

Link to comment
  • 4 months later...

I found a solution and wanted to post the results for future users.


There were 2 issues with my setup.

1. UniFi 16XG doesn't support Intel Fiber SFP+ modules.

2. UnRaid needs re-configuring to allow the Intel NIC to use UniFi SFP+ modules.



1. Nothing you can do except buy compatible NICs and modules. I ended up using UniFi SFP+ 10G modules in my Intel NIC.

2. For this to work the following mods need to be made to the syslinux.conf file so that the NIC works with the non-Intel SFP+ modules.


Go to Main -> Boot -> Flash -> syslinux Configuration and change the UnRaid OS configuration to the following:

kernel /bzimage
append initrd=/bzroot ixgbe.allow_unsupported_sfp=1,1,1,1,1,1

Each 1 in the list represents a single NIC port, for me I put six of them since I have six NICs (4x 1G and 2x 10G).


I'm now able to get an IP and a 10G link from the switch to the server!

Edited by k2x8
  • Thanks 1
Link to comment
  • 1 year later...

I know this is an old post, so my apologies on the revival. But I wanted to say, THANK YOU @k2x8! I've been searching off and on for weeks trying to find an answer as to why UNRAID couldn't/wouldn't show the interfaces for my Intel 10G 2P X520. I knew the card worked since I could pass it through to VM's with no issues. It was just UNRAID that couldn't use it. I'd tried all the modules I had lying around (Dell, Cisco, UniFi, Axiom, 10GTek). 


After adding "ixgbe.allow_unsupported_sfp=1,1,1" to the syslinux configuration, I am now able to run utilize 10Gb.


Thank you again for not giving up and posting your answer once found! 

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.