Jump to content
ajax3712

Help compiling k10temp for lm-sensors (AMD)

17 posts in this topic Last Reply

Recommended Posts

Hello all,

 

Ran a sensors-detect (after installing perl via unMENU - Thanks!) and it came up with 2 issues: it87 and a note about pending AMD K10 thermal sensors.

 

I'm a little clueless regarding the it87 (the lm-sensors.org device wiki - http://www.lm-sensors.org/wiki/Devices) says that it was built-into the kernel since versions prior to unRAID's 2.6.32.9 kernel), but am close to the resolution of the K10 thermal sensors.

 

Since it appears that support for my CPUs' sensors was introduced in a later kernel than what unRAID is currently using (same lm-sensors device wiki url as before), I'm now working to get it running on my AMD X4 build, so that I can access more detailed information regarding my server's health.

 

To that end, I am in the process of building my own development environment, but that too is an experience for me, and is well, slow-going :).  So I was wondering in the mean time if someone would be kind enough to compile the k10temp kernel module using the source located here:

 

http://khali.linux-fr.org/devel/misc/k10temp/

 

thx!

 

Share this post


Link to post

and if that does not work, try spelling "modprobe"correctly in both the commands BubbaQ mentioned.    ;)

Share this post


Link to post

:)

 

I actually tried both.

 

No go:

 

root@AJs_Unraid:~# modprobe k8temp
FATAL: Module k8temp not found.
root@AJs_Unraid:~# modprobe k10temp
FATAL: Module k10temp not found.

 

I'm pretty sure I at least don't have k10temp, as it's supposed to have been included from 2.6.33+ of the kernel.  I was trying to compile it myself but ran into some issues that I suspected was because unRAID has been pared down, which was the reason for my request to see if anyone had some free time and could compile it for me :)

Share this post


Link to post
I'm pretty sure I at least don't have k10temp, as it's supposed to have been included from 2.6.33+ of the kernel.

 

Just because something is included in a generic stock Linux kernel, does not mean it is in the unRAID kernel... the unRAID kernel has a lot of stuff stripped out of it to save space.

 

did you try

 

modprobe it87

sensors

Share this post


Link to post

I've tried that as well:

 

root@AJs_Unraid:~# modprobe it87
FATAL: Module it87 not found.

 

sensors gives me:

No sensors found!
Make sure you loaded all the kernel drivers you need.
Try sensors-detect to find out which these are.

 

sensors-detect:
[#----cut here----
# Chip drivers
# Warning: the required module it87 is not currently installed
# on your system. For status of 2.6 kernel ports check
# http://www.lm-sensors.org/wiki/Devices. If driver is built
# into the kernel, or unavailable, comment out the following line.
modprobe it87
# no driver for AMD K10 thermal sensors yet
/usr/bin/sensors -s
#----cut here----

Share this post


Link to post

What version of unRAID are you running?

They do not exist in 5.0-beta2.

 

root@Tower2:~# modprobe it87

FATAL: Module it87 not found.

root@Tower2:~# modprobe k8temp

FATAL: Module k8temp not found

Share this post


Link to post
They do not exist in 5.0-beta2.

 

They are built into the kernel in 5.0-beta2.  They will be moved out and left as standalone modules in beta 3, according to Tom's prior post.

Share this post


Link to post

They do not exist in 5.0-beta2.

 

They are built into the kernel in 5.0-beta2.  They will be moved out and left as standalone modules in beta 3, according to Tom's prior post.

<ashamed>I did not look there</ashamed>

Share this post


Link to post

I'm sorry for the confusion, I should have stated this from the get-go.  I'm running:

 

unRAID 4.5.6

uname -r:

2.6.32.9-unRAID

 

The main additional things I've installed are:

PS3 Media Server

Air-Video (non-unMENU)

avahi

sabnzbd+sickbeard

--

Various unMENU packages

 

btw, this may be totally unrelated, but one of the reasons I thought that I needed a full dev install to compile was because while perusing some of the directories involved in compiling k10temp, I came across broken links.  I thought that was b/c unRAID pared away a lot of unnecessary files... For example, both:

 

/lib/modules/2.6.32.9-unRAID/build

and

/lib/modules/2.6.32.9-unRAID/source

 

appear red in my Mac OS X Terminal and 'cd'-ing to them gives me a "no such file or dir" error.  Is that normal?  Or did I somehow hose my install?

 

AND btw, thank you very much for you time & patience with this!

Share this post


Link to post

I guess the question is...

 

Would I be able to somehow add (k10temp) this functionality (or in the case of it87 add back in)?  Or would it require going through some hoops (e.g. compiling one's own kernel)?

 

thx

-alex

Share this post


Link to post

Make a new unRAID flash and use Beta-2.... and try booting Beta-2 and see what you get.

Share this post


Link to post

I will try that soon.  As funny as it sounds, although I have a spare license, I don't have a spare usb flash drive lying around.  :) I'll let you know as soon as I get it up and running...

 

thx again for the help!

 

Share this post


Link to post

You don't need a license... just boot it, no drives assigned, and telnet in and check the sensors.

Share this post


Link to post

I'm sorry, I don't have a spare usb flash (yah, i know...  you probably thought I wrote my last post incorrectly, but I was being serious - never saw the need with storage being cheap and me being around fast internet 95% of the time :)...).  So short of deleting my existing unRAID, I'll have to wait until I can get my hands on one.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now